summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-24 17:46:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-24 17:46:45 +0000
commit1911e73c72e3a7b12a6725bdfd061d60e46a1e66 (patch)
tree9f9db203e6d113aacfeeadcab08508546a436865 /sys-apps/file
parentVersion bumped; bug #90227. (diff)
downloadgentoo-2-1911e73c72e3a7b12a6725bdfd061d60e46a1e66.tar.gz
gentoo-2-1911e73c72e3a7b12a6725bdfd061d60e46a1e66.tar.bz2
gentoo-2-1911e73c72e3a7b12a6725bdfd061d60e46a1e66.zip
touchup mips patch to handle ABI too
(Portage version: 2.0.51.20)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-4.12.ebuild4
-rw-r--r--sys-apps/file/file-4.13.ebuild10
-rw-r--r--sys-apps/file/files/file-4.xx-mips-gentoo.patch (renamed from sys-apps/file/files/file-4.xx-mips-gentoo.diff)43
3 files changed, 42 insertions, 15 deletions
diff --git a/sys-apps/file/file-4.12.ebuild b/sys-apps/file/file-4.12.ebuild
index ce2d5054ca94..c96a72964715 100644
--- a/sys-apps/file/file-4.12.ebuild
+++ b/sys-apps/file/file-4.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.12.ebuild,v 1.13 2005/04/01 19:25:14 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.12.ebuild,v 1.14 2005/04/24 17:46:45 vapier Exp $
inherit flag-o-matic gnuconfig eutils distutils libtool toolchain-funcs
@@ -25,7 +25,7 @@ src_unpack() {
# This patch is for MIPS only. It slightly changes the 'file' output
# on MIPS machines to a specific format so that other programs can
# recognize things.
- use mips && epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
+ epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.patch
# The build process tries to run the compiled file ... not a good
# thing if file was cross compiled ;)
diff --git a/sys-apps/file/file-4.13.ebuild b/sys-apps/file/file-4.13.ebuild
index aa9114a72178..c4ab8335ada9 100644
--- a/sys-apps/file/file-4.13.ebuild
+++ b/sys-apps/file/file-4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.1 2005/04/01 19:25:14 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.2 2005/04/24 17:46:45 vapier Exp $
inherit flag-o-matic gnuconfig eutils distutils libtool toolchain-funcs
@@ -21,11 +21,9 @@ src_unpack() {
unpack ${A}
cd ${S}
- # (12 Oct 2003) <kumba@gentoo.org>
- # This patch is for MIPS only. It slightly changes the 'file' output
- # on MIPS machines to a specific format so that other programs can
- # recognize things.
- use mips && epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
+ # This tweaks the output format for mips binaries so things like
+ # libtool don't barf all over the place when trying to parse it.
+ epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.patch
# The build process tries to run the compiled file ... not a good
# thing if file was cross compiled ;)
diff --git a/sys-apps/file/files/file-4.xx-mips-gentoo.diff b/sys-apps/file/files/file-4.xx-mips-gentoo.patch
index 2ff6ae9a093a..fbc18409c7bc 100644
--- a/sys-apps/file/files/file-4.xx-mips-gentoo.diff
+++ b/sys-apps/file/files/file-4.xx-mips-gentoo.patch
@@ -1,7 +1,28 @@
-diff -Naurp file-4.05.orig/magic/Magdir/elf file-4.05/magic/Magdir/elf
---- file-4.05.orig/magic/Magdir/elf 2003-05-23 17:37:35.000000000 -0400
-+++ file-4.05/magic/Magdir/elf 2003-10-12 00:52:12.000000000 -0400
-@@ -23,10 +23,32 @@
+This tweaks the output format for mips binaries so things like
+libtool don't barf all over the place when trying to parse it.
+
+BEFORE: cat: ELF 32-bit N32 MSB MIPS-IV executable, MIPS, version 1 (SYSV), for GNU/Linux 2.4.0, dynamically linked (uses shared libs), stripped
+AFTER: cat: ELF 32-bit MSB executable, MIPS, N32 MIPS-IV version 1 (SYSV), for GNU/Linux 2.4.0, dynamically linked (uses shared libs), stripped
+
+Reference:
+http://lists.debian.org/debian-mips/2001/01/msg00065.html
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=83303
+
+--- magic/Magdir/elf
++++ magic/Magdir/elf
+@@ -11,22 +11,39 @@
+ 0 string \177ELF ELF
+ >4 byte 0 invalid class
+ >4 byte 1 32-bit
+-# only for MIPS - in the future, the ABI field of e_flags should be used.
+->>18 leshort 8
+->>>36 lelong &0x20 N32
+->>18 leshort 10
+->>>36 lelong &0x20 N32
+->>18 beshort 8
+->>>36 belong &0x20 N32
+->>18 beshort 10
+->>>36 belong &0x20 N32
>4 byte 2 64-bit
>5 byte 0 invalid byte order
>5 byte 1 LSB
@@ -32,10 +53,14 @@ diff -Naurp file-4.05.orig/magic/Magdir/elf file-4.05/magic/Magdir/elf
# say something if #10 is encountered, but only gory details for #8.
->>18 leshort 8
+>>18 leshort 8 MIPS,
++>>>36 lelong &0x20 N32
++>>18 leshort 10 MIPS,
++>>>36 lelong &0x20 N32
++>>18 leshort 8
# only for 32-bit
>>>4 byte 1
>>>>36 lelong&0xf0000000 0x00000000 MIPS-I
-@@ -49,29 +71,6 @@
+@@ -49,29 +66,6 @@
>>>>48 lelong&0xf0000000 0x70000000 MIPS64
>>>>48 lelong&0xf0000000 0x80000000 MIPS32 rel2
>>>>48 lelong&0xf0000000 0x90000000 MIPS64 rel2
@@ -65,7 +90,7 @@ diff -Naurp file-4.05.orig/magic/Magdir/elf file-4.05/magic/Magdir/elf
>>18 leshort 9 Amdahl - invalid byte order,
>>18 leshort 10 MIPS (deprecated),
>>18 leshort 11 RS6000 - invalid byte order,
-@@ -110,8 +109,27 @@
+@@ -111,8 +105,31 @@
>>20 lelong 1 version 1
>>36 lelong 1 MathCoPro/FPU/MAU Required
>5 byte 2 MSB
@@ -91,10 +116,14 @@ diff -Naurp file-4.05.orig/magic/Magdir/elf file-4.05/magic/Magdir/elf
# only for MIPS - see comment in little-endian section above.
->>18 beshort 8
+>>18 beshort 8 MIPS,
++>>>36 belong &0x20 N32
++>>18 beshort 10 MIPS,
++>>>36 belong &0x20 N32
++>>18 beshort 8
# only for 32-bit
>>>4 byte 1
>>>>36 belong&0xf0000000 0x00000000 MIPS-I
-@@ -134,26 +152,6 @@
+@@ -135,26 +152,6 @@
>>>>48 belong&0xf0000000 0x70000000 MIPS64
>>>>48 belong&0xf0000000 0x80000000 MIPS32 rel2
>>>>48 belong&0xf0000000 0x90000000 MIPS64 rel2