summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:22:32 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:22:32 +0000
commitd1e78a66a1d4dfc337476dfd2ef80cb832fcf27c (patch)
treed7d013a27eea83028cbbf58f40b2651bdb8dc728 /sys-apps/entropy
parent2.2.0_alpha86 version bump. This includes all of the fixes in (diff)
downloadgentoo-2-d1e78a66a1d4dfc337476dfd2ef80cb832fcf27c.tar.gz
gentoo-2-d1e78a66a1d4dfc337476dfd2ef80cb832fcf27c.tar.bz2
gentoo-2-d1e78a66a1d4dfc337476dfd2ef80cb832fcf27c.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/entropy')
-rw-r--r--sys-apps/entropy/ChangeLog9
-rw-r--r--sys-apps/entropy/entropy-1.0_rc87.ebuild87
2 files changed, 94 insertions, 2 deletions
diff --git a/sys-apps/entropy/ChangeLog b/sys-apps/entropy/ChangeLog
index 6c051f4ab891..93c2ceebfa78 100644
--- a/sys-apps/entropy/ChangeLog
+++ b/sys-apps/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.18 2011/12/22 17:49:28 lxnay Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.19 2012/02/12 07:22:32 lxnay Exp $
+
+*entropy-1.0_rc87 (12 Feb 2012)
+
+ 12 Feb 2012; Fabio Erculiani <lxnay@gentoo.org> +entropy-1.0_rc87.ebuild:
+ version bump
*entropy-1.0_rc80 (22 Dec 2011)
diff --git a/sys-apps/entropy/entropy-1.0_rc87.ebuild b/sys-apps/entropy/entropy-1.0_rc87.ebuild
new file mode 100644
index 000000000000..39bb75ea1900
--- /dev/null
+++ b/sys-apps/entropy/entropy-1.0_rc87.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/entropy-1.0_rc87.ebuild,v 1.1 2012/02/12 07:22:32 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND="dev-db/sqlite[soundex]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+REPO_D_CONFPATH="${ROOT}/etc/entropy/repositories.conf.d"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_compile() {
+ cd "${S}"/misc/po || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" entropy-install || die "make install failed"
+ cd "${S}"/misc/po || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+}
+
+pkg_postinst() {
+ for ex_conf in "${REPO_D_CONFPATH}"/_entropy_sabayon-limbo.example; do
+ real_conf="${ex_conf%.example}"
+ if [ -f "${real_conf}" ] || [ -f "${real_conf/_}" ]; then
+ # skip installation then
+ continue
+ fi
+ elog "Installing: ${real_conf}"
+ cp "${ex_conf}" "${real_conf}" -p
+ done
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ elog "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ python_mod_optimize "/usr/lib/entropy/lib/entropy"
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/lib/entropy"
+}