summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-08-12 09:29:11 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-08-12 09:29:11 +0000
commit505c563f978c75ac9dbf80f5b23ee57d4ba03c99 (patch)
tree09154bd268e670a5b47fe371318e8ff42667eca5 /sys-apps/entropy
parentdrop selinux patch, no longer needed, close bug 378661 (diff)
downloadgentoo-2-505c563f978c75ac9dbf80f5b23ee57d4ba03c99.tar.gz
gentoo-2-505c563f978c75ac9dbf80f5b23ee57d4ba03c99.tar.bz2
gentoo-2-505c563f978c75ac9dbf80f5b23ee57d4ba03c99.zip
version bump
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/entropy')
-rw-r--r--sys-apps/entropy/ChangeLog7
-rw-r--r--sys-apps/entropy/entropy-1.0_rc38.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sys-apps/entropy/ChangeLog b/sys-apps/entropy/ChangeLog
index 362b021e196d..33126514e030 100644
--- a/sys-apps/entropy/ChangeLog
+++ b/sys-apps/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.5 2011/08/11 11:27:52 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.6 2011/08/12 09:29:11 lxnay Exp $
+
+*entropy-1.0_rc38 (12 Aug 2011)
+
+ 12 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> +entropy-1.0_rc38.ebuild:
+ version bump
*entropy-1.0_rc37 (11 Aug 2011)
diff --git a/sys-apps/entropy/entropy-1.0_rc38.ebuild b/sys-apps/entropy/entropy-1.0_rc38.ebuild
new file mode 100644
index 000000000000..462b30ce26b1
--- /dev/null
+++ b/sys-apps/entropy/entropy-1.0_rc38.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/entropy-1.0_rc38.ebuild,v 1.1 2011/08/12 09:29:11 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND="dev-db/sqlite[soundex]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_compile() {
+ # TODO: move to separate package
+ cd "${S}"/misc/po || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" entropy-install || die "make install failed"
+
+ # TODO: move to separate package
+ cd "${S}"/misc/po || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+}
+
+pkg_postinst() {
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ einfo "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ python_mod_optimize "/usr/lib/entropy/libraries/entropy"
+
+ # force python 2.x
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/libraries/entropy"
+}