summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-09 14:30:01 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-10-09 14:30:01 +0000
commite0fb5e8e4d941d21d3aabda06dd35e47969e5028 (patch)
tree742221bf1f5c4881d384ea3e23bfce649b88600e /sys-apps/elfix
parentStable on amd64 wrt bug #386135 (diff)
downloadgentoo-2-e0fb5e8e4d941d21d3aabda06dd35e47969e5028.tar.gz
gentoo-2-e0fb5e8e4d941d21d3aabda06dd35e47969e5028.tar.bz2
gentoo-2-e0fb5e8e4d941d21d3aabda06dd35e47969e5028.zip
Bump, moves utils to /usr/bin/sbin and adds revdep-pax
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/ChangeLog5
-rw-r--r--sys-apps/elfix/elfix-0.2.3.ebuild29
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index fa8ff84d6e67..df68609a592c 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,5 +1,10 @@
+*elfix-0.2.3 (09 Oct 2011)
+
+ 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +elfix-0.2.3.ebuild:
+ Bump, moves utils to /usr/bin/sbin and adds revdep-pax
+
*elfix-0.2.2 (03 Oct 2011)
03 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -elfix-0.2.1.ebuild,
diff --git a/sys-apps/elfix/elfix-0.2.3.ebuild b/sys-apps/elfix/elfix-0.2.3.ebuild
new file mode 100644
index 000000000000..a1ac678ce6c3
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.2.3.ebuild,v 1.1 2011/10/09 14:30:01 blueness Exp $
+
+EAPI=4
+
+DESCRIPTION="Tools to fix ELF binaries to work on Hardened Gentoo"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-libs/elfutils
+ dev-python/pypax
+ test? ( dev-lang/yasm )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}