summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-27 03:29:51 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-27 03:29:51 +0000
commitc4aa52d3d8bb69b20ccf50f244ef194bce25b89a (patch)
treeccc60f4628afdb4f5b5438197d6dc59b1a134a39 /sys-apps/elfix
parentBuild in the source tree. (diff)
downloadgentoo-2-c4aa52d3d8bb69b20ccf50f244ef194bce25b89a.tar.gz
gentoo-2-c4aa52d3d8bb69b20ccf50f244ef194bce25b89a.tar.bz2
gentoo-2-c4aa52d3d8bb69b20ccf50f244ef194bce25b89a.zip
Version bump, makes XT_PAX support optional
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/ChangeLog6
-rw-r--r--sys-apps/elfix/elfix-0.4.0.ebuild29
-rw-r--r--sys-apps/elfix/metadata.xml3
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 7a289c001412..cba51f66e0c2 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,5 +1,11 @@
+*elfix-0.4.0 (27 Nov 2011)
+
+ 27 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +elfix-0.4.0.ebuild,
+ metadata.xml:
+ Version bump, makes XT_PAX support optional
+
27 Nov 2011; Anthony G. Basile <blueness@gentoo.org> elfix-0.3.2.ebuild:
Force dependency on =dev-python/pypax-0.3*
diff --git a/sys-apps/elfix/elfix-0.4.0.ebuild b/sys-apps/elfix/elfix-0.4.0.ebuild
new file mode 100644
index 000000000000..dae7ffaaa139
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.4.0.ebuild,v 1.1 2011/11/27 03:29:51 blueness Exp $
+
+EAPI=4
+
+DESCRIPTION="Tools to fix ELF binaries to work on Hardened Gentoo"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test xtpax"
+
+DEPEND="dev-libs/elfutils
+ =dev-python/pypax-0.4*[xtpax=]
+ test? ( dev-lang/yasm )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}
diff --git a/sys-apps/elfix/metadata.xml b/sys-apps/elfix/metadata.xml
index e217c3733475..f89466575fc6 100644
--- a/sys-apps/elfix/metadata.xml
+++ b/sys-apps/elfix/metadata.xml
@@ -6,4 +6,7 @@
<email>blueness@gentoo.org</email>
<name>Anthony G. Basile</name>
</maintainer>
+ <use>
+ <flag name='xtpax'>Enable XT_PAX and prefer it to PT_PAX.</flag>
+ </use>
</pkgmetadata>