summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-10-06 17:37:26 +0000
committerMike Frysinger <vapier@gentoo.org>2007-10-06 17:37:26 +0000
commitcd64d9e257579f11a71066a9a1adbdb9a2ff6c46 (patch)
tree2971eab02f807fd46e7fecd7ec25c6bdadc814c7 /sys-apps/einit
parentFix tramp-make-tramp-temp-file vulnerability, bug #194713. (diff)
downloadgentoo-2-cd64d9e257579f11a71066a9a1adbdb9a2ff6c46.tar.gz
gentoo-2-cd64d9e257579f11a71066a9a1adbdb9a2ff6c46.tar.bz2
gentoo-2-cd64d9e257579f11a71066a9a1adbdb9a2ff6c46.zip
Version bump.
(Portage version: 2.1.3.11)
Diffstat (limited to 'sys-apps/einit')
-rw-r--r--sys-apps/einit/ChangeLog7
-rw-r--r--sys-apps/einit/einit-0.25.0.ebuild45
-rw-r--r--sys-apps/einit/files/digest-einit-0.25.03
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-apps/einit/ChangeLog b/sys-apps/einit/ChangeLog
index d28ea934605e..135f4f680545 100644
--- a/sys-apps/einit/ChangeLog
+++ b/sys-apps/einit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/einit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/einit/ChangeLog,v 1.5 2007/10/06 13:27:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/einit/ChangeLog,v 1.6 2007/10/06 17:37:25 vapier Exp $
+
+*einit-0.25.0 (06 Oct 2007)
+
+ 06 Oct 2007; Mike Frysinger <vapier@gentoo.org> +einit-0.25.0.ebuild:
+ Version bump.
*einit-0.24.3 (06 Oct 2007)
diff --git a/sys-apps/einit/einit-0.25.0.ebuild b/sys-apps/einit/einit-0.25.0.ebuild
new file mode 100644
index 000000000000..f1ddbaa7588b
--- /dev/null
+++ b/sys-apps/einit/einit-0.25.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/einit/einit-0.25.0.ebuild,v 1.1 2007/10/06 17:37:25 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="an alternate /sbin/init"
+HOMEPAGE="http://einit.org/"
+SRC_URI="mirror://berlios/einit/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ --enable-linux \
+ --use-posix-regex \
+ --prefix=/ \
+ --libdir-name=$(get_libdir) \
+ || die
+ emake || die
+ if use doc ; then
+ emake documentation-html ||die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ doman documentation/man/*
+ if use doc ; then
+ dohtml build/documentation/html/*.html
+ fi
+}
+
+pkg_postinst() {
+ einfo "You can always find the latest documentation at"
+ einfo "http://einit.sourceforge.net/documentation/users/"
+}
diff --git a/sys-apps/einit/files/digest-einit-0.25.0 b/sys-apps/einit/files/digest-einit-0.25.0
new file mode 100644
index 000000000000..b9d30b23a04b
--- /dev/null
+++ b/sys-apps/einit/files/digest-einit-0.25.0
@@ -0,0 +1,3 @@
+MD5 0ba94955a8205e0a0fa56baaf98b0c89 einit-0.25.0.tar.bz2 291602
+RMD160 07336f165e3ec5228f9fe78047b6f0300e0ae1d5 einit-0.25.0.tar.bz2 291602
+SHA256 693ce304230231aadcd0b89ea72fc557a937f4af5f626a14f6b0d938363d4cc5 einit-0.25.0.tar.bz2 291602