summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-27 16:04:59 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-27 16:04:59 +0000
commit9c5016407ca53d262dbaa40cf1b31b566b347948 (patch)
tree29cb2e8b1bd100466f556ed4d2a88d5726d6d71e /sys-apps/dstat
parentStabilize for everyone. (diff)
downloadgentoo-2-9c5016407ca53d262dbaa40cf1b31b566b347948.tar.gz
gentoo-2-9c5016407ca53d262dbaa40cf1b31b566b347948.tar.bz2
gentoo-2-9c5016407ca53d262dbaa40cf1b31b566b347948.zip
sys-apps/dstat: Bump EAPI to 4 to use mod_optimize on non multi ABI installs, #413745
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dstat')
-rw-r--r--sys-apps/dstat/ChangeLog6
-rw-r--r--sys-apps/dstat/dstat-0.6.9-r1.ebuild12
-rw-r--r--sys-apps/dstat/dstat-0.7.2-r1.ebuild12
3 files changed, 17 insertions, 13 deletions
diff --git a/sys-apps/dstat/ChangeLog b/sys-apps/dstat/ChangeLog
index bebab4853e85..603cf5e25d79 100644
--- a/sys-apps/dstat/ChangeLog
+++ b/sys-apps/dstat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/dstat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.38 2012/01/02 13:58:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.39 2012/04/27 16:04:59 jlec Exp $
+
+ 27 Apr 2012; Justin Lecher <jlec@gentoo.org> dstat-0.6.9-r1.ebuild,
+ dstat-0.7.2-r1.ebuild:
+ Bump EAPI to 4 to use mod_optimize on non multi ABI installs, #413745
02 Jan 2012; Justin Lecher <jlec@gentoo.org> dstat-0.6.9-r1.ebuild,
-dstat-0.7.2.ebuild, dstat-0.7.2-r1.ebuild, metadata.xml:
diff --git a/sys-apps/dstat/dstat-0.6.9-r1.ebuild b/sys-apps/dstat/dstat-0.6.9-r1.ebuild
index bd1fae78293c..ee2198222d9f 100644
--- a/sys-apps/dstat/dstat-0.6.9-r1.ebuild
+++ b/sys-apps/dstat/dstat-0.6.9-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.6.9-r1.ebuild,v 1.3 2012/01/02 13:58:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.6.9-r1.ebuild,v 1.4 2012/04/27 16:04:59 jlec Exp $
-EAPI=2
+EAPI=4
PYTHON_DEPEND="2"
@@ -19,6 +19,7 @@ IUSE=""
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -26,13 +27,12 @@ src_prepare() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
dodoc \
AUTHORS ChangeLog README TODO \
- examples/{mstat,read}.py docs/*.txt \
- || die "dodoc failed"
- dohtml docs/*.html || die "dohtml failed"
+ examples/{mstat,read}.py docs/*.txt
+ dohtml docs/*.html
}
pkg_postinst() {
diff --git a/sys-apps/dstat/dstat-0.7.2-r1.ebuild b/sys-apps/dstat/dstat-0.7.2-r1.ebuild
index 377359fe7970..1382e5723ac0 100644
--- a/sys-apps/dstat/dstat-0.7.2-r1.ebuild
+++ b/sys-apps/dstat/dstat-0.7.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.7.2-r1.ebuild,v 1.4 2012/01/02 13:58:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.7.2-r1.ebuild,v 1.5 2012/04/27 16:04:59 jlec Exp $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="2"
@@ -22,6 +22,7 @@ DEPEND=""
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
src_compile() {
@@ -29,14 +30,13 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${ED}" install || die "make install failed"
+ emake DESTDIR="${ED}" install
python_convert_shebangs 2 "${ED}usr/bin/dstat"
dodoc \
AUTHORS ChangeLog README TODO \
- examples/{mstat,read}.py docs/*.txt \
- || die "dodoc failed"
- dohtml docs/*.html || die "dohtml failed"
+ examples/{mstat,read}.py docs/*.txt
+ dohtml docs/*.html
}
pkg_postinst() {