summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-03-22 10:02:30 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-03-22 10:02:30 +0000
commite62e681b1112cbc9540c6649d7d971664d1bdc3e (patch)
tree33f64ec70a37e4e5fdb28a1df9c694bc8a6175aa /sys-apps/dmidecode
parentHardcoded fltk includedir (diff)
downloadgentoo-2-e62e681b1112cbc9540c6649d7d971664d1bdc3e.tar.gz
gentoo-2-e62e681b1112cbc9540c6649d7d971664d1bdc3e.tar.bz2
gentoo-2-e62e681b1112cbc9540c6649d7d971664d1bdc3e.zip
Version bump as requested by Justin "jlec" Lecher, closes bug #359725. This release is compatible with SMBIOS specification version 2.7.0. Remove prepalldocs from all ebuilds.
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/ChangeLog12
-rw-r--r--sys-apps/dmidecode/dmidecode-2.10.ebuild5
-rw-r--r--sys-apps/dmidecode/dmidecode-2.11.ebuild39
-rw-r--r--sys-apps/dmidecode/dmidecode-2.9.ebuild5
4 files changed, 53 insertions, 8 deletions
diff --git a/sys-apps/dmidecode/ChangeLog b/sys-apps/dmidecode/ChangeLog
index 9f9be6c87ce4..fdb92e0a92c6 100644
--- a/sys-apps/dmidecode/ChangeLog
+++ b/sys-apps/dmidecode/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/dmidecode
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.29 2010/08/29 00:08:39 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.30 2011/03/22 10:02:29 chainsaw Exp $
+
+*dmidecode-2.11 (22 Mar 2011)
+
+ 22 Mar 2011; Tony Vroon <chainsaw@gentoo.org> dmidecode-2.9.ebuild,
+ dmidecode-2.10.ebuild, +dmidecode-2.11.ebuild:
+ Version bump as requested by Justin "jlec" Lecher, closes bug #359725. This
+ release is compatible with SMBIOS specification version 2.7.0. Remove
+ prepalldocs from all ebuilds.
29 Aug 2010; Mike Frysinger <vapier@gentoo.org> dmidecode-2.10.ebuild:
Fix building with make-3.82 #334547 by Kacper Kowalik. Make sure we respect
diff --git a/sys-apps/dmidecode/dmidecode-2.10.ebuild b/sys-apps/dmidecode/dmidecode-2.10.ebuild
index 1f76b44e4954..fbc8f0821123 100644
--- a/sys-apps/dmidecode/dmidecode-2.10.ebuild
+++ b/sys-apps/dmidecode/dmidecode-2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.10.ebuild,v 1.6 2010/08/29 00:08:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.10.ebuild,v 1.7 2011/03/22 10:02:30 chainsaw Exp $
inherit flag-o-matic toolchain-funcs
@@ -36,5 +36,4 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die
- prepalldocs
}
diff --git a/sys-apps/dmidecode/dmidecode-2.11.ebuild b/sys-apps/dmidecode/dmidecode-2.11.ebuild
new file mode 100644
index 000000000000..be2a9024f251
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.11.ebuild,v 1.1 2011/03/22 10:02:30 chainsaw Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^prefix/s:/usr/local:/usr:' \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}
diff --git a/sys-apps/dmidecode/dmidecode-2.9.ebuild b/sys-apps/dmidecode/dmidecode-2.9.ebuild
index c96a2a2e34f8..dcdac490be97 100644
--- a/sys-apps/dmidecode/dmidecode-2.9.ebuild
+++ b/sys-apps/dmidecode/dmidecode-2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.9.ebuild,v 1.7 2008/01/29 16:59:07 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.9.ebuild,v 1.8 2011/03/22 10:02:29 chainsaw Exp $
inherit flag-o-matic toolchain-funcs
@@ -35,5 +35,4 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die "make install failed"
- prepalldocs
}