summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-20 22:03:25 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-20 22:03:25 +0000
commitb77ccfc47b62d9dd9a7acce67ecd6c5a9139a254 (patch)
treee0f3a15f83c22e5c5b16daab4f463eb180fb34f5 /sys-apps/dcron
parentInitial binary ebuild for OpenOffice (diff)
downloadgentoo-2-b77ccfc47b62d9dd9a7acce67ecd6c5a9139a254.tar.gz
gentoo-2-b77ccfc47b62d9dd9a7acce67ecd6c5a9139a254.tar.bz2
gentoo-2-b77ccfc47b62d9dd9a7acce67ecd6c5a9139a254.zip
New cronlayout. all the new releases are currently masked - please test. see also message on gentoo-dev
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/ChangeLog27
-rw-r--r--sys-apps/dcron/dcron-2.7-r9.ebuild67
-rw-r--r--sys-apps/dcron/files/crontab22
-rw-r--r--sys-apps/dcron/files/dcron.rc63
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.7-r91
5 files changed, 104 insertions, 16 deletions
diff --git a/sys-apps/dcron/ChangeLog b/sys-apps/dcron/ChangeLog
index b38212662df1..87e954dbc5d0 100644
--- a/sys-apps/dcron/ChangeLog
+++ b/sys-apps/dcron/ChangeLog
@@ -1,11 +1,26 @@
# ChangeLog for sys-apps/dcron
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.3 2002/04/20 12:08:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.4 2002/04/20 22:03:25 bangert Exp $
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/crontab
+
+ fixed /var/spool/cron/lastrun
+ added support for cron.hourly
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> dcron-2.7-r8.ebuild
+
+ add PROVIDE="virtual/cron" and RDEPEND="!virtual/cron sys-apps/cronbase"
+ added config section to activate /etc/cron.{hourly..etc}
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/cron.rc6
+
+ add "provide cron" to use
20 April 2002; Martin Schlemmer <azarah@gentoo.org> files/dcron.rc6 :
Update to NEED "logger"
+
*dcron-2.7-r8 (21 Mar 2002)
21 Mar 2002; Donny Davies <woodchip@gentoo.org> dcron-2.7-r8.ebuild,
@@ -13,13 +28,3 @@
Added patch from Matt Dillon to fix crontabs that begin with whitespace.
Thanks to everybody who helped analyze this problem.
-
-*dcron-2.7-r7 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/sys-apps/dcron/dcron-2.7-r9.ebuild b/sys-apps/dcron/dcron-2.7-r9.ebuild
new file mode 100644
index 000000000000..8f46fde5d63d
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7-r9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r9.ebuild,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+# to use this, you must be part of the "cron" group
+
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
+HOMEPAGE="http://apollo.backplane.com"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff || die
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ cp ${S}/crontab.c ${S}/crontab.c.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
+ cp ${S}/crontab.1 ${S}/crontab.1.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+ # fix for lines starting with whitespace
+ patch -p0 < ${FILESDIR}/${P}-whitespace.diff || die
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+
+ diropts -m 0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+
+ dodir /usr/{sbin,bin}
+ install -o root -g wheel -m 0700 crond ${D}/usr/sbin
+ install -o root -g cron -m 4750 crontab ${D}/usr/bin
+
+ dodoc CHANGELOG README
+ doman crontab.1 crond.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dcron.rc6 dcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+}
+
+
+pkg_postinst() {
+
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+
+}
diff --git a/sys-apps/dcron/files/crontab b/sys-apps/dcron/files/crontab
index 6bde0882d647..e4f4cc295666 100644
--- a/sys-apps/dcron/files/crontab
+++ b/sys-apps/dcron/files/crontab
@@ -1,9 +1,23 @@
+
+# /etc/crontab
+# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
+# $ Header: $
+
+# fcron || dcron:
+# This is NOT the system crontab! fcron and dcron do not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+
# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
-#
+
*/15 * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons
-0 0 * * * rm -f /var/cron/lastrun/cron.daily
-0 0 * * 6 rm -f /var/cron/lastrun/cron.weekly
-0 0 1 * * rm -f /var/cron/lastrun/cron.monthly
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
diff --git a/sys-apps/dcron/files/dcron.rc6 b/sys-apps/dcron/files/dcron.rc6
index 48dc3afb3957..809d8b3d446a 100644
--- a/sys-apps/dcron/files/dcron.rc6
+++ b/sys-apps/dcron/files/dcron.rc6
@@ -1,10 +1,11 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/dcron.rc6,v 1.4 2002/04/20 12:08:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/dcron.rc6,v 1.5 2002/04/20 22:03:25 bangert Exp $
depend() {
need clock hostname logger
+ provide cron
}
start() {
diff --git a/sys-apps/dcron/files/digest-dcron-2.7-r9 b/sys-apps/dcron/files/digest-dcron-2.7-r9
new file mode 100644
index 000000000000..0bbc16c10bc6
--- /dev/null
+++ b/sys-apps/dcron/files/digest-dcron-2.7-r9
@@ -0,0 +1 @@
+MD5 8984a6bb120cd674d4fb7f1cc52630a2 dcron27.tgz 15868