summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 17:20:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 17:20:58 +0000
commitbcbf390a5608409f99cd33bf8fc1d8f6bb6c52dc (patch)
treea89bde4d2cacf19a43ade049123e5ed3000c1843 /sys-apps/dbus
parentversion bump (diff)
downloadgentoo-2-bcbf390a5608409f99cd33bf8fc1d8f6bb6c52dc.tar.gz
gentoo-2-bcbf390a5608409f99cd33bf8fc1d8f6bb6c52dc.tar.bz2
gentoo-2-bcbf390a5608409f99cd33bf8fc1d8f6bb6c52dc.zip
Fix test suite building with -Wl,--as-needed (undefined reference to clock_gettime) wrt #280170.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog7
-rw-r--r--sys-apps/dbus/dbus-1.3.0.ebuild6
-rw-r--r--sys-apps/dbus/files/dbus-1.3.0-asneeded.patch84
3 files changed, 94 insertions, 3 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index f61fc3389237..c6caeaaf72c5 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dbus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.236 2009/08/03 02:13:42 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.237 2009/08/05 17:20:57 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> dbus-1.3.0.ebuild,
+ +files/dbus-1.3.0-asneeded.patch:
+ Fix test suite building with -Wl,--as-needed (undefined reference to
+ clock_gettime) wrt #280170.
*dbus-1.3.0 (03 Aug 2009)
diff --git a/sys-apps/dbus/dbus-1.3.0.ebuild b/sys-apps/dbus/dbus-1.3.0.ebuild
index 35a22670d7d4..41d2f3874692 100644
--- a/sys-apps/dbus/dbus-1.3.0.ebuild
+++ b/sys-apps/dbus/dbus-1.3.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.3.0.ebuild,v 1.1 2009/08/03 02:13:42 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.3.0.ebuild,v 1.2 2009/08/05 17:20:57 ssuominen Exp $
-inherit eutils multilib flag-o-matic
+inherit autotools eutils multilib flag-o-matic
DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
HOMEPAGE="http://dbus.freedesktop.org/"
@@ -30,6 +30,8 @@ src_unpack() {
# Tests were restricted because of this
sed -e 's/.*bus_dispatch_test.*/printf ("Disabled due to excess noise\\n");/' \
-e '/"dispatch"/d' -i "${S}/bus/test-main.c"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
}
src_compile() {
diff --git a/sys-apps/dbus/files/dbus-1.3.0-asneeded.patch b/sys-apps/dbus/files/dbus-1.3.0-asneeded.patch
new file mode 100644
index 000000000000..0f099cdccd95
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-1.3.0-asneeded.patch
@@ -0,0 +1,84 @@
+diff -ur dbus-1.3.0.orig/dbus/Makefile.am dbus-1.3.0/dbus/Makefile.am
+--- dbus-1.3.0.orig/dbus/Makefile.am 2008-04-04 19:32:04.000000000 +0300
++++ dbus-1.3.0/dbus/Makefile.am 2009-08-05 20:15:21.000000000 +0300
+@@ -176,6 +176,7 @@
+ libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined @R_DYNAMIC_LDFLAG@ @PIC_LDFLAGS@
+
+ libdbus_convenience_la_LDFLAGS=@R_DYNAMIC_LDFLAG@
++libdbus_convenience_la_LIBADD=$(DBUS_TEST_LIBS)
+
+ ## note that TESTS has special meaning (stuff to use in make check)
+ ## so if adding tests not to be run in make check, don't add them to
+@@ -194,7 +195,7 @@
+ dbus_test_SOURCES= \
+ dbus-test-main.c
+
+-dbus_test_LDADD=libdbus-convenience.la $(DBUS_TEST_LIBS)
++dbus_test_LDADD=$(DBUS_TEST_LIBS) libdbus-convenience.la
+ dbus_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ ## mop up the gcov files
+diff -ur dbus-1.3.0.orig/test/name-test/Makefile.am dbus-1.3.0/test/name-test/Makefile.am
+--- dbus-1.3.0.orig/test/name-test/Makefile.am 2009-07-16 17:01:01.000000000 +0300
++++ dbus-1.3.0/test/name-test/Makefile.am 2009-08-05 20:12:15.000000000 +0300
+@@ -21,52 +21,52 @@
+ test_names_SOURCES= \
+ test-names.c
+
+-test_names_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
++test_names_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
+ test_names_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_pending_call_dispatch_SOURCES = \
+ test-pending-call-dispatch.c
+
+-test_pending_call_dispatch_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
++test_pending_call_dispatch_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
+ test_pending_call_dispatch_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_pending_call_timeout_SOURCES = \
+ test-pending-call-timeout.c
+
+-test_pending_call_timeout_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
++test_pending_call_timeout_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
+ test_pending_call_timeout_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_threads_init_SOURCES = \
+ test-threads-init.c
+
+-test_threads_init_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
++test_threads_init_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
+ test_threads_init_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_ids_SOURCES = \
+ test-ids.c
+
+-test_ids_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_TEST_LIBS)
++test_ids_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la
+ test_ids_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_shutdown_SOURCES = \
+ test-shutdown.c
+
+ test_shutdown_CFLAGS=
+-test_shutdown_LDADD=$(top_builddir)/dbus/libdbus-convenience.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
++test_shutdown_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la ../libdbus-testutils.la
+ test_shutdown_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_privserver_SOURCES = \
+ test-privserver.c
+
+ test_privserver_CFLAGS=
+-test_privserver_LDADD=$(top_builddir)/dbus/libdbus-convenience.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
++test_privserver_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la ../libdbus-testutils.la
+ test_privserver_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ test_privserver_client_SOURCES = \
+ test-privserver-client.c
+
+ test_privserver_client_CFLAGS=
+-test_privserver_client_LDADD=$(top_builddir)/dbus/libdbus-convenience.la ../libdbus-testutils.la $(DBUS_TEST_LIBS)
++test_privserver_client_LDADD=$(DBUS_TEST_LIBS) $(top_builddir)/dbus/libdbus-convenience.la ../libdbus-testutils.la
+ test_privserver_client_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
+ endif