summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-20 01:35:48 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-20 01:35:48 +0000
commit89ebe63bb398358b004b8ad8574099bdbb51d326 (patch)
tree4460aa167373895050a9c17b61484f7de9bc5bc9 /sys-apps/dbus
parentAdding qt3 & qt4 USE flags for D-BUS (diff)
downloadgentoo-2-89ebe63bb398358b004b8ad8574099bdbb51d326.tar.gz
gentoo-2-89ebe63bb398358b004b8ad8574099bdbb51d326.tar.bz2
gentoo-2-89ebe63bb398358b004b8ad8574099bdbb51d326.zip
Rev bumped to 0.62. Had to remove arm, sh, and mips due to repoman issues. Bug #137325
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/dbus-0.62.ebuild142
-rw-r--r--sys-apps/dbus/files/digest-dbus-0.623
3 files changed, 152 insertions, 1 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index d45fcbd21112..2d9a1814b0bf 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.113 2006/04/27 22:33:46 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.114 2006/06/20 01:35:48 cardoe Exp $
+
+*dbus-0.62 (20 Jun 2006)
+
+ 20 Jun 2006; Doug Goldstein <cardoe@gentoo.org> +dbus-0.62.ebuild:
+ Rev bumped to 0.62. Had to remove arm, sh, and mips due to repoman issues.
+ Bug #137325
27 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-dbus-0.23.4-r1,
files/digest-dbus-0.50-r1, files/digest-dbus-0.50-r2,
diff --git a/sys-apps/dbus/dbus-0.62.ebuild b/sys-apps/dbus/dbus-0.62.ebuild
new file mode 100644
index 000000000000..da6e05c8ae6b
--- /dev/null
+++ b/sys-apps/dbus/dbus-0.62.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.62.ebuild,v 1.1 2006/06/20 01:35:48 cardoe Exp $
+
+inherit eutils mono python multilib debug qt3 autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gtk mono python qt3 qt4 selinux X"
+
+RDEPEND=">=dev-libs/glib-2.6
+ X? ( || ( ( x11-libs/libXt x11-libs/libX11 ) virtual/x11 ) )
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ mono? ( >=dev-lang/mono-0.95 )
+ python? ( >=dev-lang/python-2.4 >=dev-python/pyrex-0.9.3-r2 )
+ qt3? ( $(qt_min_version 3.3) )
+ qt4? ( >=x11-libs/qt-4.1.0 )
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/libxml2-2.6.21"
+ # expat code now sucks.. libxml2 is the default
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto
+ mono? ( >=dev-util/monodoc-1.1.10 ) )"
+
+pkg_setup() {
+ PKG_CONFIG_PATH="${QTDIR}/lib/pkgconfig"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #fix mono-tools depend
+ epatch "${FILESDIR}"/${PN}-0.61-mono-tools-update.diff
+
+ #fix libxml dep
+ epatch "${FILESDIR}"/${PN}-0.61-libxml-dep.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ # Only enable mono-docs if both mono and doc is defined
+ use mono && myconf="${myconf} $(use_enable doc mono-docs)"
+
+ if use qt3; then
+ myconf="${myconf} --enable-qt3=${QTDIR} --with-qt3-moc=${QTDIR}/bin/moc "
+ else
+ myconf="${myconf} --disable-qt3 --without-qt3-moc"
+ fi
+
+ if use qt4; then
+ myconf="${myconf} --enable-qt -with-qt-moc=/usr/bin/moc"
+ else
+ myconf="${myconf} --disable-qt --without-qt-moc"
+ fi
+
+ econf \
+ $(use_with X x) \
+ $(use_enable gtk) \
+ $(use_enable python) \
+ $(use_enable mono) \
+ $(use_enable kernel_linux dnotify) \
+ --disable-gcj \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug checks) \
+ $(use_enable debug asserts) \
+ --enable-glib \
+ --with-xml=libxml \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # Don't build the mono examples, they require gtk-sharp
+ touch ${S}/mono/example/{bus-listener,echo-{server,client}}.exe
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-0.61 dbus
+
+ # dbus X session script (#77504)
+ # FIXME : turns out to only work for GDM, better solution needed
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/dbus
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/dbus
+
+ einfo "To start the DBUS system-wide messagebus by default"
+ einfo "you should add it to the default runlevel :"
+ einfo "\`rc-update add dbus default\`"
+ echo
+ einfo "Run etc-update and then run the following:"
+ einfo "\`/etc/init.d/dbus reload\`"
+}
diff --git a/sys-apps/dbus/files/digest-dbus-0.62 b/sys-apps/dbus/files/digest-dbus-0.62
new file mode 100644
index 000000000000..34d498e01b3c
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-0.62
@@ -0,0 +1,3 @@
+MD5 ba7692f63d0e9f1ef06703dff56cb650 dbus-0.62.tar.gz 1737361
+RMD160 d653b25726ec96eb324761ebf9efb4a50d1590c0 dbus-0.62.tar.gz 1737361
+SHA256 884cc2083add655df57acc7bb144c61e9beeabf08ef76fa86929a58d7bc96707 dbus-0.62.tar.gz 1737361