summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-03-16 06:43:23 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-03-16 06:43:23 +0000
commit6256274e5e2451444044ce9c63ff07ab3aa67505 (patch)
treecee46b062ebb527f853daeeb71672ed15b01006d /sys-apps/dbus
parentFix for gcc 4.1. (#120910) Look for imake in the right place, fix by Octavio ... (diff)
downloadgentoo-2-6256274e5e2451444044ce9c63ff07ab3aa67505.tar.gz
gentoo-2-6256274e5e2451444044ce9c63ff07ab3aa67505.tar.bz2
gentoo-2-6256274e5e2451444044ce9c63ff07ab3aa67505.zip
Adding some necessary patches to fix QT mess.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/dbus-0.61.ebuild19
-rw-r--r--sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch11
-rw-r--r--sys-apps/dbus/files/dbus-0.61-libxml-dep.patch20
-rw-r--r--sys-apps/dbus/files/dbus-0.61-qt-disabling.patch21
5 files changed, 73 insertions, 6 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 39b5b2052a75..bf1614939d5f 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.107 2006/03/15 01:36:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.108 2006/03/16 06:43:23 cardoe Exp $
+
+ 16 Mar 2006; Doug Goldstein <cardoe@gentoo.org>
+ +files/dbus-0.61-i-hate-qt-so-much.patch,
+ +files/dbus-0.61-libxml-dep.patch, +files/dbus-0.61-qt-disabling.patch,
+ dbus-0.61.ebuild:
+ Adding some necessary patches to fix QT mess.
15 Mar 2006; Doug Goldstein <cardoe@gentoo.org> dbus-0.61.ebuild:
disable QT4 support
diff --git a/sys-apps/dbus/dbus-0.61.ebuild b/sys-apps/dbus/dbus-0.61.ebuild
index 522e073e3ddb..f0b4bebf66b4 100644
--- a/sys-apps/dbus/dbus-0.61.ebuild
+++ b/sys-apps/dbus/dbus-0.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.61.ebuild,v 1.3 2006/03/15 01:36:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.61.ebuild,v 1.4 2006/03/16 06:43:23 cardoe Exp $
inherit eutils mono python multilib debug qt3 autotools
@@ -41,10 +41,19 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.60-qt-pc.patch
# Fix GLIB Declaration for ANSI C
- epatch ${FILESDIR}/${PN}-0.60-decls-ansi-c.patch
+ epatch "${FILESDIR}"/${PN}-0.60-decls-ansi-c.patch
#fix mono-tools depend
- epatch ${FILESDIR}/${PN}-0.61-mono-tools-update.diff
+ epatch "${FILESDIR}"/${PN}-0.61-mono-tools-update.diff
+
+ #fix qt4 disabling
+ epatch "${FILESDIR}"/${PN}-0.61-qt-disabling.patch
+
+ #fix Trolltech's Makefile blunder
+ epatch "${FILESDIR}"/${PN}-0.61-i-hate-qt-so-much.patch
+
+ #fix libxml dep
+ epatch "${FILESDIR}"/${PN}-0.61-libxml-dep.patch
eautoreconf
}
@@ -56,9 +65,9 @@ src_compile() {
use mono && myconf="${myconf} $(use_enable doc mono-docs)"
if use qt; then
- myconf="${myconf} --enable-qt3=${QTDIR} QT_MOC=/usr/bin/moc --with-qt3-moc=${QTDIR}/bin/moc --disable-qt"
+ myconf="${myconf} --enable-qt3=${QTDIR} --with-qt-moc=/usr/bin/moc --with-qt3-moc=${QTDIR}/bin/moc --disable-qt"
else
- myconf="${myconf} --disable-qt --disable-qt3"
+ myconf="${myconf} --disable-qt --disable-qt3 --without-qt-moc --without-qt3-moc"
fi
econf \
diff --git a/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch b/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch
new file mode 100644
index 000000000000..b22d525c8dc4
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch
@@ -0,0 +1,11 @@
+--- qt/Makefile.am 2006-02-16 19:04:38.000000000 -0500
++++ qt/Makefile.am.new 2006-03-15 23:39:10.000000000 -0500
+@@ -62,7 +62,7 @@
+ $(top_srcdir)/qt/qdbusserver.lo: qdbusserver.moc
+ $(top_srcdir)/qt/qdbusconnection.lo: qdbusconnection_p.moc
+
+-CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection.moc
++CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection_p.moc
+
+ libdbus_qt4_1_la_LIBADD= $(DBUS_QT_LIBS) $(top_builddir)/dbus/libdbus-1.la
+ libdbus_qt4_1_la_LDFLAGS= -version-info 1:0 -no-undefined
diff --git a/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch b/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch
new file mode 100644
index 000000000000..f7e122f752bb
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch
@@ -0,0 +1,20 @@
+--- configure.in 2006-02-24 11:36:29.000000000 -0500
++++ configure.in.xml 2006-03-15 23:47:31.000000000 -0500
+@@ -9,6 +9,8 @@
+
+ AM_CONFIG_HEADER(config.h)
+
++LIBXML_REQUIRED=2.6.0
++
+ # Honor aclocal flags
+ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+@@ -753,7 +755,7 @@
+ [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
+ have_expat=false)
+
+-PKG_CHECK_MODULES(LIBXML, libxml-2.0, have_libxml=true, have_libxml=false)
++PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED, have_libxml=true, have_libxml=false)
+
+ # see what we want to use
+ dbus_use_libxml=false
diff --git a/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch b/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch
new file mode 100644
index 000000000000..fc270baef346
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch
@@ -0,0 +1,21 @@
+--- dbus-0.61/configure.in.disableqt4 2006-02-28 13:33:47.000000000 +0100
++++ dbus-0.61/configure.in 2006-02-28 13:33:29.000000000 +0100
+@@ -1033,6 +1033,10 @@
+ fi
+ have_qt=no
+ else
++ if test x$enable_qt = xno; then
++ have_qt=no;
++ have_qtest=no;
++ else
+ dnl Qt4 flags
+ AC_SUBST(DBUS_QT_CFLAGS)
+ AC_SUBST(DBUS_QT_LIBS)
+@@ -1055,6 +1059,7 @@
+
+ AC_SUBST(DBUS_QTESTLIB_CFLAGS)
+ AC_SUBST(DBUS_QTESTLIB_LIBS)
++ fi
+ fi
+
+ AM_CONDITIONAL(HAVE_QT, test x$have_qt = xyes)