summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-15 12:11:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-15 12:11:32 +0000
commit1aceaf301c941964e5ed42056a1d7574d1171b9b (patch)
tree56a54228f02a00db5e290f888425b4d9dcb9fb54 /sys-apps/cpuid/cpuid-20110305.ebuild
parentRe-add support for Bash versions < 4.2 (the manuals tend not to be clear abou... (diff)
downloadgentoo-2-1aceaf301c941964e5ed42056a1d7574d1171b9b.tar.gz
gentoo-2-1aceaf301c941964e5ed42056a1d7574d1171b9b.tar.bz2
gentoo-2-1aceaf301c941964e5ed42056a1d7574d1171b9b.zip
Initial commit. Bug #179805
(Portage version: 2.2.0_alpha39/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/cpuid/cpuid-20110305.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20110305.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20110305.ebuild b/sys-apps/cpuid/cpuid-20110305.ebuild
new file mode 100644
index 000000000000..468c3ccce7d9
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20110305.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpuid/cpuid-20110305.ebuild,v 1.1 2011/06/15 12:11:32 hwoarang Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}