summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-11 00:57:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-11 00:57:46 +0000
commit59f20b9addfee439aed70941506169584e350782 (patch)
tree4b2200e44c3d3111200e2280a31f5cdd9c1ac24f /sys-apps/coreutils
parentUpdate loop aes #129496 by Alon Bar-Lev and fix building on sparc/arm systems... (diff)
downloadgentoo-2-59f20b9addfee439aed70941506169584e350782.tar.gz
gentoo-2-59f20b9addfee439aed70941506169584e350782.tar.bz2
gentoo-2-59f20b9addfee439aed70941506169584e350782.zip
old
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r2.ebuild149
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r6.ebuild156
-rw-r--r--sys-apps/coreutils/coreutils-5.3.0-r1.ebuild141
-rw-r--r--sys-apps/coreutils/coreutils-5.93.ebuild143
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.2.1-r23
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.2.1-r62
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.3.0-r12
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.932
8 files changed, 0 insertions, 598 deletions
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild
deleted file mode 100644
index c44f93ce7df8..000000000000
--- a/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild,v 1.15 2005/10/29 09:41:14 vapier Exp $
-
-inherit eutils flag-o-matic
-
-PATCH_VER=0.6
-I18N_VER=i18n-0.2
-PATCHDIR=${WORKDIR}/patch
-
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
- mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2
- mirror://gentoo/${P}-${I18N_VER}.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build acl selinux static"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( sys-apps/acl sys-apps/attr )
- nls? ( sys-devel/gettext )
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.49
- >=sys-devel/automake-1.8.3
- >=sys-devel/autoconf-2.58
- >=sys-devel/m4-1.4-r1
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # Mandrake's lsw patch caused issues on ia64 and amd64 with ls
- # Reported upstream, but we don't apply it for now
- # mv ${PATCHDIR}/mandrake/019* ${PATCHDIR}/excluded
- mv ${PATCHDIR}/mandrake/025* ${PATCHDIR}/excluded
- sed -i -e '/rm.*fr/s:\\::' ${PATCHDIR}/mandrake/027_all_coreutils-mdk-build-fix.patch #53881
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/mandrake
- epatch ${WORKDIR}/${P}-${I18N_VER}.patch
-
- # Apply the ACL patches.
- # WARNING: These CONFLICT with the SELINUX patches
- if use acl
- then
- mv ${PATCHDIR}/generic/00{1,2,4}* ${PATCHDIR}/excluded
- mv ${PATCHDIR}/selinux/001_all_coreutils-noacl* ${PATCHDIR}/excluded
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/acl
- else
- mv ${PATCHDIR}/selinux/001_all_coreutils-acl* ${PATCHDIR}/excluded
- fi
-
- # patch to remove Stallman's su/wheel group rant (which doesn't apply,
- # since Gentoo's su is not GNU/su, but that from shadow.
- # do not include su infopage, as it is not valid for the su
- # from sys-apps/shadow that we are using.
- # Patch to add processor specific info to the uname output
-
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/generic
-
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/extra
-
- use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
-
- # Sparc32 SMP bug fix -- see bug #46593
- use sparc && echo -ne "\n\n" >> ${S}/src/pr.c
-
- # Since we've patched many .c files, the make process will
- # try to re-build the manpages by running `./bin --help`.
- # When cross-compiling, we can't do that since 'bin' isn't
- # a native binary, so let's just install outdated man-pages.
- [[ ${CTARGET:-${CHOST}} != ${CHOST} ]] && touch man/*.1
-}
-
-src_compile() {
- if [ -z "`which cvs 2>/dev/null`" ]
- then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
-
- export WANT_AUTOMAKE=1.8
- export WANT_AUTOCONF=2.5
-
- mv m4/inttypes.m4 m4/inttypes-eggert.m4
- touch aclocal.m4 configure config.hin \
- Makefile.in */Makefile.in */*/Makefile.in
-
- ebegin "Reconfiguring configure scripts (be patient)"
- aclocal -I m4 &>/dev/null || die
- autoconf || die
- automake || die
- eend $?
-
- econf \
- --bindir=/bin \
- --enable-largefile \
- `use_enable nls` \
- `use_enable selinux` || die
-
- if use static
- then
- emake LDFLAGS=-static || die
- else
- emake || die
- fi
-}
-
-src_install() {
- einstall \
- bindir=${D}/bin || die
-
- cd ${D}
- dodir /usr/bin
- rm -rf usr/lib
-
- # add DIRCOLORS
- insinto /etc
- doins ${FILESDIR}/DIR_COLORS
-
- # move non-critical packages into /usr
- mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
- mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
- mv bin/{tail,test,tsort,unexpand,users} usr/bin
- cd usr/bin
- ln -s ../../bin/* .
-
- if ! use build
- then
- cd ${S}
- dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
- else
- rm -rf ${D}/usr/share
- fi
-}
-
-pkg_postinst() {
- # hostname does not get removed as it is included with older stage1
- # tarballs, and net-tools installs to /bin
- if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
- then
- rm -f ${ROOT}/usr/bin/hostname
- fi
-}
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
deleted file mode 100644
index a3b3b8ffa158..000000000000
--- a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.18 2006/02/17 12:29:44 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-PATCH_VER=0.11
-PATCHDIR="${WORKDIR}/patch"
-
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
- mirror://gentoo/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="acl build nls selinux static"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( sys-apps/acl sys-apps/attr )
- nls? ( sys-devel/gettext )
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.49
- =sys-devel/automake-1.8*
- >=sys-devel/autoconf-2.58
- >=sys-devel/m4-1.4-r1
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
-
- # Apply the ACL patches.
- # WARNING: These CONFLICT with the SELINUX patches
- if use acl ; then
- mv "${PATCHDIR}"/generic/00{2,4}* "${PATCHDIR}"/excluded
- mv "${PATCHDIR}"/selinux/001_all_coreutils-noacl* "${PATCHDIR}"/excluded
- EPATCH_MULTI_MSG="Applying ACL patches ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
- else
- mv "${PATCHDIR}"/selinux/001_all_coreutils-acl* "${PATCHDIR}"/excluded
- fi
-
- # patch to remove Stallman's su/wheel group rant (which doesn't apply,
- # since Gentoo's su is not GNU/su, but that from shadow.
- # do not include su infopage, as it is not valid for the su
- # from sys-apps/shadow that we are using.
- # Patch to add processor specific info to the uname output
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/extra
- # Make sure test is +x #87795
- chmod a+rx tests/sort/sort-mb-tests
-
- use selinux && EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
-
- # Sparc32 SMP bug fix -- see bug #46593
- use sparc && echo -ne "\n\n" >> "${S}"/src/pr.c
-
- # Since we've patched many .c files, the make process will
- # try to re-build the manpages by running `./bin --help`.
- # When cross-compiling, we can't do that since 'bin' isn't
- # a native binary, so let's just install outdated man-pages.
- tc-is-cross-compiler && touch man/*.1
-
- ebegin "Reconfiguring configure scripts (be patient)"
- export WANT_AUTOMAKE=1.8
- export WANT_AUTOCONF=2.5
-
- mv m4/inttypes.m4 m4/inttypes-eggert.m4
- touch aclocal.m4 configure config.hin \
- Makefile.in */Makefile.in */*/Makefile.in
-
- aclocal -I m4 || die "aclocal"
- autoconf || die "autoconf"
- automake || die "automake"
- eend $?
-}
-
-src_compile() {
- if ! type -p cvs > /dev/null ; then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
-
- local myconf=""
- [[ ${USERLAND} == "GNU" ]] \
- && myconf="${myconf} --bindir=/bin" \
- || myconf="${myconf} --program-prefix=g"
-
- econf \
- --enable-largefile \
- $(use_enable nls) \
- $(use_enable selinux) \
- ${myconf} \
- || die "econf"
-
- use static && append-ldflags -static
- emake LDFLAGS="${LDFLAGS}" || die "emake"
-}
-
-src_test() {
- # Non-root tests will fail if the full path isnt
- # accessible to non-root users
- chmod -R go-w "${WORKDIR}"
- chmod a+rx "${WORKDIR}"
- addwrite /dev/full
- export RUN_EXPENSIVE_TESTS="yes"
- #export FETISH_GROUPS="portage wheel"
- make check || die "make check failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- insinto /etc
- doins "${FILESDIR}"/DIR_COLORS
-
- if [[ ${USERLAND} == "GNU" ]] ; then
- # move non-critical packages into /usr
- cd "${D}"
- dodir /usr/bin
- mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
- mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
- mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
- cd bin
- local x
- for x in * ; do
- dosym /bin/${x} /usr/bin/${x}
- done
- fi
-
- if ! use build ; then
- cd "${S}"
- dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
- else
- rm -r "${D}"/usr/share
- fi
-}
-
-pkg_postinst() {
- [[ ${USERLAND} != "GNU" ]] && return 0
-
- # hostname does not get removed as it is included with older stage1
- # tarballs, and net-tools installs to /bin
- if [[ -e ${ROOT}/usr/bin/hostname && ! -L ${ROOT}/usr/bin/hostname ]] ; then
- rm -f "${ROOT}"/usr/bin/hostname
- fi
-}
diff --git a/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild b/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild
deleted file mode 100644
index 9f9a31e6335c..000000000000
--- a/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.3.0-r1.ebuild,v 1.6 2006/02/17 12:29:44 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-PATCH_VER=1.3
-
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
- mirror://gentoo/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~seemant/distfiles/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="acl build nls selinux static"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( sys-apps/acl sys-apps/attr )
- nls? ( sys-devel/gettext )
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.49
- =sys-devel/automake-1.8*
- >=sys-devel/autoconf-2.58
- >=sys-devel/m4-1.4-r1
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- PATCHDIR="${WORKDIR}/patch"
-
- EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
-
- # Apply the ACL/SELINUX patches.
- if use selinux ; then
- EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
- ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
- elif use acl ; then
- EPATCH_MULTI_MSG="Applying ACL patches ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
- fi
-
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/extra
-
- # Since we've patched many .c files, the make process will
- # try to re-build the manpages by running `./bin --help`.
- # When cross-compiling, we can't do that since 'bin' isn't
- # a native binary, so let's just install outdated man-pages.
- tc-is-cross-compiler && touch man/*.1
-
- ebegin "Reconfiguring configure scripts (be patient)"
- export WANT_AUTOMAKE=1.8
- export WANT_AUTOCONF=2.5
- aclocal -I m4 || die "aclocal"
- autoconf || die "autoconf"
- automake || die "automake"
- eend $?
-}
-
-src_compile() {
- if ! type -p cvs > /dev/null ; then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
-
- local myconf=""
- [[ ${USERLAND} == "GNU" ]] \
- && myconf="${myconf} --bindir=/bin" \
- || myconf="${myconf} --program-prefix=g"
-
- econf \
- --enable-largefile \
- $(use_enable nls) \
- $(use_enable selinux) \
- ${myconf} \
- || die "econf"
-
- use static && append-ldflags -static
- emake LDFLAGS="${LDFLAGS}" || die "emake"
-}
-
-src_test() {
- # Non-root tests will fail if the full path isnt
- # accessible to non-root users
- chmod -R go-w "${WORKDIR}"
- chmod a+rx "${WORKDIR}"
- addwrite /dev/full
- export RUN_EXPENSIVE_TESTS="yes"
- #export FETISH_GROUPS="portage wheel"
- make check || die "make check failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- rm -f "${D}"/usr/lib/charset.alias
-
- # remove files provided by other packages
- rm "${D}"/bin/{kill,uptime} # procps
- rm "${D}"/bin/{groups,su} # shadow
- rm "${D}"/bin/hostname # net-tools
- rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
- # provide by the man-pages package
- rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
- rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
- rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
-
- insinto /etc
- doins "${FILESDIR}"/DIR_COLORS
-
- if [[ ${USERLAND} == "GNU" ]] ; then
- # move non-critical packages into /usr
- cd "${D}"
- dodir /usr/bin
- mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
- mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
- mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
- cd bin
- local x
- for x in * ; do
- dosym /bin/${x} /usr/bin/${x}
- done
- fi
-
- if ! use build ; then
- cd "${S}"
- dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
- else
- rm -r "${D}"/usr/share
- fi
-}
diff --git a/sys-apps/coreutils/coreutils-5.93.ebuild b/sys-apps/coreutils/coreutils-5.93.ebuild
deleted file mode 100644
index 1b01e6c27550..000000000000
--- a/sys-apps/coreutils/coreutils-5.93.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.93.ebuild,v 1.4 2006/02/17 12:29:44 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-PATCH_VER=1.1
-
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
- mirror://gentoo/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~seemant/distfiles/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="acl build nls selinux static"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( sys-apps/acl sys-apps/attr )
- nls? ( sys-devel/gettext )
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.49
- =sys-devel/automake-1.8*
- >=sys-devel/autoconf-2.58
- >=sys-devel/m4-1.4-r1
- sys-apps/help2man"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- PATCHDIR="${WORKDIR}/patch"
-
- EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
-
- # Apply the ACL/SELINUX patches.
- if use selinux ; then
- EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
- ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
- elif use acl ; then
- EPATCH_MULTI_MSG="Applying ACL patches ..." \
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
- fi
-
- EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
- chmod a+rx tests/sort/sort-mb-tests
-
- # Since we've patched many .c files, the make process will
- # try to re-build the manpages by running `./bin --help`.
- # When cross-compiling, we can't do that since 'bin' isn't
- # a native binary, so let's just install outdated man-pages.
- tc-is-cross-compiler && touch man/*.1
- # There's no reason for this crap to use the private version
- sed -i 's:__mempcpy:mempcpy:g' lib/*.c
-
- export WANT_AUTOMAKE=1.9
- export WANT_AUTOCONF=2.5
- ebegin "Reconfiguring configure scripts (be patient)"
- aclocal -I m4 || die "aclocal"
- autoconf || die "autoconf"
- automake || die "automake"
- eend $?
-}
-
-src_compile() {
- if ! type -p cvs > /dev/null ; then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
-
- local myconf=""
- [[ ${USERLAND} == "GNU" ]] \
- && myconf="${myconf} --bindir=/bin" \
- || myconf="${myconf} --program-prefix=g"
-
- econf \
- --enable-largefile \
- $(use_enable nls) \
- $(use_enable selinux) \
- ${myconf} \
- || die "econf"
-
- use static && append-ldflags -static
- emake LDFLAGS="${LDFLAGS}" || die "emake"
-}
-
-src_test() {
- # Non-root tests will fail if the full path isnt
- # accessible to non-root users
- chmod -R go-w "${WORKDIR}"
- chmod a+rx "${WORKDIR}"
- addwrite /dev/full
- export RUN_EXPENSIVE_TESTS="yes"
- #export FETISH_GROUPS="portage wheel"
- make check || die "make check failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- rm -f "${D}"/usr/lib/charset.alias
-
- # remove files provided by other packages
- rm "${D}"/bin/{kill,uptime} # procps
- rm "${D}"/bin/{groups,su} # shadow
- rm "${D}"/bin/hostname # net-tools
- rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
- # provide by the man-pages package
- rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
- rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
- rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
-
- insinto /etc
- newins src/dircolors.hin DIR_COLORS
-
- if [[ ${USERLAND} == "GNU" ]] ; then
- # move non-critical packages into /usr
- cd "${D}"
- dodir /usr/bin
- mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
- mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
- mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
- cd bin
- local x
- for x in * ; do
- dosym /bin/${x} /usr/bin/${x}
- done
- fi
-
- if ! use build ; then
- cd "${S}"
- dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
- else
- rm -r "${D}"/usr/share
- fi
-}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.2.1-r2 b/sys-apps/coreutils/files/digest-coreutils-5.2.1-r2
deleted file mode 100644
index 2b0fa02e004b..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-5.2.1-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 172ee3c315af93d3385ddfbeb843c53f coreutils-5.2.1.tar.bz2 4270776
-MD5 7d161e32876df4dddf5d5284f8c6588b coreutils-5.2.1-gentoo-0.6.tar.bz2 65612
-MD5 7dad35dee7a6517440feac4eef8b64c4 coreutils-5.2.1-i18n-0.2.patch.bz2 21795
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.2.1-r6 b/sys-apps/coreutils/files/digest-coreutils-5.2.1-r6
deleted file mode 100644
index 7f3dc729ab0b..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-5.2.1-r6
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 172ee3c315af93d3385ddfbeb843c53f coreutils-5.2.1.tar.bz2 4270776
-MD5 7c84ee1692c3cb068b7069321444556e coreutils-5.2.1-patches-0.11.tar.bz2 91118
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.3.0-r1 b/sys-apps/coreutils/files/digest-coreutils-5.3.0-r1
deleted file mode 100644
index ff2ebc2996fd..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-5.3.0-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 903890208248639ac723d2c4988e04bd coreutils-5.3.0.tar.bz2 4473010
-MD5 15038f61180579cbb9385d3ce9777bf3 coreutils-5.3.0-patches-1.3.tar.bz2 55111
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.93 b/sys-apps/coreutils/files/digest-coreutils-5.93
deleted file mode 100644
index bd77bfec538c..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-5.93
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 adc7a9ab02e1629ede6123a1ed8aaa65 coreutils-5.93-patches-1.1.tar.bz2 61120
-MD5 955d8abfd3dd8af2ca3af51480f1f9af coreutils-5.93.tar.bz2 4896288