summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-14 04:08:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-14 04:08:10 +0000
commit4f38e97595e23bf333b7fe56e220a9bcbe3262b8 (patch)
tree3130ee9ac51cf020325e9fe08f000190e710f69d /sys-apps/coreutils
parentKeyworded mips to satisfy repoman deps for xmms. (Manifest recommit) (diff)
downloadgentoo-2-4f38e97595e23bf333b7fe56e220a9bcbe3262b8.tar.gz
gentoo-2-4f38e97595e23bf333b7fe56e220a9bcbe3262b8.tar.bz2
gentoo-2-4f38e97595e23bf333b7fe56e220a9bcbe3262b8.zip
more colors for DIR_COLORS #46614 by Alexandru Toma
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/coreutils-5.2.0-r2.ebuild4
-rw-r--r--sys-apps/coreutils/files/DIR_COLORS138
2 files changed, 140 insertions, 2 deletions
diff --git a/sys-apps/coreutils/coreutils-5.2.0-r2.ebuild b/sys-apps/coreutils/coreutils-5.2.0-r2.ebuild
index 0b23eab3e30f..7009978c0c96 100644
--- a/sys-apps/coreutils/coreutils-5.2.0-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.0-r2.ebuild,v 1.4 2004/05/14 00:36:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.0-r2.ebuild,v 1.5 2004/05/14 04:08:10 vapier Exp $
inherit eutils flag-o-matic
@@ -129,7 +129,7 @@ src_install() {
# add DIRCOLORS
insinto /etc
- doins ${PATCHDIR}/DIR_COLORS
+ doins ${FILESDIR}/DIR_COLORS
# move non-critical packages into /usr
mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
diff --git a/sys-apps/coreutils/files/DIR_COLORS b/sys-apps/coreutils/files/DIR_COLORS
new file mode 100644
index 000000000000..eff27d451374
--- /dev/null
+++ b/sys-apps/coreutils/files/DIR_COLORS
@@ -0,0 +1,138 @@
+# Configuration file for dircolors, a utility to help you set the
+# LS_COLORS environment variable used by GNU ls with the --color option.
+#
+# You can copy this file to .dir_colors in your $HOME directory to override
+# the system defaults.
+#
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/files/DIR_COLORS,v 1.1 2004/05/14 04:08:10 vapier Exp $
+
+# COLOR needs one of these arguments: 'tty' colorizes output to ttys, but not
+# pipes. 'all' adds color characters to all output. 'none' shuts colorization
+# off.
+COLOR tty
+
+# Extra command line options for ls go here.
+# Basically these ones are:
+# -F = show '/' for dirs, '*' for executables, etc.
+# -T 0 = don't trust tab spacing when formatting ls output.
+OPTIONS -F -T 0
+
+# Below, there should be one TERM entry for each termtype that is colorizable
+TERM linux
+TERM linux-c
+TERM mach-color
+TERM console
+TERM con132x25
+TERM con132x30
+TERM con132x43
+TERM con132x60
+TERM con80x25
+TERM con80x28
+TERM con80x30
+TERM con80x43
+TERM con80x50
+TERM con80x60
+TERM cons25
+TERM xterm
+TERM xterm-color
+TERM xterm-debian
+TERM color-xterm
+TERM color_xterm
+TERM rxvt
+TERM screen
+TERM screen-w
+TERM vt100
+TERM dtterm
+TERM ansi
+TERM Eterm
+
+# EIGHTBIT, followed by '1' for on, '0' for off. (8-bit output)
+EIGHTBIT 1
+
+# Below are the color init strings for the basic file types. A color init
+# string consists of one or more of the following numeric codes:
+# Attribute codes:
+# 00=none 01=bold 04=underscore 05=blink 07=reverse 08=concealed
+# Text color codes:
+# 30=black 31=red 32=green 33=yellow 34=blue 35=magenta 36=cyan 37=white
+# Background color codes:
+# 40=black 41=red 42=green 43=yellow 44=blue 45=magenta 46=cyan 47=white
+NORMAL 00 # global default, although everything should be something.
+FILE 00 # normal file
+DIR 01;34 # directory
+LINK 01;36 # symbolic link. (If you set this to 'target' instead of a
+ # numerical value, the color is as for the file pointer to.)
+FIFO 40;33 # pipe
+SOCK 01;35 # socket
+DOOR 01;35 # door
+BLK 40;33;01 # block device driver
+CHR 40;33;01 # character device driver
+ORPHAN 01;05;37;41 # orphaned syminks
+MISSING 01;05;37;41 # ... and the files they point to
+
+# This is for files with execute permission:
+EXEC 01;32
+
+# List any file extensions like '.gz' or '.tar' that you would like ls
+# to colorize below. Put the extension, a space, and the color init string.
+# (and any comments you want to add after a '#')
+
+.cmd 01;32 # executables (bright green)
+.exe 01;32
+.com 01;32
+.btm 01;32
+.bat 01;32
+.sh 01;32
+.csh 01;32
+
+.tar 01;31 # archives or compressed (bright red)
+.tgz 01;31
+.arj 01;31
+.taz 01;31
+.lzh 01;31
+.zip 01;31
+.z 01;31
+.Z 01;31
+.gz 01;31
+.bz2 01;31
+.bz 01;31
+.tz 01;31
+.deb 01;31
+.rpm 01;31
+.rar 01;31
+.ace 01;31
+.cpio 01;31
+
+.jpg 01;35 # image formats
+.jpeg 01;35
+.gif 01;35
+.bmp 01;35
+.ppm 01;35
+.tga 01;35
+.xbm 01;35
+.xpm 01;35
+.tif 01;35
+.tiff 01;35
+.png 01;35
+.mng 01;35
+.xcf 01;35
+.pcx 01;35
+.mpg 01;35
+.mpeg 01;35
+.m2v 01;35 # MPEG-2 Video only
+.avi 01;35
+.mkv 01;35 # Matroska (http://matroska.org/)
+.ogm 01;35 # Ogg Media File
+.mp4 01;35 # "Offical" container for MPEG-4
+.m4v 01;35 # MPEG-4 Video only
+.mp4v 01;35 # MPEG-4 Video only
+.mov 01;35 # Quicktime (http://developer.apple.com/qa/qtw/qtw99.html)
+.qt 01;35 # Quicktime (http://developer.apple.com/qa/qtw/qtw99.html)
+.wmv 01;35 # Windows Media Video
+.asf 01;35 # Advanced Systems Format (contains Windows Media Video)
+.rm 01;35 # Real Media
+.rmvb 01;35 # Real Media Variable Bitrate
+.flc 01;35 # AutoDesk Animator
+.fli 01;35 # AutoDesk Animator
+.gl 01;35
+.dl 01;35