summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-13 15:29:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-13 15:29:04 +0000
commit56502c5d619b7df74ca06c91efe79edbac1097ee (patch)
tree6ab193b3e57fb32c2665c4757a6eb9aaff32cc63 /sys-apps/coreutils/coreutils-5.2.1-r2.ebuild
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-56502c5d619b7df74ca06c91efe79edbac1097ee.tar.gz
gentoo-2-56502c5d619b7df74ca06c91efe79edbac1097ee.tar.bz2
gentoo-2-56502c5d619b7df74ca06c91efe79edbac1097ee.zip
cross-compile fix
Diffstat (limited to 'sys-apps/coreutils/coreutils-5.2.1-r2.ebuild')
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild
index 45c8abb43350..8c25bc14fd08 100644
--- a/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild,v 1.3 2004/11/12 15:37:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r2.ebuild,v 1.4 2004/12/13 15:29:04 vapier Exp $
inherit eutils flag-o-matic
@@ -71,6 +71,12 @@ src_unpack() {
# Sparc32 SMP bug fix -- see bug #46593
use sparc && echo -ne "\n\n" >> ${S}/src/pr.c
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ [[ ${CTARGET:-${CHOST}} != ${CHOST} ]] && touch man/*.1
}
src_compile() {