summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2004-09-21 00:27:44 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2004-09-21 00:27:44 +0000
commit5cb470ce45c2f78caf71d1a9faed2c598d2b92ec (patch)
tree4c9211eee0ae2577d970206ab6eef8f76a10b981 /sys-apps/coldplug
parentadding povlegal license covering 3.6 (diff)
downloadgentoo-2-5cb470ce45c2f78caf71d1a9faed2c598d2b92ec.tar.gz
gentoo-2-5cb470ce45c2f78caf71d1a9faed2c598d2b92ec.tar.bz2
gentoo-2-5cb470ce45c2f78caf71d1a9faed2c598d2b92ec.zip
new ebuild, coldplug, to replace the hotplug init.d startup script
Diffstat (limited to 'sys-apps/coldplug')
-rw-r--r--sys-apps/coldplug/ChangeLog18
-rw-r--r--sys-apps/coldplug/Manifest5
-rw-r--r--sys-apps/coldplug/coldplug-20040920.ebuild26
-rw-r--r--sys-apps/coldplug/files/coldplug.rc31
-rw-r--r--sys-apps/coldplug/files/digest-coldplug-200409201
-rw-r--r--sys-apps/coldplug/metadata.xml9
6 files changed, 90 insertions, 0 deletions
diff --git a/sys-apps/coldplug/ChangeLog b/sys-apps/coldplug/ChangeLog
new file mode 100644
index 000000000000..86c6a668cfb4
--- /dev/null
+++ b/sys-apps/coldplug/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for sys-apps/hotplug
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coldplug/ChangeLog,v 1.1 2004/09/21 00:27:44 gregkh Exp $
+
+*coldplug-20040920 (20 Sep 2004)
+
+ 20 Sep 2004; Greg Kroah-Hartman <gregkh@gentoo.org> +metadata.xml,
+ +files/coldplug.rc, +coldplug-20040920.ebuild:
+ New package, coldplug. Split out from hotplug to hold the
+ init script that tries to load modules for devices that are
+ already present in the system at boot time.
+
+ It can cause problems and lockups, so use at your own risk.
+
+ I've disabled the ability to unload stuff at shutdown as that
+ just caused too many problems, lockups, and oopses. No other
+ distro enables this feature, and now I realize why :)
+
diff --git a/sys-apps/coldplug/Manifest b/sys-apps/coldplug/Manifest
new file mode 100644
index 000000000000..d1ae9b458972
--- /dev/null
+++ b/sys-apps/coldplug/Manifest
@@ -0,0 +1,5 @@
+MD5 1613f0c39766a6371f26e6f6d87ce8d6 ChangeLog 216
+MD5 075d5a933d6175160a02ddf15bd4f454 metadata.xml 260
+MD5 cf380e03094af976c5d1255621e51039 coldplug-20040920.ebuild 842
+MD5 7c7bdd621c151e38b9f282d9dec54c5c files/coldplug.rc 697
+MD5 6038bb8c3af43a0e6f0aa876e4307df6 files/digest-coldplug-20040920 69
diff --git a/sys-apps/coldplug/coldplug-20040920.ebuild b/sys-apps/coldplug/coldplug-20040920.ebuild
new file mode 100644
index 000000000000..a48024bf4f75
--- /dev/null
+++ b/sys-apps/coldplug/coldplug-20040920.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coldplug/coldplug-20040920.ebuild,v 1.1 2004/09/21 00:27:44 gregkh Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=hotplug-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="coldplug init.d program to load modules at bootime"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+IUSE=""
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/hotplug-20040920"
+
+src_install() {
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/coldplug.rc coldplug
+}
+
diff --git a/sys-apps/coldplug/files/coldplug.rc b/sys-apps/coldplug/files/coldplug.rc
new file mode 100644
index 000000000000..2aad4ac472b1
--- /dev/null
+++ b/sys-apps/coldplug/files/coldplug.rc
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coldplug/files/coldplug.rc,v 1.1 2004/09/21 00:27:44 gregkh Exp $
+
+depend() {
+ need modules
+}
+
+checkconfig() {
+ if [ ! -d /etc/hotplug ] ; then
+ eerror "Coldplug requires scripts & configs in /etc/hotplug !"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ for RC in /etc/hotplug/*.rc
+ do
+ NAME=`basename $RC .rc`
+ ebegin "Coldplugging $NAME devices"
+ # We do not want to check the return status, as
+ # some of the scripts may fail due to drivers not
+ # compiled as modules ...
+ $RC start
+ eend 0
+ done
+}
+
diff --git a/sys-apps/coldplug/files/digest-coldplug-20040920 b/sys-apps/coldplug/files/digest-coldplug-20040920
new file mode 100644
index 000000000000..cb37cae939a6
--- /dev/null
+++ b/sys-apps/coldplug/files/digest-coldplug-20040920
@@ -0,0 +1 @@
+MD5 9e6b06dfa3b91f051b55e1483adb5a68 hotplug-2004_09_20.tar.gz 44398
diff --git a/sys-apps/coldplug/metadata.xml b/sys-apps/coldplug/metadata.xml
new file mode 100644
index 000000000000..1e43b9dfc9ff
--- /dev/null
+++ b/sys-apps/coldplug/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>gregkh@gentoo.org</email>
+ <name>Greg Kroah-Hartman</name>
+</maintainer>
+</pkgmetadata>