summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/bzip2
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/bzip2')
-rw-r--r--sys-apps/bzip2/bzip2-1.0.1-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/bzip2/bzip2-1.0.1-r1.ebuild b/sys-apps/bzip2/bzip2-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..92fb2fadbf05
--- /dev/null
+++ b/sys-apps/bzip2/bzip2-1.0.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r1.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo"
+SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${A}
+ ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${A}"
+
+HOMEPAGE="http://sourceware.cygnus.com/bzip2/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ # bzip2's try makefile does not use CFLAGS so we hard-wire the compile
+ # options using sed ;)
+
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" \
+ -e "s:/man/man1:/man/man1:" Makefile.orig > Makefile
+
+ cp Makefile-libbz2_so Makefile-libbz2.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile-libbz2.orig > Makefile-libbz2_so
+
+}
+
+src_compile() {
+
+ try pmake -f Makefile-libbz2_so all
+ try pmake all
+
+}
+src_install() {
+
+ dodir /usr/share/man/man1
+ try make PREFIX=${D}/usr install
+ rm -rf ${D}/usr/man
+
+ dolib.so libbz2.so.1.0.1
+ mv ${D}/usr/bin ${D}
+ preplib /usr
+
+ dodoc README LICENSE CHANGES Y2K_INFO
+ docinto txt
+ dodoc bzip2.txt
+ docinto ps
+ dodoc manual.ps
+ docinto html
+ dodoc manual_*.html
+
+}
+
+