summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-14 00:08:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-14 00:08:09 +0000
commitd47981b651f657ed14a058ce51d3822337c3eff0 (patch)
treef3b247a27f89333c382c47b78f9bed00a2eafc4f /sys-apps/busybox
parentNew major version, including support for more than just LiveJournal. Thanks t... (diff)
downloadgentoo-2-d47981b651f657ed14a058ce51d3822337c3eff0.tar.gz
gentoo-2-d47981b651f657ed14a058ce51d3822337c3eff0.tar.bz2
gentoo-2-d47981b651f657ed14a058ce51d3822337c3eff0.zip
split the insmod patches so we can apply the alpha/hppa support patch to 1.01 and 1.00 #105786
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.00-r4.ebuild3
-rw-r--r--sys-apps/busybox/busybox-1.01.ebuild3
-rw-r--r--sys-apps/busybox/files/1.00/fix-amd64-insmod.patch15
-rw-r--r--sys-apps/busybox/files/1.00/more-insmod-arches.patch15
4 files changed, 19 insertions, 17 deletions
diff --git a/sys-apps/busybox/busybox-1.00-r4.ebuild b/sys-apps/busybox/busybox-1.00-r4.ebuild
index ffd66d85fa5b..5b08174e6db5 100644
--- a/sys-apps/busybox/busybox-1.00-r4.ebuild
+++ b/sys-apps/busybox/busybox-1.00-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r4.ebuild,v 1.16 2005/08/24 00:29:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00-r4.ebuild,v 1.17 2005/09/14 00:08:09 vapier Exp $
inherit eutils
@@ -60,6 +60,7 @@ src_unpack() {
epatch "${FILESDIR}"/1.00/busybox-read-timeout.patch
epatch "${FILESDIR}"/1.00/readlink-follow.patch
epatch "${FILESDIR}"/1.00/more-insmod-arches.patch
+ epatch "${FILESDIR}"/1.00/fix-amd64-insmod.patch
epatch "${FILESDIR}"/1.00/bash-tests.patch
epatch "${FILESDIR}"/1.00/cp-posix-opts.patch
epatch "${FILESDIR}"/1.00/standalone.patch
diff --git a/sys-apps/busybox/busybox-1.01.ebuild b/sys-apps/busybox/busybox-1.01.ebuild
index cc669aed2874..a784708d6c13 100644
--- a/sys-apps/busybox/busybox-1.01.ebuild
+++ b/sys-apps/busybox/busybox-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.01.ebuild,v 1.2 2005/08/24 00:29:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.01.ebuild,v 1.3 2005/09/14 00:08:09 vapier Exp $
inherit eutils
@@ -59,6 +59,7 @@ src_unpack() {
# patches for 1.00 go here.
epatch "${FILESDIR}"/1.00/busybox-read-timeout.patch
epatch "${FILESDIR}"/1.00/readlink-follow.patch
+ epatch "${FILESDIR}"/1.00/more-insmod-arches.patch
epatch "${FILESDIR}"/1.00/bash-tests.patch
epatch "${FILESDIR}"/1.00/standalone.patch
epatch "${FILESDIR}"/1.00/nice.patch
diff --git a/sys-apps/busybox/files/1.00/fix-amd64-insmod.patch b/sys-apps/busybox/files/1.00/fix-amd64-insmod.patch
new file mode 100644
index 000000000000..8d60f0650066
--- /dev/null
+++ b/sys-apps/busybox/files/1.00/fix-amd64-insmod.patch
@@ -0,0 +1,15 @@
+Index: modutils/insmod.c
+===================================================================
+--- modutils/insmod.c (revision 9620)
++++ modutils/insmod.c (revision 10061)
+@@ -290,8 +290,8 @@
+ /* X86_64 */
+ #if defined(__x86_64__)
+ #define MATCH_MACHINE(x) (x == EM_X86_64)
+-#define SHT_RELM SHT_REL
+-#define Elf64_RelM Elf64_Rel
++#define SHT_RELM SHT_RELA
++#define Elf64_RelM Elf64_Rela
+ #define ELFCLASSM ELFCLASS64
+ #endif
+
diff --git a/sys-apps/busybox/files/1.00/more-insmod-arches.patch b/sys-apps/busybox/files/1.00/more-insmod-arches.patch
index 42e1f88708bd..3056942b94a1 100644
--- a/sys-apps/busybox/files/1.00/more-insmod-arches.patch
+++ b/sys-apps/busybox/files/1.00/more-insmod-arches.patch
@@ -41,18 +41,3 @@ diff -u -r1.125 -r1.126
/* H8/300 */
#if defined(__H8300H__) || defined(__H8300S__)
#define MATCH_MACHINE(x) (x == EM_H8_300)
-Index: modutils/insmod.c
-===================================================================
---- modutils/insmod.c (revision 9620)
-+++ modutils/insmod.c (revision 10061)
-@@ -290,8 +290,8 @@
- /* X86_64 */
- #if defined(__x86_64__)
- #define MATCH_MACHINE(x) (x == EM_X86_64)
--#define SHT_RELM SHT_REL
--#define Elf64_RelM Elf64_Rel
-+#define SHT_RELM SHT_RELA
-+#define Elf64_RelM Elf64_Rela
- #define ELFCLASSM ELFCLASS64
- #endif
-