summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-07 02:45:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-07 02:45:59 +0000
commitc37dccd8ac24933ea8247255675f88ce977d61d9 (patch)
treed73621e78133c227f374575f84836aa1c8db47a0 /sys-apps/busybox
parentremove duplicate evas from DEPEND as pointed out by Marc-Andre Landry (diff)
downloadgentoo-2-c37dccd8ac24933ea8247255675f88ce977d61d9.tar.gz
gentoo-2-c37dccd8ac24933ea8247255675f88ce977d61d9.tar.bz2
gentoo-2-c37dccd8ac24933ea8247255675f88ce977d61d9.zip
fix nested break and abort if user config not found #141640
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.1.3.ebuild6
-rw-r--r--sys-apps/busybox/busybox-1.2.0.ebuild5
-rw-r--r--sys-apps/busybox/busybox-1.2.1.ebuild6
3 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/busybox/busybox-1.1.3.ebuild b/sys-apps/busybox/busybox-1.1.3.ebuild
index 545282638a9b..f3eec6282a01 100644
--- a/sys-apps/busybox/busybox-1.1.3.ebuild
+++ b/sys-apps/busybox/busybox-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.13 2006/08/05 20:04:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.14 2006/08/07 02:45:59 vapier Exp $
inherit eutils flag-o-matic
@@ -77,14 +77,14 @@ src_unpack() {
break
fi
done
+ [[ -e .config ]] && break
done
if [[ -r ${S}/.config ]] ; then
einfo "Found your ${configfile} and using it."
yes "" | make oldconfig > /dev/null
return 0
else
- einfo "Could not locate user configfile, going with default"
- yes "" | make oldconfig > /dev/null
+ die "Could not locate user configfile, please fix"
fi
fi
if use netboot ; then
diff --git a/sys-apps/busybox/busybox-1.2.0.ebuild b/sys-apps/busybox/busybox-1.2.0.ebuild
index a25bab7ab5f0..40a6248c12cc 100644
--- a/sys-apps/busybox/busybox-1.2.0.ebuild
+++ b/sys-apps/busybox/busybox-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.5 2006/08/05 20:04:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.6 2006/08/07 02:45:59 vapier Exp $
inherit eutils flag-o-matic
@@ -77,11 +77,14 @@ src_unpack() {
break
fi
done
+ [[ -e .config ]] && break
done
if [[ -r ${S}/.config ]] ; then
einfo "Found your ${configfile} and using it."
yes "" | make oldconfig > /dev/null
return 0
+ else
+ die "Could not locate user configfile, please fix"
fi
fi
if use netboot ; then
diff --git a/sys-apps/busybox/busybox-1.2.1.ebuild b/sys-apps/busybox/busybox-1.2.1.ebuild
index 454dd1abe00e..1a4621a364a4 100644
--- a/sys-apps/busybox/busybox-1.2.1.ebuild
+++ b/sys-apps/busybox/busybox-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.1 2006/08/05 20:06:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.2 2006/08/07 02:45:59 vapier Exp $
inherit eutils flag-o-matic
@@ -77,14 +77,14 @@ src_unpack() {
break
fi
done
+ [[ -e .config ]] && break
done
if [[ -r ${S}/.config ]] ; then
einfo "Found your ${configfile} and using it."
yes "" | make oldconfig > /dev/null
return 0
else
- einfo "Could not locate user configfile, going with default"
- yes "" | make oldconfig > /dev/null
+ die "Could not locate user configfile, please fix"
fi
fi
if use netboot ; then