summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-02 18:59:14 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-02 18:59:14 +0000
commit8634bafd4bd7c046b4b633f3aae5ed47bf87f3bf (patch)
tree0cfff33160ecc6e7ff3edb4d0d95cc877bfeb9cd /sys-apps/busybox
parentUpdate contrib extras, per bug #434098. (diff)
downloadgentoo-2-8634bafd4bd7c046b4b633f3aae5ed47bf87f3bf.tar.gz
gentoo-2-8634bafd4bd7c046b4b633f3aae5ed47bf87f3bf.tar.bz2
gentoo-2-8634bafd4bd7c046b4b633f3aae5ed47bf87f3bf.zip
Make USE=static the default to reflect what we have always been doing (building /bin/bb statically), and depend on libselinux[static-libs] as need be #436752 by Alphat-PC.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog8
-rw-r--r--sys-apps/busybox/busybox-1.20.2.ebuild37
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild38
-rw-r--r--sys-apps/busybox/metadata.xml1
4 files changed, 25 insertions, 59 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index be425a95398a..404eb9d473dc 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.330 2012/10/20 19:39:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.331 2012/11/02 18:59:14 vapier Exp $
+
+ 02 Nov 2012; Mike Frysinger <vapier@gentoo.org> busybox-1.20.2.ebuild,
+ busybox-9999.ebuild, metadata.xml:
+ Make USE=static the default to reflect what we have always been doing
+ (building /bin/bb statically), and depend on libselinux[static-libs] as need
+ be #436752 by Alphat-PC.
20 Oct 2012; Mike Frysinger <vapier@gentoo.org>
+files/busybox-1.20.2-selinux-pkg-config.patch, busybox-1.20.2.ebuild:
diff --git a/sys-apps/busybox/busybox-1.20.2.ebuild b/sys-apps/busybox/busybox-1.20.2.ebuild
index c355a70e9f73..3c1c0d74be95 100644
--- a/sys-apps/busybox/busybox-1.20.2.ebuild
+++ b/sys-apps/busybox/busybox-1.20.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.20.2.ebuild,v 1.11 2012/10/20 19:39:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.20.2.ebuild,v 1.12 2012/11/02 18:59:14 vapier Exp $
EAPI="4"
inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
@@ -57,12 +57,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="ipv6 livecd make-symlinks math mdev -pam selinux sep-usr static systemd"
+IUSE="ipv6 livecd make-symlinks math mdev -pam selinux sep-usr +static systemd"
RESTRICT="test"
-RDEPEND="selinux? ( sys-libs/libselinux )
+RDEPEND="!static? ( selinux? ( sys-libs/libselinux ) )
pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}
+ static? ( selinux? ( sys-libs/libselinux[static-libs(+)] ) )
>=sys-kernel/linux-headers-2.6.39"
S=${WORKDIR}/${MY_P}
@@ -154,9 +155,7 @@ src_configure() {
if use static && use pam ; then
ewarn "You cannot have USE='static pam'. Assuming static is more important."
fi
- use static \
- && busybox_config_option n PAM \
- || busybox_config_option pam PAM
+ busybox_config_option $(usex static n pam) PAM
busybox_config_option static STATIC
busybox_config_option systemd FEATURE_SYSTEMD
busybox_config_option math FEATURE_AWK_LIBM
@@ -203,18 +202,6 @@ src_compile() {
export SKIP_STRIP=y
emake V=1 busybox
- if ! use static ; then
- cp .config{,.bak}
- mv busybox_unstripped{,.bak}
- use pam && busybox_config_option n PAM
- emake CONFIG_STATIC=y busybox
- mv busybox_unstripped bb
- mv busybox_unstripped{.bak,}
- mv .config{.bak,}
- else
- # keeps src_install simpler
- ln busybox_unstripped bb
- fi
}
src_install() {
@@ -226,20 +213,12 @@ src_install() {
if use sep-usr ; then
# install /ginit to take care of mounting stuff
exeinto /
- newexe bb ginit
+ newexe busybox_unstripped ginit
dosym /ginit /bin/bb
- if use static ; then
- dosym bb /bin/busybox
- else
- newbin busybox_unstripped busybox
- fi
+ dosym bb /bin/busybox
else
newbin busybox_unstripped busybox
- if use static ; then
- dosym busybox /bin/bb
- else
- dobin bb
- fi
+ dosym busybox /bin/bb
fi
if use mdev ; then
dodir /$(get_libdir)/mdev/
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 74f4463efe49..25648d81ff82 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.6 2012/10/03 18:51:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.7 2012/11/02 18:59:14 vapier Exp $
EAPI="4"
inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
@@ -57,12 +57,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="ipv6 livecd make-symlinks math mdev -pam selinux sep-usr static systemd"
+IUSE="ipv6 livecd make-symlinks math mdev -pam selinux sep-usr +static systemd"
RESTRICT="test"
-RDEPEND="selinux? ( sys-libs/libselinux )
+RDEPEND="!static? ( selinux? ( sys-libs/libselinux ) )
pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}
+ static? ( selinux? ( sys-libs/libselinux[static-libs(+)] ) )
>=sys-kernel/linux-headers-2.6.39"
S=${WORKDIR}/${MY_P}
@@ -102,6 +103,7 @@ src_prepare() {
-e "/^AR\>/s:=.*:= $(tc-getAR):" \
-e "/^CC\>/s:=.*:= $(tc-getCC):" \
-e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ -e "/^PKG_CONFIG\>/s:=.*:= $(tc-getPKG_CONFIG):" \
Makefile || die
sed -i \
-e 's:-static-libgcc::' \
@@ -152,9 +154,7 @@ src_configure() {
if use static && use pam ; then
ewarn "You cannot have USE='static pam'. Assuming static is more important."
fi
- use static \
- && busybox_config_option n PAM \
- || busybox_config_option pam PAM
+ busybox_config_option $(usex static n pam) PAM
busybox_config_option static STATIC
busybox_config_option systemd FEATURE_SYSTEMD
busybox_config_option math FEATURE_AWK_LIBM
@@ -201,18 +201,6 @@ src_compile() {
export SKIP_STRIP=y
emake V=1 busybox
- if ! use static ; then
- cp .config{,.bak}
- mv busybox_unstripped{,.bak}
- use pam && busybox_config_option n PAM
- emake CONFIG_STATIC=y busybox
- mv busybox_unstripped bb
- mv busybox_unstripped{.bak,}
- mv .config{.bak,}
- else
- # keeps src_install simpler
- ln busybox_unstripped bb
- fi
}
src_install() {
@@ -224,20 +212,12 @@ src_install() {
if use sep-usr ; then
# install /ginit to take care of mounting stuff
exeinto /
- newexe bb ginit
+ newexe busybox_unstripped ginit
dosym /ginit /bin/bb
- if use static ; then
- dosym bb /bin/busybox
- else
- newbin busybox_unstripped busybox
- fi
+ dosym bb /bin/busybox
else
newbin busybox_unstripped busybox
- if use static ; then
- dosym busybox /bin/bb
- else
- dobin bb
- fi
+ dosym busybox /bin/bb
fi
if use mdev ; then
dodir /$(get_libdir)/mdev/
diff --git a/sys-apps/busybox/metadata.xml b/sys-apps/busybox/metadata.xml
index db1a236ae87d..72850fbb6817 100644
--- a/sys-apps/busybox/metadata.xml
+++ b/sys-apps/busybox/metadata.xml
@@ -7,6 +7,7 @@
<flag name="math">Enable math support in gawk (requires libm)</flag>
<flag name="mdev">Create the appropriate symlink in /sbin and install mdev.conf and support files</flag>
<flag name="sep-usr">Support a separate /usr without needing an initramfs by booting with init=/ginit</flag>
+<flag name="static">Make the system rescue shell (/bin/bb) static so you can recover even when glibc is broken</flag>
<flag name="systemd">Support systemd</flag>
</use>
</pkgmetadata>