summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-08-19 17:51:19 +0000
committerZac Medico <zmedico@gentoo.org>2008-08-19 17:51:19 +0000
commitb2e3d9dfdc95db41db9eed30d3ef7fe4ac7e8d82 (patch)
tree3925a43cf60b400e96f2284f9380a192e42ec769 /sys-apps/baselayout
parentStable on sparc, bug #235028 (diff)
downloadgentoo-2-b2e3d9dfdc95db41db9eed30d3ef7fe4ac7e8d82.tar.gz
gentoo-2-b2e3d9dfdc95db41db9eed30d3ef7fe4ac7e8d82.tar.bz2
gentoo-2-b2e3d9dfdc95db41db9eed30d3ef7fe4ac7e8d82.zip
Avoid potential warning messages in the SYMLINK_LIB code which may be
triggered when find traverses a directory whose parent has already been merged from lib to lib64. (Portage version: 2.2_rc8_p11419/cvs/Linux 2.6.26-0810-x86-64 i686)
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/ChangeLog7
-rw-r--r--sys-apps/baselayout/baselayout-2.0.0.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 53985ce49e58..b0ab0ddd9f30 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for sys-apps/baselayout
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.469 2008/08/19 06:12:52 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.470 2008/08/19 17:51:19 zmedico Exp $
# See the rc-scripts ChangeLog in subversion for release info:
# http://sources.gentoo.org/viewcvs.py/*checkout*/baselayout/trunk/ChangeLog
19 Aug 2008; Zac Medico <zmedico@gentoo.org> baselayout-2.0.0.ebuild:
+ Avoid potential warning messages in the SYMLINK_LIB code which may be
+ triggered when find traverses a directory whose parent has already been
+ merged from lib to lib64.
+
+ 19 Aug 2008; Zac Medico <zmedico@gentoo.org> baselayout-2.0.0.ebuild:
Make the SYMLINK_LIB code in pkg_preinst merge files from lib directories
to lib64 directories when necessary, instead of blindly wiping out the
content of the lib dir. Thanks to Daniel Robbins for finding the cause of
diff --git a/sys-apps/baselayout/baselayout-2.0.0.ebuild b/sys-apps/baselayout/baselayout-2.0.0.ebuild
index c2c1991d229e..926409d53a04 100644
--- a/sys-apps/baselayout/baselayout-2.0.0.ebuild
+++ b/sys-apps/baselayout/baselayout-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.0.0.ebuild,v 1.6 2008/08/19 06:12:52 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.0.0.ebuild,v 1.7 2008/08/19 17:51:19 zmedico Exp $
inherit multilib
@@ -69,6 +69,11 @@ pkg_preinst() {
# Move directories if the dest doesn't exist.
find "$srcdir" -type d -print0 | \
while read -d $'\0' src ; do
+
+ # If a parent directory of $src has already
+ # been merged then it will no longer exist.
+ [ -d "$src" ] || continue
+
dest=$destdir${src#${srcdir}}
if [ ! -d "$dest" ] ; then
if [ -e "$dest" ] ; then