summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-03 00:43:20 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-03 00:43:20 +0000
commit803ec660c49cd98cc18966cdf3ac52bf6bc4f875 (patch)
tree77606672f80fa0c822df1b04df8aaec3a715b0ec /sys-apps/baselayout
parentAdd patch from upstream. (diff)
downloadgentoo-2-803ec660c49cd98cc18966cdf3ac52bf6bc4f875.tar.gz
gentoo-2-803ec660c49cd98cc18966cdf3ac52bf6bc4f875.tar.bz2
gentoo-2-803ec660c49cd98cc18966cdf3ac52bf6bc4f875.zip
tweak style in previous commit
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-2.0.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-apps/baselayout/baselayout-2.0.0.ebuild b/sys-apps/baselayout/baselayout-2.0.0.ebuild
index a17351fecb32..050efb429d55 100644
--- a/sys-apps/baselayout/baselayout-2.0.0.ebuild
+++ b/sys-apps/baselayout/baselayout-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.0.0.ebuild,v 1.8 2009/03/02 20:17:47 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.0.0.ebuild,v 1.9 2009/03/03 00:43:20 vapier Exp $
inherit multilib
@@ -166,6 +166,8 @@ src_install() {
}
pkg_postinst() {
+ local x
+
# We installed some files to /usr/share/baselayout instead of /etc to stop
# (1) overwriting the user's settings
# (2) screwing things up when attempting to merge files
@@ -177,9 +179,9 @@ pkg_postinst() {
cp -p "${ROOT}usr/share/baselayout/${x}" "${ROOT}"etc
done
- # fix shadow permissions to not be world-readable
+ # Force shadow permissions to not be world-readable #260993
for x in shadow ; do
- [ -e "${ROOT}etc/${x}" ] && chmod 0600 "${ROOT}etc/$x"
+ [ -e "${ROOT}etc/${x}" ] && chmod 0600 "${ROOT}etc/${x}"
done
# This is also written in src_install (so it's in CONTENTS), but