summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2005-03-06 22:15:58 +0000
committerBrian Jackson <iggy@gentoo.org>2005-03-06 22:15:58 +0000
commit4c97728b7701507428911a9dad2a84ce9675f494 (patch)
treee7dfe7cf69d3aa2367aaaf511ec8ca3fbc17c9d8 /sys-apps/baselayout-lite
parentProduces bad 32bit static libs on amd64, so grub fails. 2.15.94.0.2.2 works f... (diff)
downloadgentoo-2-4c97728b7701507428911a9dad2a84ce9675f494.tar.gz
gentoo-2-4c97728b7701507428911a9dad2a84ce9675f494.tar.bz2
gentoo-2-4c97728b7701507428911a9dad2a84ce9675f494.zip
pre2 release for testing
Diffstat (limited to 'sys-apps/baselayout-lite')
-rw-r--r--sys-apps/baselayout-lite/ChangeLog8
-rw-r--r--sys-apps/baselayout-lite/baselayout-lite-1.0_pre2.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-apps/baselayout-lite/ChangeLog b/sys-apps/baselayout-lite/ChangeLog
index 730eaa8f709a..3e23f41c1450 100644
--- a/sys-apps/baselayout-lite/ChangeLog
+++ b/sys-apps/baselayout-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/baselayout-lite
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/ChangeLog,v 1.5 2005/03/01 23:58:46 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/ChangeLog,v 1.6 2005/03/06 22:15:58 iggy Exp $
+
+*baselayout-lite-1.0_pre2 (06 Mar 2005)
+
+ 06 Mar 2005; Brian Jackson <iggy@gentoo.org>
+ +baselayout-lite-1.0_pre2.ebuild:
+ pre2 release for testing
01 Mar 2005; <solar@gentoo.org> baselayout-lite-1.0_pre1.ebuild:
- make baselayout-lite provide virtual/baselayout
diff --git a/sys-apps/baselayout-lite/baselayout-lite-1.0_pre2.ebuild b/sys-apps/baselayout-lite/baselayout-lite-1.0_pre2.ebuild
new file mode 100644
index 000000000000..3376bcba0a09
--- /dev/null
+++ b/sys-apps/baselayout-lite/baselayout-lite-1.0_pre2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/baselayout-lite-1.0_pre2.ebuild,v 1.1 2005/03/06 22:15:58 iggy Exp $
+
+IUSE="build bootstrap uclibc"
+
+DESCRIPTION="Baselayout for embedded systems"
+HOMEPAGE="http://www.gentoo.org/proj/en/base/embedded/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~iggy/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+
+PROVIDE="virtual/baselayout"
+DEPEND="!virtual/baselayout"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ # the new tarball has the layout we want, just copy it straight to the
+ # output dir
+ cp -a ${S}/image/* ${D}
+ find ${D} -name CVS -exec rm -rf {} \;
+
+ [ -f $ROOT/proc/cpuinfo ] && rm -f ${D}/proc/.keep
+ use uclibc && rm -f ${D}/etc/nsswitch.conf
+ chmod 755 ${D}/etc/init.d/*
+
+ # compile the few things that need to be
+ cd ${S}/src
+ make || die "failed to compile the bits and pieces"
+ into /
+ dosbin rc runscript
+
+ # device node creation stuff
+ cd ${D}/dev || die
+ einfo "Making device nodes (this could take a minute or so...)"
+
+ MAKEDEV std
+ mknod -m 0600 console c 5 1
+
+ for i in 0 1 2 3 4; do
+ mknod -m 0660 hda${i/0} b 3 ${i}
+ mknod -m 0660 sda${i/0} b 8 ${i}
+ chown root:disk hda${i/0} sda${i/0}
+ mknod -m 0600 tty${i} c 4 ${i}
+ chown root:tty tty${i}
+ done
+
+ MAKEDEV ttyS0
+}
+
+pkg_postinst() {
+ # Touching /etc/passwd and /etc/shadow after install can be fatal, as many
+ # new users do not update them properly. thus remove all ._cfg files if
+ # we are not busy with a build.
+ if ! ( use build || use bootstrap )
+ then
+ ewarn "Removing invalid backup copies of critical config files..."
+ rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
+ fi
+
+ # Doing device node creation here, since portage doesnt record
+ # device nodes in CONTENTS
+
+ # (Jul 23 2004 -solar)
+ # Moved device node creation to src_install() so that we can get
+ # the device nods into a binary package which can then be
+ # installed on a host which does not have python/portage etc.
+}