summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-14 12:27:35 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-14 12:27:35 +0000
commite71f69eb55eaccaa47f9f435f8ccfb43911f46cd (patch)
tree24ffeccfe4c57d23cbc591fc2c848faa91c1b673 /sys-apps/attr
parentVersion bump. (diff)
downloadgentoo-2-e71f69eb55eaccaa47f9f435f8ccfb43911f46cd.tar.gz
gentoo-2-e71f69eb55eaccaa47f9f435f8ccfb43911f46cd.tar.bz2
gentoo-2-e71f69eb55eaccaa47f9f435f8ccfb43911f46cd.zip
old
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/attr-2.4.39.ebuild63
-rw-r--r--sys-apps/attr/attr-2.4.41.ebuild63
-rw-r--r--sys-apps/attr/files/attr-2.4.39-linguas.patch11
3 files changed, 0 insertions, 137 deletions
diff --git a/sys-apps/attr/attr-2.4.39.ebuild b/sys-apps/attr/attr-2.4.39.ebuild
deleted file mode 100644
index 41ec79c85c0e..000000000000
--- a/sys-apps/attr/attr-2.4.39.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.39.ebuild,v 1.12 2008/02/23 03:57:01 vapier Exp $
-
-inherit eutils autotools toolchain-funcs
-
-MY_P="${PN}_${PV}-1"
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
- ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.4.39-gettext.patch
- epatch "${FILESDIR}"/${PN}-2.4.39-linguas.patch #205948
- epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die "failed to update builddefs"
- # libtool will clobber install-sh which is really a custom file
- mv install-sh acl.install-sh || die
- AT_M4DIR="m4" eautoreconf
- mv acl.install-sh install-sh || die
- strip-linguas po
-}
-
-src_compile() {
- unset PLATFORM #184564
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --libexecdir=/usr/$(get_libdir) \
- --bindir=/bin \
- || die
- emake || die
-}
-
-src_install() {
- emake DIST_ROOT="${D}" install install-lib install-dev || die
- # the man-pages packages provides the man2 files
- rm -r "${D}"/usr/share/man/man2
- prepalldocs
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
- gen_usr_ldscript libattr.so
-}
diff --git a/sys-apps/attr/attr-2.4.41.ebuild b/sys-apps/attr/attr-2.4.41.ebuild
deleted file mode 100644
index 4e1b63716f4c..000000000000
--- a/sys-apps/attr/attr-2.4.41.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.41.ebuild,v 1.9 2008/12/16 17:56:50 jer Exp $
-
-inherit eutils autotools toolchain-funcs
-
-MY_P="${PN}_${PV}-1"
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
- ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.4.39-gettext.patch
- epatch "${FILESDIR}"/${PN}-2.4.39-linguas.patch #205948
- epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die "failed to update builddefs"
- # libtool will clobber install-sh which is really a custom file
- mv install-sh acl.install-sh || die
- AT_M4DIR="m4" eautoreconf
- mv acl.install-sh install-sh || die
- strip-linguas po
-}
-
-src_compile() {
- unset PLATFORM #184564
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --libexecdir=/usr/$(get_libdir) \
- --bindir=/bin \
- || die
- emake || die
-}
-
-src_install() {
- emake DIST_ROOT="${D}" install install-lib install-dev || die
- # the man-pages packages provides the man2 files
- rm -r "${D}"/usr/share/man/man2
- prepalldocs
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
- gen_usr_ldscript libattr.so
-}
diff --git a/sys-apps/attr/files/attr-2.4.39-linguas.patch b/sys-apps/attr/files/attr-2.4.39-linguas.patch
deleted file mode 100644
index 0c3ce5a97dde..000000000000
--- a/sys-apps/attr/files/attr-2.4.39-linguas.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile
-+++ po/Makefile
-@@ -6,7 +6,7 @@
- include $(TOPDIR)/include/builddefs
-
- POTHEAD = $(PKG_NAME).pot
--LINGUAS = de es fr gl nl pl sv
-+LINGUAS ?= de es fr gl nl pl sv
- LSRCFILES = $(LINGUAS:%=%.po) $(POTHEAD)
- LDIRT = $(POTHEAD)
-