summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-23 03:54:46 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-23 03:54:46 +0000
commit1cc4fe2f3ecec539263a52defa4a94eff7e370d3 (patch)
tree8c094aa1c180e54eae7d1c9a0ca0424aff69fdef /sys-apps/attr
parentMake sure we respect LINGUAS #205948 by Arvid Norlander, update the ACL patch... (diff)
downloadgentoo-2-1cc4fe2f3ecec539263a52defa4a94eff7e370d3.tar.gz
gentoo-2-1cc4fe2f3ecec539263a52defa4a94eff7e370d3.tar.bz2
gentoo-2-1cc4fe2f3ecec539263a52defa4a94eff7e370d3.zip
old
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/attr-2.4.32.ebuild57
-rw-r--r--sys-apps/attr/attr-2.4.38.ebuild57
-rw-r--r--sys-apps/attr/files/attr-2.4.28-no-compress-docs.patch25
-rw-r--r--sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch14
4 files changed, 0 insertions, 153 deletions
diff --git a/sys-apps/attr/attr-2.4.32.ebuild b/sys-apps/attr/attr-2.4.32.ebuild
deleted file mode 100644
index 49069f300846..000000000000
--- a/sys-apps/attr/attr-2.4.32.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.32.ebuild,v 1.13 2007/03/26 08:00:17 antarus Exp $
-
-inherit eutils autotools toolchain-funcs
-
-MY_P="${PN}_${PV}-1"
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
- ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
- epatch "${FILESDIR}"/${PN}-2.4.28-no-compress-docs.patch
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die "failed to update builddefs"
- eautoconf
-}
-
-src_compile() {
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --libexecdir=/usr/$(get_libdir) \
- --bindir=/bin \
- || die
- emake || die
-}
-
-src_install() {
- emake DIST_ROOT="${D}" install install-lib install-dev || die
- # the man-pages packages provides the man2 files
- rm -r "${D}"/usr/share/man/man2
- prepalldocs
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
- gen_usr_ldscript libattr.so
-}
diff --git a/sys-apps/attr/attr-2.4.38.ebuild b/sys-apps/attr/attr-2.4.38.ebuild
deleted file mode 100644
index b79302dfa217..000000000000
--- a/sys-apps/attr/attr-2.4.38.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.38.ebuild,v 1.11 2007/12/11 10:18:34 vapier Exp $
-
-inherit eutils autotools toolchain-funcs
-
-MY_P="${PN}_${PV}-1"
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
- ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
- epatch "${FILESDIR}"/${PN}-2.4.38-LDFLAGS.patch
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
- include/builddefs.in \
- || die "failed to update builddefs"
- eautoconf
-}
-
-src_compile() {
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- $(use_enable nls gettext) \
- --libexecdir=/usr/$(get_libdir) \
- --bindir=/bin \
- || die
- emake || die
-}
-
-src_install() {
- emake DIST_ROOT="${D}" install install-lib install-dev || die
- # the man-pages packages provides the man2 files
- rm -r "${D}"/usr/share/man/man2
- prepalldocs
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
- gen_usr_ldscript libattr.so
-}
diff --git a/sys-apps/attr/files/attr-2.4.28-no-compress-docs.patch b/sys-apps/attr/files/attr-2.4.28-no-compress-docs.patch
deleted file mode 100644
index f257f99c9503..000000000000
--- a/sys-apps/attr/files/attr-2.4.28-no-compress-docs.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-let portage compress CHANGES
-
---- doc/Makefile
-+++ doc/Makefile
-@@ -10,18 +10,15 @@
- LSRCFILES = INSTALL PORTING CHANGES COPYING
- LDIRT = *.gz
-
--default: $(SUBDIRS) CHANGES.gz
-+default: $(SUBDIRS)
- $(SUBDIRS_MAKERULE)
-
- include $(BUILDRULES)
-
--CHANGES.gz:
-- $(ZIP) --best -c < CHANGES > $@
--
- install: default
- $(SUBDIRS_MAKERULE)
- $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
-- $(INSTALL) -m 644 PORTING CHANGES.gz $(PKG_DOC_DIR)
-+ $(INSTALL) -m 644 PORTING CHANGES $(PKG_DOC_DIR)
- ifeq ($(PKG_DISTRIBUTION), debian)
- $(INSTALL) -S CHANGES.gz $(PKG_DOC_DIR)/changelog.gz
- else
diff --git a/sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch b/sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch
deleted file mode 100644
index f5f1ebb74f12..000000000000
--- a/sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-make sure the library link respects LDFLAGS
-
-http://oss.sgi.com/bugzilla/show_bug.cgi?id=642
-
---- include/buildmacros
-+++ include/buildmacros
-@@ -10,6 +10,7 @@
- # during the "dist" phase (packaging).
-
- LDFLAGS += $(LOADERFLAGS) $(LLDFLAGS)
-+LTLDFLAGS += $(LOADERFLAGS)
- LDLIBS = $(LLDLIBS) $(PLDLIBS) $(MALLOCLIB)
-
- MAKEOPTS = --no-print-directory