summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-08 11:03:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-08 11:03:23 +0000
commite220df7d118b0a4ca3aeb6980789385953e7a255 (patch)
tree9a3d21957e5d20d907f9c7079abacdab787690e7 /sys-apps/apmd
parentold (diff)
downloadgentoo-2-e220df7d118b0a4ca3aeb6980789385953e7a255.tar.gz
gentoo-2-e220df7d118b0a4ca3aeb6980789385953e7a255.tar.bz2
gentoo-2-e220df7d118b0a4ca3aeb6980789385953e7a255.zip
clean up, fix homepage to debian qa site since current one is spam
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/apmd')
-rw-r--r--sys-apps/apmd/apmd-3.2.2_p5.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-apps/apmd/apmd-3.2.2_p5.ebuild b/sys-apps/apmd/apmd-3.2.2_p5.ebuild
index 036b1e6db78b..cbc3a5f63466 100644
--- a/sys-apps/apmd/apmd-3.2.2_p5.ebuild
+++ b/sys-apps/apmd/apmd-3.2.2_p5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/apmd/apmd-3.2.2_p5.ebuild,v 1.12 2007/07/22 06:22:14 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apmd/apmd-3.2.2_p5.ebuild,v 1.13 2010/07/08 11:03:23 ssuominen Exp $
inherit eutils multilib toolchain-funcs
@@ -9,7 +9,7 @@ MY_P="${PN}_${MY_PV}"
PATCHV="${PV#*_p}"
DESCRIPTION="Advanced Power Management Daemon"
-HOMEPAGE="http://www.worldvisions.ca/~apenwarr/apmd/"
+HOMEPAGE="http://packages.qa.debian.org/a/apmd.html"
SRC_URI="mirror://debian/pool/main/a/apmd/${MY_P}.orig.tar.gz
mirror://debian/pool/main/a/apmd/${MY_P}-${PATCHV}.diff.gz"
@@ -45,35 +45,35 @@ src_unpack() {
-e 's:\(EXES=.*\)xapm:\1:' \
-e 's:\(.*\)\$(LT_INSTALL).*xapm.*$:\1echo:' \
"${S}"/Makefile \
- || die "sed failed"
+ || die
fi
# apmd is perfectly happy with system linux-headers
sed -e 's:-I/usr/src/linux/include::' -i "${S}"/Makefile
}
src_compile() {
- emake CC=$(tc-getCC) || die "emake failed"
+ emake CC=$(tc-getCC) || die
}
src_install() {
dodir /usr/sbin
make DESTDIR="${D}" PREFIX=/usr LIBDIR=/usr/$(get_libdir) install \
- || die "install failed"
+ || die
keepdir /etc/apm/{event.d,suspend.d,resume.d,other.d,scripts.d}
exeinto /etc/apm
- doexe debian/apmd_proxy || die "doexe failed"
+ doexe debian/apmd_proxy || die
dodoc AUTHORS apmsleep.README README debian/README.Debian \
- debian/changelog* debian/copyright*
+ debian/changelog*
doman *.1 *.8
# note: apmd_proxy.conf is currently disabled and not used, thus
# not installed - liquidx (01 Mar 2004)
- newconfd "${FILESDIR}"/apmd.confd apmd || die "newconfd failed"
- newinitd "${FILESDIR}"/apmd.rc6 apmd || die "newinitd failed"
+ newconfd "${FILESDIR}"/apmd.confd apmd || die
+ newinitd "${FILESDIR}"/apmd.rc6 apmd || die
use nls || rm -rf "${D}"/usr/share/man/fr
}