summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-29 02:28:11 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-29 02:28:11 +0000
commitf592ea482f99bf0db9b0942d54e64e398ac6f29b (patch)
treea0d867b83542134b76f0eb53b7ba92af354292ba /sys-apps/acl
parentVersion bump #113816 by Rodrigo Severo. (diff)
downloadgentoo-2-f592ea482f99bf0db9b0942d54e64e398ac6f29b.tar.gz
gentoo-2-f592ea482f99bf0db9b0942d54e64e398ac6f29b.tar.bz2
gentoo-2-f592ea482f99bf0db9b0942d54e64e398ac6f29b.zip
Version bump and build cleanup.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/ChangeLog8
-rw-r--r--sys-apps/acl/acl-2.2.32.ebuild54
-rw-r--r--sys-apps/acl/files/acl-2.2.32-only-symlink-when-needed.patch18
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.321
4 files changed, 80 insertions, 1 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 0596d84cc7e5..e7736ad65f37 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/acl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.43 2005/09/25 11:20:57 redhatter Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.44 2005/11/29 02:28:10 vapier Exp $
+
+*acl-2.2.32 (29 Nov 2005)
+
+ 29 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/acl-2.2.32-only-symlink-when-needed.patch, +acl-2.2.32.ebuild:
+ Version bump and build cleanup.
25 Sep 2005; Stuart Longland <redhatter@gentoo.org> acl-2.2.27.ebuild:
Marking stable as per bug #73278 (which has hung around for yonks)
diff --git a/sys-apps/acl/acl-2.2.32.ebuild b/sys-apps/acl/acl-2.2.32.ebuild
new file mode 100644
index 000000000000..20deef92263e
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.32.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.32.ebuild,v 1.1 2005/11/29 02:28:10 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls debug"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ use debug \
+ && export DEBUG=-DDEBUG \
+ || export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-dev install-lib || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libacl.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libacl.so
+}
diff --git a/sys-apps/acl/files/acl-2.2.32-only-symlink-when-needed.patch b/sys-apps/acl/files/acl-2.2.32-only-symlink-when-needed.patch
new file mode 100644
index 000000000000..387a08352e16
--- /dev/null
+++ b/sys-apps/acl/files/acl-2.2.32-only-symlink-when-needed.patch
@@ -0,0 +1,18 @@
+We dont want to generate symlinks when the libdir is the same as the
+devlibdir, otherwise we clobber the real files with broken symlinks
+
+--- include/buildmacros
++++ include/buildmacros
+@@ -102,9 +102,11 @@
+ ../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
+ ../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
+ ../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_LIB_DIR); \
++ if test "x$(PKG_DEVLIB_DIR)" != "x$(PKG_LIB_DIR)" ; then \
+ ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(PKG_LIB_DIR)/$(LIBNAME).a; \
+ ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(PKG_LIB_DIR)/$(LIBNAME).la; \
+- ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so
++ ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so; \
++ fi
+ else
+ INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
+ endif
diff --git a/sys-apps/acl/files/digest-acl-2.2.32 b/sys-apps/acl/files/digest-acl-2.2.32
new file mode 100644
index 000000000000..852df067b759
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.32
@@ -0,0 +1 @@
+MD5 85d2e73c5a3175b96d1d956c52835fe4 acl-2.2.32.src.tar.gz 149167