summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-11-28 18:26:23 +0000
committerJason Wever <weeve@gentoo.org>2003-11-28 18:26:23 +0000
commit9605ea21429f4c4db7a3dc9d27045588abc5f20f (patch)
tree96903f655c7d5155f3480c42c0bcea268f3a0842 /sys-apps/acl/acl-2.2.13.ebuild
parentAdded a fix for sparcs so attr will build. Not that we can use XFS yet, but ... (diff)
downloadgentoo-2-9605ea21429f4c4db7a3dc9d27045588abc5f20f.tar.gz
gentoo-2-9605ea21429f4c4db7a3dc9d27045588abc5f20f.tar.bz2
gentoo-2-9605ea21429f4c4db7a3dc9d27045588abc5f20f.zip
Fixed ebuilds for sparc, resolves bug #34611 (see for more details).
Diffstat (limited to 'sys-apps/acl/acl-2.2.13.ebuild')
-rw-r--r--sys-apps/acl/acl-2.2.13.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/acl/acl-2.2.13.ebuild b/sys-apps/acl/acl-2.2.13.ebuild
index 176da8ddd562..6270794b18be 100644
--- a/sys-apps/acl/acl-2.2.13.ebuild
+++ b/sys-apps/acl/acl-2.2.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13.ebuild,v 1.6 2003/10/02 04:29:37 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13.ebuild,v 1.7 2003/11/28 18:26:20 weeve Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Access control list utilities, libraries and headers"
@@ -30,6 +30,11 @@ src_compile() {
sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
-e 's:-O1::' include/builddefs.orig > include/builddefs || die
+ if [ "${ARCH}" = "sparc" ]; then
+ sed -i -e 's/sparc.*$/linux/' include/builddefs || \
+ die "failed to update builddefs for sparc"
+ fi
+
emake || die
}