summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-08 23:13:06 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-08 23:13:06 +0000
commite55b822eb9ed8ae44a1847814a6d4fd34e2dc95b (patch)
tree7f899575b6c270e9b6e5144da1f9adfcca03e435 /skel.ebuild
parentflac update (1.0.3) and repoman fixes too (diff)
downloadgentoo-2-e55b822eb9ed8ae44a1847814a6d4fd34e2dc95b.tar.gz
gentoo-2-e55b822eb9ed8ae44a1847814a6d4fd34e2dc95b.tar.bz2
gentoo-2-e55b822eb9ed8ae44a1847814a6d4fd34e2dc95b.zip
added SLOT and KEYWORDS
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild38
1 files changed, 31 insertions, 7 deletions
diff --git a/skel.ebuild b/skel.ebuild
index 6652a8772a10..256a2c252767 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -15,13 +15,41 @@
DESCRIPTION="This is a sample skeleton ebuild file"
# Homepage, not used by Portage directly but handy for developer reference
-HOMEPAGE="http://"
+HOMEPAGE="http://foo.bar.com"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
# License of the package. This must match the name of file(s) in
# /usr/portage/licenses/. For complex license combination see the developer
# docs on gentoo.org for details.
LICENSE=""
+# The SLOT variable is used to tell Portage if it's OK to keep multiple
+# versions of the same package installed at the same time. For example,
+# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
+# with 1.2.2), it would be optimal to instruct Portage to not remove
+# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
+# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
+# emerge clean understands SLOTs, and will keep the most recent version
+# of each SLOT and remove everything else.
+# Note that normal applications should use SLOT="0" if possible, since
+# there should only be exactly one version installed at a time.
+# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
+SLOT="1"
+
+# Using KEYWORDS, we can record masking information *inside* an ebuild
+# instead of relying on an external package.mask file. Right now, you
+# should set the KEYWORDS variable for every ebuild so that it contains
+# the names of all the architectures with which the ebuild works. We have
+# 4 official architecture names right now: "x86", "ppc", "sparc" and
+# "sparc64". So, if you've confirmed that your ebuild works on x86 and ppc,
+# you'd specify: KEYWORDS="x86"
+# For packages that are platform-independant (like Java, PHP or Perl
+# applications) specify KEYWORDS="*".
+KEYWORDS="x86"
+
# Build-time dependencies, such as
# ssl? ( >=openssl-0.9.6b )
# >=perl-5.6.1-r1
@@ -34,10 +62,6 @@ DEPEND=""
# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
#RDEPEND=""
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
-SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
-
# Source directory; the dir where the sources can be found (automatically
# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
# if you omit this line.
@@ -60,7 +84,7 @@ src_compile() {
# Note the use of --infodir and --mandir, above. This is to make
# this package FHS 2.2-compliant. For more information, see
# http://www.pathname.com/fhs/
-
+
# emake (previously known as pmake) is a script that calls the
# standard GNU make with parallel building options for speedier
# builds (especially on SMP systems). Try emake first. It might
@@ -73,7 +97,7 @@ src_compile() {
src_install () {
# You must *personally verify* that this trick doesn't install
# anything outside of DESTDIR; do this by reading and
- # understanding the install part of the Makefiles.
+ # understanding the install part of the Makefiles.
make DESTDIR=${D} install || die
# For Makefiles that don't make proper use of DESTDIR, setting
# prefix is often an alternative. However if you do this, then