summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-12-03 08:52:46 +0000
committerSven Vermeulen <swift@gentoo.org>2012-12-03 08:52:46 +0000
commit28283f0cbc14c95805e846773f8f80d4387280dd (patch)
tree3bf3d4987b9bf4b06ea503b3f790a8cee6a6cc8e /sec-policy/selinux-apache
parentfix typo, thanks tomwij (diff)
downloadgentoo-2-28283f0cbc14c95805e846773f8f80d4387280dd.tar.gz
gentoo-2-28283f0cbc14c95805e846773f8f80d4387280dd.tar.bz2
gentoo-2-28283f0cbc14c95805e846773f8f80d4387280dd.zip
Bumping to revision 8
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sec-policy/selinux-apache')
-rw-r--r--sec-policy/selinux-apache/ChangeLog9
-rw-r--r--sec-policy/selinux-apache/files/fix-make-gpg-optional-r8.patch52
-rw-r--r--sec-policy/selinux-apache/selinux-apache-2.20120725-r8.ebuild20
3 files changed, 79 insertions, 2 deletions
diff --git a/sec-policy/selinux-apache/ChangeLog b/sec-policy/selinux-apache/ChangeLog
index d5a6aaa5619a..8643349154fe 100644
--- a/sec-policy/selinux-apache/ChangeLog
+++ b/sec-policy/selinux-apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sec-policy/selinux-apache
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-apache/ChangeLog,v 1.45 2012/11/18 15:18:22 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-apache/ChangeLog,v 1.46 2012/12/03 08:52:31 swift Exp $
+
+*selinux-apache-2.20120725-r8 (03 Dec 2012)
+
+ 03 Dec 2012; Sven Vermeulen +files/fix-make-gpg-optional-r8.patch,
+ +selinux-apache-2.20120725-r8.ebuild:
+ Bumping to revision 8
*selinux-apache-2.20120725-r7 (18 Nov 2012)
@@ -206,4 +212,3 @@
03 Jan 2004; Chris PeBenito <pebenito@gentoo.org> :
Initial commit.
-
diff --git a/sec-policy/selinux-apache/files/fix-make-gpg-optional-r8.patch b/sec-policy/selinux-apache/files/fix-make-gpg-optional-r8.patch
new file mode 100644
index 000000000000..ce8aac34cbd4
--- /dev/null
+++ b/sec-policy/selinux-apache/files/fix-make-gpg-optional-r8.patch
@@ -0,0 +1,52 @@
+--- contrib/apache.te 2012-11-25 20:20:08.229745244 +0100
++++ contrib/apache.te 2012-11-24 20:02:13.095338898 +0100
+@@ -357,7 +357,6 @@
+
+ type httpd_gpg_t;
+ domain_type(httpd_gpg_t)
+-gpg_entry_type(httpd_gpg_t)
+ role system_r types httpd_gpg_t;
+
+ ifdef(`distro_gentoo',`
+@@ -586,10 +585,6 @@
+ allow httpd_t httpd_script_exec_type:dir list_dir_perms;
+ ')
+
+-tunable_policy(`httpd_enable_cgi && httpd_use_gpg',`
+- gpg_spec_domtrans(httpd_t, httpd_gpg_t)
+-')
+-
+ tunable_policy(`httpd_enable_cgi && httpd_use_nfs',`
+ fs_nfs_domtrans(httpd_t, httpd_sys_script_t)
+ ')
+@@ -677,6 +672,13 @@
+ ')
+
+ optional_policy(`
++ tunable_policy(`httpd_enable_cgi && httpd_use_gpg',`
++ gpg_spec_domtrans(httpd_t, httpd_gpg_t)
++ ')
++')
++
++
++optional_policy(`
+ tunable_policy(`httpd_mod_auth_ntlm_winbind',`
+ samba_domtrans_winbind_helper(httpd_t)
+ ')
+@@ -1398,7 +1400,6 @@
+
+ miscfiles_read_localization(httpd_gpg_t)
+
+-gpg_exec(httpd_gpg_t)
+
+ tunable_policy(`httpd_gpg_anon_write',`
+ miscfiles_manage_public_files(httpd_gpg_t)
+@@ -1407,3 +1408,8 @@
+ optional_policy(`
+ apache_manage_sys_rw_content(httpd_gpg_t)
+ ')
++
++optional_policy(`
++ gpg_entry_type(httpd_gpg_t)
++ gpg_exec(httpd_gpg_t)
++')
diff --git a/sec-policy/selinux-apache/selinux-apache-2.20120725-r8.ebuild b/sec-policy/selinux-apache/selinux-apache-2.20120725-r8.ebuild
new file mode 100644
index 000000000000..277653a5d046
--- /dev/null
+++ b/sec-policy/selinux-apache/selinux-apache-2.20120725-r8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-apache/selinux-apache-2.20120725-r8.ebuild,v 1.1 2012/12/03 08:52:31 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="apache"
+BASEPOL="2.20120725-r8"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for apache"
+
+KEYWORDS="~amd64 ~x86"
+DEPEND="${DEPEND}
+ sec-policy/selinux-kerberos
+"
+RDEPEND="${DEPEND}"
+
+POLICY_PATCH="${FILESDIR}/fix-make-gpg-optional-r8.patch"