summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-04-09 21:52:22 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-04-09 21:52:22 +0000
commitef3c05a6fbf1ca570b625ebf04e59dd3099dd05a (patch)
tree367b4bdea30e7ce2f57f44ac5783edb1b4c06f52 /sci-visualization
parentStable on amd64. (diff)
downloadgentoo-2-ef3c05a6fbf1ca570b625ebf04e59dd3099dd05a.tar.gz
gentoo-2-ef3c05a6fbf1ca570b625ebf04e59dd3099dd05a.tar.bz2
gentoo-2-ef3c05a6fbf1ca570b625ebf04e59dd3099dd05a.zip
Prune old version.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/opendx/ChangeLog5
-rw-r--r--sci-visualization/opendx/files/digest-opendx-4.3.21
-rw-r--r--sci-visualization/opendx/opendx-4.3.2.ebuild111
3 files changed, 4 insertions, 113 deletions
diff --git a/sci-visualization/opendx/ChangeLog b/sci-visualization/opendx/ChangeLog
index 155b9d325b90..358e6f7e5f79 100644
--- a/sci-visualization/opendx/ChangeLog
+++ b/sci-visualization/opendx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-visualization/opendx
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.2 2006/03/26 20:17:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.3 2006/04/09 21:52:22 cryos Exp $
+
+ 09 Apr 2006; Marcus D. Hanwell <cryos@gentoo.org> -opendx-4.3.2.ebuild:
+ Prune old version.
29 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+opendx-4.3.2.ebuild, +opendx-4.3.2-r1.ebuild:
diff --git a/sci-visualization/opendx/files/digest-opendx-4.3.2 b/sci-visualization/opendx/files/digest-opendx-4.3.2
deleted file mode 100644
index 189444d56482..000000000000
--- a/sci-visualization/opendx/files/digest-opendx-4.3.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 201afdd86a5ddcfda0dc60fc7b6d3fea dx-4.3.2.tar.gz 9904514
diff --git a/sci-visualization/opendx/opendx-4.3.2.ebuild b/sci-visualization/opendx/opendx-4.3.2.ebuild
deleted file mode 100644
index de5503ae1ab0..000000000000
--- a/sci-visualization/opendx/opendx-4.3.2.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.3.2.ebuild,v 1.1 2006/01/29 20:05:41 cryos Exp $
-
-# Set SMP="no" to force disable of SMP compilation.
-# Set SMP="yes" to force enable of SMP compilation.
-# Otherwise it will be autodetected from /usr/src/linux.
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A 3D data visualization tool"
-HOMEPAGE="http://www.opendx.org/"
-SRC_URI="http://opendx.npaci.edu/source/${P/open}.tar.gz"
-
-# There are a few jar files that can be added to enhance JX.
-# These are java40.jar from the Netscape libraries
-# (we've provided them in the OpenDX.org lib area) nscosmop211.jar
-# from the Cosmo Player libs.
-# http://opendx.npaci.edu/libs/
-#SRC_URI="${SRC_URI}
-# http://opendx.npaci.edu/libs/netscape-java40.tar.gz
-# http://opendx.npaci.edu/libs/cosmoplayer-jar.tar.gz"
-
-LICENSE="IPL-1"
-SLOT="0"
-# Should work on x86, ppc, alpha at least
-KEYWORDS="~x86 ~ppc"
-
-IUSE="hdf cdf netcdf tiff imagemagick" # java doc"
-
-DEPEND="virtual/x11
- x11-libs/openmotif
- sci-libs/szip
- hdf? ( sci-libs/hdf )
- cdf? ( sci-libs/cdf )
- netcdf? ( sci-libs/netcdf )
- tiff? ( media-libs/tiff )
- imagemagick? ( >=media-gfx/imagemagick-5.3.4 )"
-# waiting on bug #36349 for media-libs/jasper in imagemagick
-# java support gives some trouble - deprecated api and other unresolved symbols
-# java? ( virtual/jdk
-# dev-java/java-config )"
-
-S="${WORKDIR}/${P/open}"
-
-smp() {
- has "$1" "${SMP}"
-}
-
-smp_check() {
- if [ -e /usr/src/linux/.config ]
- then
- if [ "`grep SMP /usr/src/linux/.config | cut -d= -f2`" = "y" ]
- then
- return 0
- else
- return 1
- fi
- else
- die "SMP check failed. Make sure /usr/src/linux/.config exists."
- fi
-}
-
-src_compile() {
- local myconf="--with-x \
- --host=${CHOST}"
-
- # Check for SMP
- # This needs to be done for /usr/src/linux, NOT the running kernel
- # Allow override using smp().
- if smp no
- then
- myconf="${myconf} --disable-smp-linux"
- einfo "Disabling SMP capabilities"
- elif smp yes || smp_check
- then
- myconf="${myconf} --enable-smp-linux"
- einfo "Enabling SMP capabilities"
- else
- myconf="${myconf} --disable-smp-linux"
- einfo "Disabling SMP capabilities"
- fi
-
- # with gcc 3.3.2 I had an infinite loop on src/exec/libdx/zclipQ.c
- append-flags -fno-strength-reduce
-
- # szlib is used by hdf package, have to link with it here aswell
-
- local GENTOOARCH="${ARCH}"
- # opendx uses this variable
- unset ARCH
- # use java && myconf="${myconf} JNIPATH=$(java-config -O)/include:$(java-config -O)/include/linux"
- econf LIBS="-lsz" \
- `use_with cdf` \
- `use_with netcdf` \
- `use_with hdf` \
- `use_with tiff` \
- `use_with imagemagick magick` \
- ${myconf} || die
-
- # `use_with java javadx`
- # This is broken
- # `use_enable doc installhtml`
-
- make || die
- ARCH="${GENTOOARCH}"
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-}