summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-12-20 07:11:02 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-12-20 07:11:02 +0000
commite088ccd598cf4bafda08a98eb78e7a9a0663fe28 (patch)
tree059389bcd77ba3b8b4b7b52ec62995ce362b3a4b /sci-visualization
parentVersion bump (diff)
downloadgentoo-2-e088ccd598cf4bafda08a98eb78e7a9a0663fe28.tar.gz
gentoo-2-e088ccd598cf4bafda08a98eb78e7a9a0663fe28.tar.bz2
gentoo-2-e088ccd598cf4bafda08a98eb78e7a9a0663fe28.zip
Version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/qtiplot/ChangeLog11
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.4-gcc4.3.patch15
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch14
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.4-no-python.patch63
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.4-pro.patch143
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.4-sip.patch31
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.7.4.ebuild135
7 files changed, 411 insertions, 1 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index d3f6aaf46fa7..d5d225317a01 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.38 2008/12/18 22:57:38 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.39 2008/12/20 07:11:02 grozin Exp $
+
+*qtiplot-0.9.7.4 (20 Dec 2008)
+
+ 20 Dec 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/qtiplot-0.9.7.4-gcc4.3.patch,
+ +files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch,
+ +files/qtiplot-0.9.7.4-no-python.patch, +files/qtiplot-0.9.7.4-pro.patch,
+ +files/qtiplot-0.9.7.4-sip.patch, +qtiplot-0.9.7.4.ebuild:
+ Version bump
18 Dec 2008; Markus Dittrich <markusle@gentoo.org>
+files/qtiplot-0.9.7.3-sip.patch, qtiplot-0.9.7.3.ebuild:
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-gcc4.3.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-gcc4.3.patch
new file mode 100644
index 000000000000..639aa8d40d31
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-gcc4.3.patch
@@ -0,0 +1,15 @@
+# patch needed for providing the proper includes needed for
+# gcc-4.3 (08/25/2008)
+
+Index: qtiplot-0.9.7.4/qtiplot/src/plot2D/ScaleEngine.cpp
+===================================================================
+--- qtiplot-0.9.7.4.orig/qtiplot/src/plot2D/ScaleEngine.cpp
++++ qtiplot-0.9.7.4/qtiplot/src/plot2D/ScaleEngine.cpp
+@@ -27,6 +27,7 @@
+ * *
+ ***************************************************************************/
+ #include "ScaleEngine.h"
++#include <limits.h>
+
+ QwtScaleTransformation* ScaleEngine::transformation() const
+ {
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch
new file mode 100644
index 000000000000..0e6c1bbb8f10
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-liborigin-gcc4.3.patch
@@ -0,0 +1,14 @@
+# fix gcc-4.3 missing headers
+
+Index: qtiplot-0.9.7.4/3rdparty/liborigin/OriginObj.h
+===================================================================
+--- qtiplot-0.9.7.4.orig/3rdparty/liborigin/OriginObj.h
++++ qtiplot-0.9.7.4/3rdparty/liborigin/OriginObj.h
+@@ -33,6 +33,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstring>
+ #include "boost/variant.hpp"
+ #include "boost/date_time/posix_time/ptime.hpp"
+
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-no-python.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-no-python.patch
new file mode 100644
index 000000000000..de2db4c7811b
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-no-python.patch
@@ -0,0 +1,63 @@
+Index: qtiplot-0.9.7.4/qtiplot/src/scripting/ScriptEdit.cpp
+===================================================================
+--- qtiplot-0.9.7.4.orig/qtiplot/src/scripting/ScriptEdit.cpp
++++ qtiplot-0.9.7.4/qtiplot/src/scripting/ScriptEdit.cpp
+@@ -28,7 +28,11 @@
+ ***************************************************************************/
+ #include "ScriptEdit.h"
+ #include "Note.h"
++
++#ifdef SCRIPTING_PYTHON
+ #include "PythonSyntaxHighlighter.h"
++#endif
++
+ #include "FindReplaceDialog.h"
+
+ #include <QAction>
+@@ -58,9 +62,11 @@ ScriptEdit::ScriptEdit(ScriptingEnv *env
+ setTextFormat(Qt::PlainText);
+ setAcceptRichText (false);
+
++#ifdef SCRIPTING_PYTHON
+ if (scriptEnv->name() == QString("Python"))
+ d_highlighter = new PythonSyntaxHighlighter(this);
+-
++#endif
++
+ d_fmt_default.setBackground(palette().brush(QPalette::Base));
+ d_fmt_failure.setBackground(QBrush(QColor(255,128,128)));
+
+@@ -142,6 +148,7 @@ void ScriptEdit::customEvent(QEvent *e)
+ connect(myScript, SIGNAL(error(const QString&, const QString&, int)), this, SLOT(insertErrorMsg(const QString&)));
+ connect(myScript, SIGNAL(print(const QString&)), this, SLOT(scriptPrint(const QString&)));
+
++#ifdef SCRIPTING_PYTHON
+ if (scriptEnv->name() == QString("Python") && !d_highlighter)
+ d_highlighter = new PythonSyntaxHighlighter(this);
+ else {
+@@ -149,6 +156,7 @@ void ScriptEdit::customEvent(QEvent *e)
+ delete d_highlighter;
+ d_highlighter = 0;
+ }
++#endif
+ }
+ }
+
+@@ -585,13 +593,16 @@ void ScriptEdit::setDirPath(const QStrin
+
+ void ScriptEdit::rehighlight()
+ {
++#ifdef SCRIPTING_PYTHON
+ if (scriptEnv->name() != QString("Python"))
+ return;
+-
++#endif
+ if (d_highlighter)
+ delete d_highlighter;
+
++#ifdef SCRIPTING_PYTHON
+ d_highlighter = new PythonSyntaxHighlighter(this);
++#endif
+ }
+
+ void ScriptEdit::showFindDialog(bool replace)
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-pro.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-pro.patch
new file mode 100644
index 000000000000..9c170de02cd3
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-pro.patch
@@ -0,0 +1,143 @@
+Index: qtiplot-0.9.7.4/fitPlugins/explin/explin.pro
+===================================================================
+--- qtiplot-0.9.7.4.orig/fitPlugins/explin/explin.pro
++++ qtiplot-0.9.7.4/fitPlugins/explin/explin.pro
+@@ -12,12 +12,13 @@ CONFIG += dll
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++#INCLUDEPATH += ../../3rdparty/gsl/include/
++#LIBS += ../../3rdparty/gsl/lib/libgsl.a
++#LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++INCLUDEPATH += /usr/include/gsl
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+ INSTALLS += target
+Index: qtiplot-0.9.7.4/fitPlugins/exp_saturation/exp_saturation.pro
+===================================================================
+--- qtiplot-0.9.7.4.orig/fitPlugins/exp_saturation/exp_saturation.pro
++++ qtiplot-0.9.7.4/fitPlugins/exp_saturation/exp_saturation.pro
+@@ -12,12 +12,12 @@ CONFIG += dll
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++#LIBS += ../../3rdparty/gsl/lib/libgsl.a
++#LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++INCLUDEPATH += /usr/include/gsl
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+ INSTALLS += target
+Index: qtiplot-0.9.7.4/fitPlugins/fitRational0/fitRational0.pro
+===================================================================
+--- qtiplot-0.9.7.4.orig/fitPlugins/fitRational0/fitRational0.pro
++++ qtiplot-0.9.7.4/fitPlugins/fitRational0/fitRational0.pro
+@@ -12,12 +12,13 @@ CONFIG += dll
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++#INCLUDEPATH += ../../3rdparty/gsl/include/
++#LIBS += ../../3rdparty/gsl/lib/libgsl.a
++#LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++INCLUDEPATH += /usr/include/gsl
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+ INSTALLS += target
+Index: qtiplot-0.9.7.4/fitPlugins/fitRational1/fitRational1.pro
+===================================================================
+--- qtiplot-0.9.7.4.orig/fitPlugins/fitRational1/fitRational1.pro
++++ qtiplot-0.9.7.4/fitPlugins/fitRational1/fitRational1.pro
+@@ -12,12 +12,13 @@ CONFIG += dll
+ DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++#INCLUDEPATH += ../../3rdparty/gsl/include/
++#LIBS += ../../3rdparty/gsl/lib/libgsl.a
++#LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++INCLUDEPATH += /usr/include/gsl
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+ INSTALLS += target
+Index: qtiplot-0.9.7.4/qtiplot/qtiplot.pro
+===================================================================
+--- qtiplot-0.9.7.4.orig/qtiplot/qtiplot.pro
++++ qtiplot-0.9.7.4/qtiplot/qtiplot.pro
+@@ -20,7 +20,7 @@ win32:INCLUDEPATH += ../3rdparty/libpng/
+ win32:LIBS += ../3rdparty/libpng/libpng.a
+
+ # Uncomment the following line if you want to perform a custom installation using the *.path variables defined bellow.
+-#CONFIG += CustomInstall
++CONFIG += CustomInstall
+
+ CONFIG += release
+ #CONFIG += debug
+@@ -30,13 +30,12 @@ CONFIG += release
+ #!!! Warning: You must modify these paths according to your computer settings
+ #############################################################################
+
+-INCLUDEPATH += ../3rdparty/muparser/include
+-INCLUDEPATH += ../3rdparty/qwtplot3d/include
+-INCLUDEPATH += ../3rdparty/qwt/src
+-INCLUDEPATH += ../3rdparty/liborigin
+-INCLUDEPATH += ../3rdparty/gsl/include
+-INCLUDEPATH += ../3rdparty/zlib123/include
+-INCLUDEPATH += ../3rdparty/boost_1_36_0
++INCLUDEPATH += /usr/include/muparser
++INCLUDEPATH += ../3rdparty/qwtplot3d/include
++INCLUDEPATH += /usr/include/qwt5
++INCLUDEPATH += ../3rdparty/liborigin
++INCLUDEPATH += /usr/include/gsl
++INCLUDEPATH += /usr/include/boost
+
+ ##################### 3rd PARTY LIBRARIES SECTION ###########################
+ #!!! Warning: You must modify these paths according to your computer settings
+@@ -45,15 +44,15 @@ INCLUDEPATH += ../3rdparty/boost_1
+ ##################### Linux (Mac OS X) ######################################
+
+ # statically link against libraries in 3rdparty
+-unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
+-unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
+-unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
+-unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
+-unix:LIBS += /usr/local/lib/libboost_date_time-gcc41-mt.a
+-unix:LIBS += /usr/local/lib/libboost_thread-gcc41-mt.a
++#unix:LIBS += ../3rdparty/muparser/lib/libmuparser.a
++#unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
++#unix:LIBS += ../3rdparty/gsl/lib/libgsl.a
++#unix:LIBS += ../3rdparty/gsl/lib/libgslcblas.a
++#unix:LIBS += /usr/local/lib/libboost_date_time-gcc41-mt.a
++#unix:LIBS += /usr/local/lib/libboost_thread-gcc41-mt.a
+
+ # dynamically link against dependencies if they are installed system-wide
+-#unix:LIBS += -lmuparser
++unix:LIBS += -lmuparser -lqwt $$system(pkg-config --libs gsl) -lz -lboost_date_time -lboost_thread
+ #unix:LIBS += -lqwt
+ #unix:LIBS += -lgsl -lgslcblas
+
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-sip.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-sip.patch
new file mode 100644
index 000000000000..a55f62dbd886
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.4-sip.patch
@@ -0,0 +1,31 @@
+Index: qtiplot-0.9.7.4/qtiplot/src/scripting/qti.sip
+===================================================================
+--- qtiplot-0.9.7.4.orig/qtiplot/src/scripting/qti.sip
++++ qtiplot-0.9.7.4/qtiplot/src/scripting/qti.sip
+@@ -74,8 +74,6 @@ private:
+ MdiSubWindow(const MdiSubWindow&);
+ };
+
+-typedef QList<MdiSubWindow*> MDIWindowList;
+-
+ class Table: MdiSubWindow
+ {
+ %TypeHeaderCode
+@@ -1072,7 +1070,7 @@ public:
+ Graph3D* plotParametricSurface(const QString&, const QString&, const QString&,
+ double, double, double, double, int=40, int=40, bool=true, bool=true) /PyName=plot3D/;
+
+- MDIWindowList windowsList() /PyName=windows/;
++ QList<MdiSubWindow*> windowsList() /PyName=windows/;
+
+ // folders
+ Folder *activeFolder() /NoDerived/;
+@@ -1867,7 +1865,7 @@ class Folder : QObject
+ #include "src/core/Folder.h"
+ %End
+ public:
+- MDIWindowList windowsList() /PyName=windows/;
++ QList<MdiSubWindow*> windowsList() /PyName=windows/;
+ // TODO: implement signal Folder::nameChanged and make it update the project explorer; adjust renaming from GUI accordingly
+ // void setFolderName(const QString&) /PyName=setName/;
+ QString name();
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.4.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.4.ebuild
new file mode 100644
index 000000000000..bf5cbf0bcb45
--- /dev/null
+++ b/sci-visualization/qtiplot/qtiplot-0.9.7.4.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.4.ebuild,v 1.1 2008/12/20 07:11:02 grozin Exp $
+
+EAPI="1"
+inherit eutils multilib qt4 fdo-mime python
+
+DESCRIPTION="Qt based clone of the Origin plotting package"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2
+ doc? ( mirror://gentoo/${PN}-0.9.7-manual-en.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="python doc bindist"
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND=">=x11-libs/qwt-5.1
+ >=x11-libs/qwtplot3d-0.2.7
+ x11-libs/qt-gui:4
+ x11-libs/qt-qt3support:4
+ x11-libs/qt-assistant:4
+ >=dev-cpp/muParser-1.28
+ >=dev-libs/boost-1.35.0
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/sip-4.5.2 )"
+
+RDEPEND="${CDEPEND}
+ python? ( >=dev-lang/python-2.5
+ dev-python/PyQt4
+ dev-python/pygsl
+ sci-libs/scipy )"
+
+QT4_BUILT_WITH_USE_CHECK="qt3support"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-pro.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+ epatch "${FILESDIR}"/${P}-liborigin-gcc4.3.patch
+ epatch "${FILESDIR}"/${P}-no-python.patch
+ epatch "${FILESDIR}"/${P}-sip.patch
+
+ sed -i \
+ -e '/manual/d'\
+ -e '/3rd/d' \
+ qtiplot.pro || die "sed qtiplot.pro failed"
+
+ python_version
+
+ sed -i \
+ -e '/manual/d' \
+ -e "s:doc/${PN}:doc/${PF}:" \
+ -e "s:local/${PN}:$(get_libdir)/python${PYVER}/site-packages:" \
+ qtiplot/qtiplot.pro || die " sed for qtiplot/qtiplot.pro failed"
+
+ if ! use python; then
+ sed -i \
+ -e '/^SCRIPTING_LANGS += Python/d' \
+ -e '/sipcmd/d' \
+ qtiplot/qtiplot.pro || die "sed for python option failed"
+ fi
+
+ # the lib$$suff did not work in the fitRational*.pro files
+ pushd fitPlugins >& /dev/null
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ fit*/fitRational*.pro exp_saturation/*.pro explin/*.pro \
+ || die "sed fitRational* failed"
+ popd
+
+ for l in ${LANGS}; do
+ if ! use linguas_${l}; then
+ sed -i \
+ -e "s:translations/qtiplot_${l}.ts::" \
+ -e "s:translations/qtiplot_${l}.qm::" \
+ qtiplot/qtiplot.pro || die
+ fi
+ done
+}
+
+src_compile() {
+ eqmake4
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ rm -f "${D}"/usr/share/${PN}/translations/*.ts
+ use python && chmod -x "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/qti_wordlist.txt
+
+ newicon qtiplot_logo.png qtiplot.png
+ make_desktop_entry qtiplot QtiPlot qtiplot
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${WORKDIR}"/qtiplot-manual/* \
+ || die "install manual failed"
+ rm -rf "${D}"/usr/share/doc/${PF}/html/*/.svn
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ if use python; then
+ python_version
+ python_mod_compile \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/qti{plotrc,Util}.py
+ fi
+
+ if use doc; then
+ elog "On the first start, do Help -> Choose Help Folder"
+ elog "and select /usr/share/doc/${PF}/html"
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+
+ if use python; then
+ python_version
+ python_mod_cleanup
+ fi
+}