summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-07-22 19:21:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-07-22 19:21:49 +0000
commitd081a9ba8deb11ee3d3e0b9b4a4b3c3dc1e3b82a (patch)
tree1028912da3b47975a064b0d8d3ab7bc901f85155 /sci-visualization
parentarm/ia64/m68k/s390/sh/sparc stable wrt #322709 (diff)
downloadgentoo-2-d081a9ba8deb11ee3d3e0b9b4a4b3c3dc1e3b82a.tar.gz
gentoo-2-d081a9ba8deb11ee3d3e0b9b4a4b3c3dc1e3b82a.tar.bz2
gentoo-2-d081a9ba8deb11ee3d3e0b9b4a4b3c3dc1e3b82a.zip
Got rid of fortran eclass, switched to EAPI=3
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/grace/ChangeLog8
-rw-r--r--sci-visualization/grace/grace-5.1.22-r1.ebuild39
2 files changed, 16 insertions, 31 deletions
diff --git a/sci-visualization/grace/ChangeLog b/sci-visualization/grace/ChangeLog
index 41ff3b92df0a..8ba8cdd6e1ce 100644
--- a/sci-visualization/grace/ChangeLog
+++ b/sci-visualization/grace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/grace
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/grace/ChangeLog,v 1.41 2008/09/23 13:23:33 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/grace/ChangeLog,v 1.42 2010/07/22 19:21:49 bicatali Exp $
+
+ 22 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ grace-5.1.22-r1.ebuild:
+ Got rid of fortran eclass, switched to EAPI=3
23 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org>
-files/grace-5.1.21-stdc99.patch, -files/grace.desktop,
diff --git a/sci-visualization/grace/grace-5.1.22-r1.ebuild b/sci-visualization/grace/grace-5.1.22-r1.ebuild
index 6db5fafe01f4..14aa9b652def 100644
--- a/sci-visualization/grace/grace-5.1.22-r1.ebuild
+++ b/sci-visualization/grace/grace-5.1.22-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/grace/grace-5.1.22-r1.ebuild,v 1.6 2008/09/18 01:03:10 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/grace/grace-5.1.22-r1.ebuild,v 1.7 2010/07/22 19:21:49 bicatali Exp $
-EAPI="1"
-inherit eutils fortran
+EAPI=3
+inherit eutils toolchain-funcs
DESCRIPTION="Motif based XY-plotting tool"
HOMEPAGE="http://plasma-gate.weizmann.ac.il/Grace/"
@@ -28,18 +28,7 @@ DEPEND="x11-libs/openmotif
RDEPEND="${DEPEND}
x11-misc/xdg-utils"
-pkg_setup() {
- if use fortran; then
- FORTRAN="gfortran g77 ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
-
+src_prepare() {
# move tmpnam to mkstemp (adapted from debian)
epatch "${FILESDIR}"/${P}-mkstemp.patch
# fix configure instead of aclocal.m4
@@ -50,10 +39,6 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-dlmodule.patch
epatch "${FILESDIR}"/${P}-pdfdrv.patch
- # fix for glibc-2.7 (bug #217971)
- # removed (bug #231607)
- # epatch "${FILESDIR}"/${P}-stdc99.patch
-
# don't strip if not asked for
sed -i \
-e 's:$(INSTALL_PROGRAM) -s:$(INSTALL_PROGRAM):g' \
@@ -75,7 +60,7 @@ src_unpack() {
src_compile() {
local myconf
if use fortran; then
- myconf="--with-f77=${FORTRANC}"
+ myconf="--with-f77=$(tc-getFC)"
else
myconf="--without-f77"
fi
@@ -96,22 +81,18 @@ src_compile() {
$(use_enable jpeg jpegdrv) \
$(use_enable png pngdrv) \
$(use_enable pdf pdfdrv) \
- ${myconf} \
- || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGES ChangeLog DEVELOPERS README COPYRIGHT \
- || die "dodoc failed"
+ dodoc CHANGES ChangeLog DEVELOPERS README COPYRIGHT
dosym ../../${PN}/examples /usr/share/doc/${PF}/examples
dosym ../../${PN}/doc /usr/share/doc/${PF}/html
- doman "${D}"/usr/share/doc/${PF}/html/*.1
- rm -f "${D}"/usr/share/doc/${PF}/html/*.1
+ doman "${ED}"/usr/share/doc/${PF}/html/*.1
+ rm -f "${ED}"/usr/share/doc/${PF}/html/*.1
doicon "${FILESDIR}"/${PN}.png || die "failed installing icon"
make_desktop_entry xmgrace Grace grace
}