summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-01-09 07:05:24 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-01-09 07:05:24 +0000
commita08a3ef8a8743202bf38c4c7a1d4d908ed4bc6b1 (patch)
treeca3b941dc168a90ad436fce8b18519372e9e4058 /sci-visualization
parentold (diff)
downloadgentoo-2-a08a3ef8a8743202bf38c4c7a1d4d908ed4bc6b1.tar.gz
gentoo-2-a08a3ef8a8743202bf38c4c7a1d4d908ed4bc6b1.tar.bz2
gentoo-2-a08a3ef8a8743202bf38c4c7a1d4d908ed4bc6b1.zip
Version bump
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gle/ChangeLog10
-rw-r--r--sci-visualization/gle/files/gle-4.2.4-parallel.patch21
-rw-r--r--sci-visualization/gle/gle-4.2.4.ebuild108
3 files changed, 137 insertions, 2 deletions
diff --git a/sci-visualization/gle/ChangeLog b/sci-visualization/gle/ChangeLog
index f772716efc6b..59cbabc60f85 100644
--- a/sci-visualization/gle/ChangeLog
+++ b/sci-visualization/gle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/gle
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.15 2011/06/10 12:07:38 grozin Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/ChangeLog,v 1.16 2012/01/09 07:05:24 grozin Exp $
+
+*gle-4.2.4 (09 Jan 2012)
+
+ 09 Jan 2012; Andrey Grozin <grozin@gentoo.org> +gle-4.2.4.ebuild,
+ +files/gle-4.2.4-parallel.patch:
+ Version bump
10 Jun 2011; Andrey Grozin <grozin@gentoo.org> gle-4.2.3b.ebuild:
Fixed dependence with USE=qt4, thanks to fulvio ciriaco <oivulf@gmail.com>
diff --git a/sci-visualization/gle/files/gle-4.2.4-parallel.patch b/sci-visualization/gle/files/gle-4.2.4-parallel.patch
new file mode 100644
index 000000000000..1eff8c067102
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.4-parallel.patch
@@ -0,0 +1,21 @@
+--- src/gui/MakefileAC.in.orig 2010-01-06 20:10:04.000000000 +0000
++++ src/gui/MakefileAC.in 2010-01-06 20:21:15.000000000 +0000
+@@ -84,14 +84,14 @@
+ qmake:
+ $(QMAKE_PROG) $(QMAKE_OPTS)
+
+-domake:
+- $(MAKE_PROG)
++domake: Makefile
++ $(MAKE)
+
+-repmake:
++repmake: Makefile
+ perl ../../platform/autopackage/qt-replace.pl Makefile
+
+ doclean:
+- -$(MAKE_PROG) clean
++ -$(MAKE) clean
+ -@$(RM) qgle install_qgle_name_mac Makefile
+ -@$(RMDIR) moc
+ -@$(RMDIR) objects
diff --git a/sci-visualization/gle/gle-4.2.4.ebuild b/sci-visualization/gle/gle-4.2.4.ebuild
new file mode 100644
index 000000000000..a9e79e6161fe
--- /dev/null
+++ b/sci-visualization/gle/gle-4.2.4.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gle/gle-4.2.4.ebuild,v 1.1 2012/01/09 07:05:24 grozin Exp $
+
+EAPI=2
+inherit eutils elisp-common qt4-r2 flag-o-matic autotools
+
+DESCRIPTION="Graphics Layout Engine"
+HOMEPAGE="http://glx.sourceforge.net/"
+MY_P=${PN}-graphics-${PV}
+MAN_V=4.2.2
+SRC_URI="mirror://sourceforge/glx/${MY_P}f-src.tar.gz
+ doc? ( mirror://sourceforge/glx/${PN}-manual-${MAN_V}.pdf
+ mirror://sourceforge/glx/GLEusersguide.pdf )"
+SLOT="0"
+LICENSE="BSD-2 emacs? ( GPL-2 ) qt4? ( GPL-2 )"
+IUSE="X qt4 jpeg png tiff doc emacs vim-syntax"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ qt4? ( x11-libs/qt-opengl:4 )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl
+ virtual/latex-base
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel.patch
+ eaclocal
+ eautoconf
+}
+
+src_configure() {
+ # CPPFLAGS are understood as C++ flags
+ append-cppflags ${CXXFLAGS}
+ econf \
+ --without-rpath \
+ --with-manip \
+ $(use_with qt4 qt /usr) \
+ $(use_with X x) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use emacs; then
+ cd contrib/editors/highlighting
+ mv ${PN}-emacs.el ${PN}-mode.el
+ elisp-compile ${PN}-mode.el || die
+ fi
+}
+
+src_install() {
+ # -jN failed to install some data files
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ #emake DESTDIR="${D}" install || die "emake install failed"
+ rmdir "${D}"/usr/share/doc/gle-graphics || die "rmdir gle-graphics failed"
+ dodoc README.txt
+
+ if use qt4; then
+ newicon src/gui/images/gle_icon.png gle.png
+ make_desktop_entry qgle GLE gle
+ newdoc src/gui/readme.txt gui_readme.txt
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-manual-${MAN_V}.pdf \
+ "${DISTDIR}"/GLEusersguide.pdf
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/editors/highlighting/gle-mode.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/64gle-gentoo.el || die
+ fi
+
+ if use vim-syntax ; then
+ dodir /usr/share/vim/vimfiles/ftplugins \
+ /usr/share/vim/vimfiles/indent \
+ /usr/share/vim/vimfiles/syntax
+ cd contrib/editors/highlighting/vim
+ chmod 644 ftplugin/* indent/* syntax/*
+ insinto /usr/share/vim/vimfiles/ftplugins
+ doins ftplugin/* || die
+ insinto /usr/share/vim/vimfiles/indent
+ doins indent/* || die
+ insinto /usr/share/vim/vimfiles/syntax
+ doins syntax/* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}