summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-02-26 21:36:48 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-02-26 21:36:48 +0000
commit876542ff9437d118661bbfb0c6a1d49de9847fbc (patch)
treef7efa8f9f58abbf3a8bfcde34d1c490fd819a665 /sci-visualization
parentMasked for testing ~dev-libs/libedit-20090111.3.0 (diff)
downloadgentoo-2-876542ff9437d118661bbfb0c6a1d49de9847fbc.tar.gz
gentoo-2-876542ff9437d118661bbfb0c6a1d49de9847fbc.tar.bz2
gentoo-2-876542ff9437d118661bbfb0c6a1d49de9847fbc.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/veusz/ChangeLog9
-rw-r--r--sci-visualization/veusz/veusz-1.3.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/sci-visualization/veusz/ChangeLog b/sci-visualization/veusz/ChangeLog
index abcdb199197a..801a4c7b719b 100644
--- a/sci-visualization/veusz/ChangeLog
+++ b/sci-visualization/veusz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/veusz
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/veusz/ChangeLog,v 1.11 2008/12/03 12:20:19 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/veusz/ChangeLog,v 1.12 2009/02/26 21:36:48 grozin Exp $
+
+*veusz-1.3 (26 Feb 2009)
+
+ 26 Feb 2009; Andrey Grozin <grozin@gentoo.org> +veusz-1.3.ebuild:
+ Version bump
*veusz-1.2.1 (03 Dec 2008)
diff --git a/sci-visualization/veusz/veusz-1.3.ebuild b/sci-visualization/veusz/veusz-1.3.ebuild
new file mode 100644
index 000000000000..9a75efbf7f53
--- /dev/null
+++ b/sci-visualization/veusz/veusz-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/veusz/veusz-1.3.ebuild,v 1.1 2009/02/26 21:36:48 grozin Exp $
+
+inherit distutils
+
+DESCRIPTION="Qt based scientific plotting package with good Postscript output"
+HOMEPAGE="http://home.gna.org/veusz/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+IUSE="doc examples fits"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+
+DEPEND="dev-python/numpy"
+
+RDEPEND="${DEPEND}
+ dev-python/PyQt4
+ fits? ( dev-python/pyfits )"
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+ if use doc; then
+ cd Documents
+ doins -r Interface.txt manual.html manimages manual.pdf || die "doc install failed"
+ fi
+}