diff options
author | Sebastien Fabbro <bicatali@gentoo.org> | 2009-09-18 18:40:01 +0000 |
---|---|---|
committer | Sebastien Fabbro <bicatali@gentoo.org> | 2009-09-18 18:40:01 +0000 |
commit | 765d12ce37546572fa1a5b860a7c11f0fbf07e52 (patch) | |
tree | e48d9fc4c6db12b0c657387f96c056559ffc40c6 /sci-visualization | |
parent | Stable on amd64 (#283969) (diff) | |
download | gentoo-2-765d12ce37546572fa1a5b860a7c11f0fbf07e52.tar.gz gentoo-2-765d12ce37546572fa1a5b860a7c11f0fbf07e52.tar.bz2 gentoo-2-765d12ce37546572fa1a5b860a7c11f0fbf07e52.zip |
Fixed for more recent versions of sip, and re-introduced minigzip since it is not distributed by zlib. Closing bug #274633
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r-- | sci-visualization/qtiplot/ChangeLog | 10 | ||||
-rw-r--r-- | sci-visualization/qtiplot/files/qtiplot-0.9.7.7-sip.patch | 55 | ||||
-rw-r--r-- | sci-visualization/qtiplot/files/qtiplot-0.9.7.7-syslibs.patch | 44 | ||||
-rw-r--r-- | sci-visualization/qtiplot/qtiplot-0.9.7.7-r1.ebuild (renamed from sci-visualization/qtiplot/qtiplot-0.9.7.7.ebuild) | 5 |
4 files changed, 89 insertions, 25 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog index 04f04d60b47a..df1af57b6a7f 100644 --- a/sci-visualization/qtiplot/ChangeLog +++ b/sci-visualization/qtiplot/ChangeLog @@ -1,6 +1,14 @@ # ChangeLog for sci-visualization/qtiplot # Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 -# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.45 2009/07/29 04:13:59 dirtyepic Exp $ +# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.46 2009/09/18 18:40:01 bicatali Exp $ + +*qtiplot-0.9.7.7-r1 (18 Sep 2009) + + 18 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org> + -qtiplot-0.9.7.7.ebuild, +qtiplot-0.9.7.7-r1.ebuild, + +files/qtiplot-0.9.7.7-sip.patch, files/qtiplot-0.9.7.7-syslibs.patch: + Fixed for more recent versions of sip, and re-introduced minigzip since it + is not distributed by zlib. Closing bug #274633 29 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> qtiplot-0.9.7.7.ebuild, +files/qtiplot-0.9.7.7-gcc44.patch: diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-sip.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-sip.patch new file mode 100644 index 000000000000..bef7966972f9 --- /dev/null +++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-sip.patch @@ -0,0 +1,55 @@ +diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/matrix/Matrix.h qtiplot-0.9.7.7/qtiplot/src/matrix/Matrix.h +--- qtiplot-0.9.7.7.orig/qtiplot/src/matrix/Matrix.h 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/qtiplot/src/matrix/Matrix.h 2009-09-18 18:39:50.000000000 +0100 +@@ -137,6 +137,7 @@ + void setColorMapType(ColorMapType mapType); + + QwtLinearColorMap colorMap(){return d_color_map;}; ++ QwtLinearColorMap *colorMapPointer(){return &d_color_map;}; + void setColorMap(const QwtLinearColorMap& map); + //! Used when restoring from project files + void setColorMap(const QStringList& lst); +diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/plot2D/Spectrogram.h qtiplot-0.9.7.7/qtiplot/src/plot2D/Spectrogram.h +--- qtiplot-0.9.7.7.orig/qtiplot/src/plot2D/Spectrogram.h 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/qtiplot/src/plot2D/Spectrogram.h 2009-09-18 18:40:14.000000000 +0100 +@@ -62,6 +62,7 @@ + void setDefaultColorMap(); + + QwtLinearColorMap colorMap(){return color_map;}; ++ QwtLinearColorMap *colorMapPointer(){return &color_map;}; + void setCustomColorMap(const QwtLinearColorMap& map); + void updateData(Matrix *m); + +diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/plot3D/Graph3D.h qtiplot-0.9.7.7/qtiplot/src/plot3D/Graph3D.h +--- qtiplot-0.9.7.7.orig/qtiplot/src/plot3D/Graph3D.h 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/qtiplot/src/plot3D/Graph3D.h 2009-09-18 18:40:37.000000000 +0100 +@@ -274,6 +274,8 @@ + + QString colorMapFile(){return d_color_map_file;}; + QwtLinearColorMap colorMap(){return d_color_map;}; ++ QwtLinearColorMap *colorMapPointer(){return &d_color_map;}; ++ + + static bool openColorMapFile(ColorVector& cv, QString fname); + +diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/scripting/qti.sip qtiplot-0.9.7.7/qtiplot/src/scripting/qti.sip +--- qtiplot-0.9.7.7.orig/qtiplot/src/scripting/qti.sip 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/qtiplot/src/scripting/qti.sip 2009-09-18 18:19:15.000000000 +0100 +@@ -505,7 +505,7 @@ + void setDefaultColorMap(); + void setGrayScale(); + void setRainbowColorMap(); +- QwtLinearColorMap colorMap(); ++ QwtLinearColorMap *colorMapPointer()/PyName=colorMap/; + void setColorMap(const QwtLinearColorMap&); + + void resetView(); +@@ -993,7 +993,7 @@ + void setDataColors(const QColor&, const QColor&); + QString colorMapFile(); + void setDataColorMap(const QString& fileName); +- QwtLinearColorMap colorMap(); ++ QwtLinearColorMap *colorMapPointer()/PyName=colorMap/; + void setDataColorMap(const QwtLinearColorMap&); + + void changeTransparency(double) /PyName=setOpacity/; diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-syslibs.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-syslibs.patch index 2ace5f295dac..e6162192ed5f 100644 --- a/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-syslibs.patch +++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.7-syslibs.patch @@ -1,6 +1,6 @@ diff -Nur qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pri qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pri ---- qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pri 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pri 2009-04-14 09:25:58.000000000 +0100 +--- qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pri 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pri 2009-09-18 19:29:12.000000000 +0100 @@ -57,11 +57,11 @@ ../3rdparty/qwtplot3d/include/qwt3d_multiplot.h
@@ -18,8 +18,8 @@ diff -Nur qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pri qtiplot-0.9.7.7/ # zlib support for gl2ps
zlib {
diff -Nur qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pro qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pro ---- qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pro 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pro 2009-04-13 19:19:12.000000000 +0100 +--- qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/3rdparty/qwtplot3d/qwtplot3d.pro 2009-09-18 19:29:12.000000000 +0100 @@ -82,11 +82,10 @@ include/qwt3d_multiplot.h @@ -36,8 +36,8 @@ diff -Nur qtiplot-0.9.7.7.orig/3rdparty/qwtplot3d/qwtplot3d.pro qtiplot-0.9.7.7/ # zlib support for gl2ps zlib { diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/explin/explin.pro qtiplot-0.9.7.7/fitPlugins/explin/explin.pro ---- qtiplot-0.9.7.7.orig/fitPlugins/explin/explin.pro 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/fitPlugins/explin/explin.pro 2009-04-13 19:32:36.000000000 +0100 +--- qtiplot-0.9.7.7.orig/fitPlugins/explin/explin.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/fitPlugins/explin/explin.pro 2009-09-18 19:29:12.000000000 +0100 @@ -12,9 +12,8 @@ DESTDIR = ../
@@ -51,8 +51,8 @@ diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/explin/explin.pro qtiplot-0.9.7.7/fitP #dynamically link against GSL installed system-wide
#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/exp_saturation/exp_saturation.pro qtiplot-0.9.7.7/fitPlugins/exp_saturation/exp_saturation.pro ---- qtiplot-0.9.7.7.orig/fitPlugins/exp_saturation/exp_saturation.pro 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/fitPlugins/exp_saturation/exp_saturation.pro 2009-04-13 19:33:27.000000000 +0100 +--- qtiplot-0.9.7.7.orig/fitPlugins/exp_saturation/exp_saturation.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/fitPlugins/exp_saturation/exp_saturation.pro 2009-09-18 19:29:12.000000000 +0100 @@ -12,9 +12,9 @@ DESTDIR = ../
@@ -67,16 +67,16 @@ diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/exp_saturation/exp_saturation.pro qtip #dynamically link against GSL installed system-wide
#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitPlugins.pro qtiplot-0.9.7.7/fitPlugins/fitPlugins.pro ---- qtiplot-0.9.7.7.orig/fitPlugins/fitPlugins.pro 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/fitPlugins/fitPlugins.pro 2009-04-13 19:34:21.000000000 +0100 +--- qtiplot-0.9.7.7.orig/fitPlugins/fitPlugins.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/fitPlugins/fitPlugins.pro 2009-09-18 19:29:12.000000000 +0100 @@ -4,3 +4,4 @@ exp_saturation \
fitRational0 \
fitRational1
+
diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitRational0/fitRational0.pro qtiplot-0.9.7.7/fitPlugins/fitRational0/fitRational0.pro ---- qtiplot-0.9.7.7.orig/fitPlugins/fitRational0/fitRational0.pro 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/fitPlugins/fitRational0/fitRational0.pro 2009-04-13 19:34:49.000000000 +0100 +--- qtiplot-0.9.7.7.orig/fitPlugins/fitRational0/fitRational0.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/fitPlugins/fitRational0/fitRational0.pro 2009-09-18 19:29:12.000000000 +0100 @@ -12,9 +12,9 @@ DESTDIR = ../
@@ -91,8 +91,8 @@ diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitRational0/fitRational0.pro qtiplot- #dynamically link against GSL installed system-wide
#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitRational1/fitRational1.pro qtiplot-0.9.7.7/fitPlugins/fitRational1/fitRational1.pro ---- qtiplot-0.9.7.7.orig/fitPlugins/fitRational1/fitRational1.pro 2009-04-13 17:42:29.000000000 +0100 -+++ qtiplot-0.9.7.7/fitPlugins/fitRational1/fitRational1.pro 2009-04-13 19:35:04.000000000 +0100 +--- qtiplot-0.9.7.7.orig/fitPlugins/fitRational1/fitRational1.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/fitPlugins/fitRational1/fitRational1.pro 2009-09-18 19:29:12.000000000 +0100 @@ -12,9 +12,8 @@ DESTDIR = ../
@@ -106,8 +106,8 @@ diff -Nur qtiplot-0.9.7.7.orig/fitPlugins/fitRational1/fitRational1.pro qtiplot- #dynamically link against GSL installed system-wide
#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtiplot.pro ---- qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro 2009-04-13 17:42:30.000000000 +0100 -+++ qtiplot-0.9.7.7/qtiplot/qtiplot.pro 2009-04-13 19:05:13.000000000 +0100 +--- qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/qtiplot/qtiplot.pro 2009-09-18 19:31:47.000000000 +0100 @@ -21,7 +21,7 @@ #CONFIG += HAVE_EMF
@@ -117,7 +117,7 @@ diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtipl CONFIG += release
#CONFIG += debug
-@@ -31,13 +31,12 @@ +@@ -31,13 +31,13 @@ #!!! Warning: You must modify these paths according to your computer settings
#############################################################################
@@ -127,7 +127,7 @@ diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtipl -INCLUDEPATH += ../3rdparty/qwt/src
-INCLUDEPATH += ../3rdparty/liborigin
-INCLUDEPATH += ../3rdparty/gsl/include
--INCLUDEPATH += ../3rdparty/zlib
+ INCLUDEPATH += ../3rdparty/zlib
-INCLUDEPATH += ../3rdparty/boost_1_36_0
+INCLUDEPATH += /usr/include/qwt5
+INCLUDEPATH += /usr/include/liborigin2
@@ -136,7 +136,7 @@ diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtipl ##################### 3rd PARTY LIBRARIES SECTION ###########################
#!!! Warning: You must modify these paths according to your computer settings
-@@ -46,12 +45,10 @@ +@@ -46,12 +46,10 @@ ##################### Linux (Mac OS X) ######################################
# statically link against libraries in 3rdparty
@@ -153,7 +153,7 @@ diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtipl # dynamically link against dependencies if they are installed system-wide
#unix:LIBS += -lmuparser
-@@ -213,8 +209,6 @@ +@@ -213,8 +211,6 @@ contains(CONFIG, HAVE_LIBPNG){
DEFINES += GL2PS_HAVE_LIBPNG
@@ -163,8 +163,8 @@ diff -Nur qtiplot-0.9.7.7.orig/qtiplot/qtiplot.pro qtiplot-0.9.7.7/qtiplot/qtipl ###############################################################
diff -Nur qtiplot-0.9.7.7.orig/qtiplot/src/origin/origin.pri qtiplot-0.9.7.7/qtiplot/src/origin/origin.pri ---- qtiplot-0.9.7.7.orig/qtiplot/src/origin/origin.pri 2009-04-13 17:42:30.000000000 +0100 -+++ qtiplot-0.9.7.7/qtiplot/src/origin/origin.pri 2009-04-13 19:17:43.000000000 +0100 +--- qtiplot-0.9.7.7.orig/qtiplot/src/origin/origin.pri 2009-09-18 18:16:33.000000000 +0100 ++++ qtiplot-0.9.7.7/qtiplot/src/origin/origin.pri 2009-09-18 19:29:12.000000000 +0100 @@ -4,14 +4,6 @@ INCLUDEPATH += src/origin/
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.7.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.7-r1.ebuild index 43d6cbfc5243..ef02e7d1f3b5 100644 --- a/sci-visualization/qtiplot/qtiplot-0.9.7.7.ebuild +++ b/sci-visualization/qtiplot/qtiplot-0.9.7.7-r1.ebuild @@ -1,6 +1,6 @@ # Copyright 1999-2009 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 -# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.7.ebuild,v 1.5 2009/07/29 04:13:59 dirtyepic Exp $ +# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.7-r1.ebuild,v 1.1 2009/09/18 18:40:01 bicatali Exp $ EAPI=2 inherit eutils qt4 fdo-mime python @@ -34,7 +34,7 @@ CDEPEND=">=x11-libs/qwt-5.2 DEPEND="${CDEPEND} dev-util/pkgconfig - python? ( >=dev-python/sip-4.5.2 ) + python? ( dev-python/sip ) doc? ( app-text/docbook-sgml-utils app-text/docbook-xml-dtd:4.2 )" @@ -48,6 +48,7 @@ src_prepare() { epatch "${FILESDIR}"/${P}-syslibs.patch epatch "${FILESDIR}"/${P}-docbuild.patch epatch "${FILESDIR}"/${P}-gcc44.patch + has_version ">=dev-python/sip-4.8" && epatch "${FILESDIR}"/${P}-sip.patch python_version sed -i \ |