summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-22 12:18:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-22 12:18:26 +0000
commit7383c6e4377414aa0568867937ffd41a12491271 (patch)
tree3e0f5448f0a896a5eccad48d4bd923732e69826e /sci-visualization
parentVersion bump. Fixes bug #331471 and bug #326875 (diff)
downloadgentoo-2-7383c6e4377414aa0568867937ffd41a12491271.tar.gz
gentoo-2-7383c6e4377414aa0568867937ffd41a12491271.tar.bz2
gentoo-2-7383c6e4377414aa0568867937ffd41a12491271.zip
Version bump. Thanks to Andreas K. Hüttel (dilfridge) <mail@akhuettel.de> for the ebuild
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/spyview/ChangeLog9
-rw-r--r--sci-visualization/spyview/spyview-20100810.ebuild43
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-visualization/spyview/ChangeLog b/sci-visualization/spyview/ChangeLog
index de99e1c7d1b9..62e31caf1bfe 100644
--- a/sci-visualization/spyview/ChangeLog
+++ b/sci-visualization/spyview/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/spyview
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.6 2010/07/06 22:25:21 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.7 2010/08/22 12:18:26 hwoarang Exp $
+
+*spyview-20100810 (22 Aug 2010)
+
+ 22 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +spyview-20100810.ebuild:
+ Version bump. Thanks to Andreas K. Hüttel (dilfridge) <mail@akhuettel.de>
+ for the ebuild
06 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
-spyview-20100203.ebuild:
diff --git a/sci-visualization/spyview/spyview-20100810.ebuild b/sci-visualization/spyview/spyview-20100810.ebuild
new file mode 100644
index 000000000000..92746e6eabc3
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20100810.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI=2
+
+inherit base flag-o-matic eutils multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/boost-1.39
+ media-libs/netpbm
+ >=x11-libs/fltk-1.1.9:1.1
+ app-text/ghostscript-gpl"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/spyview-2010-08-10-22_14
+
+src_prepare() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L/usr/$(get_libdir)/fltk-1.1
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview --docdir=/usr/share/doc/${PF}
+}