summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-27 18:25:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-27 18:25:22 +0000
commit52fc2e6b7958261eb4d1af4a74f723984167c933 (patch)
tree31eb5ac88bf19be118010d77742556fae322797a /sci-visualization
parentVersion bump #248930 by Arfrever Frehtes Taifersar Arahesis. (diff)
downloadgentoo-2-52fc2e6b7958261eb4d1af4a74f723984167c933.tar.gz
gentoo-2-52fc2e6b7958261eb4d1af4a74f723984167c933.tar.bz2
gentoo-2-52fc2e6b7958261eb4d1af4a74f723984167c933.zip
Removed imlib dependency (bug #249077, thanks Dustin Polke), added pkg-config depend and respect cflags
(Portage version: 2.2_rc16/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/g3data/ChangeLog9
-rw-r--r--sci-visualization/g3data/files/g3data-1.5.1-makefile.patch21
-rw-r--r--sci-visualization/g3data/g3data-1.5.1.ebuild19
-rw-r--r--sci-visualization/g3data/metadata.xml4
4 files changed, 44 insertions, 9 deletions
diff --git a/sci-visualization/g3data/ChangeLog b/sci-visualization/g3data/ChangeLog
index b0ebaf870dc1..377906169055 100644
--- a/sci-visualization/g3data/ChangeLog
+++ b/sci-visualization/g3data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/g3data
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/g3data/ChangeLog,v 1.3 2007/07/18 02:19:19 cryos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/g3data/ChangeLog,v 1.4 2008/11/27 18:25:22 bicatali Exp $
+
+ 27 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/g3data-1.5.1-makefile.patch, metadata.xml, g3data-1.5.1.ebuild:
+ Removed imlib dependency (bug #249077, thanks Dustin Polke), added
+ pkg-config depend and respect cflags
18 Jul 2007; Marcus D. Hanwell <cryos@gentoo.org> -g3data-1.5.0.ebuild,
g3data-1.5.1.ebuild:
diff --git a/sci-visualization/g3data/files/g3data-1.5.1-makefile.patch b/sci-visualization/g3data/files/g3data-1.5.1-makefile.patch
new file mode 100644
index 000000000000..f83ca596c6e6
--- /dev/null
+++ b/sci-visualization/g3data/files/g3data-1.5.1-makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile.orig 2008-11-27 18:16:03.000000000 +0000
++++ Makefile 2008-11-27 18:17:05.000000000 +0000
+@@ -1,15 +1,13 @@
+-CC=gcc
+-CFLAGS=-Wall `pkg-config --cflags gtk+-2.0`
++MYCFLAGS=-Wall `pkg-config --cflags gtk+-2.0`
+ LIBS=`pkg-config --libs gtk+-2.0`
+ bindir ?= /usr/bin
+ mandir ?= /usr/share/man
+
+ .c.o:
+- $(CC) -c $(CFLAGS) $(CPPFLAGS) $<
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) $(MYCFLAGS) $<
+
+ g3data: main.o sort.o points.o drawing.o g3data.1.gz
+- $(CC) $(CFLAGS) -o g3data main.o sort.o points.o drawing.o $(LIBS)
+- strip g3data
++ $(CC) $(CFLAGS) $(MYCFLAGS) -o g3data main.o sort.o points.o drawing.o $(LIBS)
+
+ main.o: main.c main.h strings.h vardefs.h
+
diff --git a/sci-visualization/g3data/g3data-1.5.1.ebuild b/sci-visualization/g3data/g3data-1.5.1.ebuild
index 42891c3a1025..61ebb8667c8a 100644
--- a/sci-visualization/g3data/g3data-1.5.1.ebuild
+++ b/sci-visualization/g3data/g3data-1.5.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/g3data/g3data-1.5.1.ebuild,v 1.2 2007/07/18 02:19:19 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/g3data/g3data-1.5.1.ebuild,v 1.3 2008/11/27 18:25:22 bicatali Exp $
+
+inherit eutils
DESCRIPTION="Tool for extracting data from graphs"
HOMEPAGE="http://www.frantz.fi/software/g3data.php"
@@ -11,11 +13,17 @@ SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE="examples"
-RDEPEND=">=x11-libs/gtk+-2.6.0
- media-libs/imlib"
+RDEPEND=">=x11-libs/gtk+-2.6.0"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
~app-text/docbook-sgml-utils-0.6.14"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
src_compile() {
emake || die "emake failed"
}
@@ -25,8 +33,9 @@ src_install() {
doman g3data.1.gz || die "doman failed"
dodoc README.SOURCE || die "README.SOURCE not found"
if use examples; then
+ docinto examples
dodoc README.TEST
- insinto ${DESTDIR}usr/share/doc/${PF}/
+ insinto /usr/share/doc/${PF}/examples
doins test1.png test1.values test2.png test2.values
fi
}
diff --git a/sci-visualization/g3data/metadata.xml b/sci-visualization/g3data/metadata.xml
index 51ab4ef202fb..6802aababd33 100644
--- a/sci-visualization/g3data/metadata.xml
+++ b/sci-visualization/g3data/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<longdescription>
g3data is used for extracting data from graphs. In pubilcations graphs are
- often included, but the actual data is not. g3data makes the extraction
- process much easier.
+ often included, but the actual data is not. g3data makes the extraction
+ process much easier.
</longdescription>
</pkgmetadata>