summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-10-04 00:03:32 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-10-04 00:03:32 +0000
commit23f903e8dbc0bc563000b90fe34531b25c32f552 (patch)
tree1a78c3dd55ff10baad7d7f936cfd01bee048a847 /sci-visualization
parentremove unused app-misc/tracker:thumbnailing use flag (diff)
downloadgentoo-2-23f903e8dbc0bc563000b90fe34531b25c32f552.tar.gz
gentoo-2-23f903e8dbc0bc563000b90fe34531b25c32f552.tar.bz2
gentoo-2-23f903e8dbc0bc563000b90fe34531b25c32f552.zip
fix a typo in 4.2.0; exchange all make with emake; use SITELISP variable from elisp-common.eclass instead of hard coded path for GNU Emacs support file installation; delete X11 support files when not having USE=X (see bug 194527)
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gnuplot/ChangeLog9
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild23
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.2.2.ebuild21
3 files changed, 35 insertions, 18 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index dc93a76087a7..a1e878c43c12 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.43 2007/09/23 17:08:15 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.44 2007/10/04 00:03:32 opfer Exp $
+
+ 04 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
+ gnuplot-4.2.0-r2.ebuild, gnuplot-4.2.2.ebuild:
+ fix a typo in 4.2.0; exchange all make with emake; use SITELISP variable
+ from elisp-common.eclass instead of hard coded path for GNU Emacs support
+ file installation; delete X11 support files when not having USE=X (see bug
+ 194527)
23 Sep 2007; nixnut <nixnut@gentoo.org> gnuplot-4.2.0-r2.ebuild:
Stable on ppc wrt bug 189672
diff --git a/sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild b/sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild
index 4786697bb827..0ea7e0d0c172 100644
--- a/sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild,v 1.7 2007/09/23 17:08:15 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.0-r2.ebuild,v 1.8 2007/10/04 00:03:32 opfer Exp $
inherit eutils elisp-common multilib wxwidgets
@@ -55,7 +55,7 @@ src_compile() {
# See bug #156427.
if use tetex ; then
sed -i \
- -e 's/TEXMFLOCAL/TEXTMFSITE/g' share/Makefile.in || die "sed failed"
+ -e 's/TEXMFLOCAL/TEXMFSITE/g' share/Makefile.in || die "sed failed"
else
sed -i \
-e '/^SUBDIRS/ s/LaTeX//' share/Makefile.in || die "sed failed"
@@ -96,21 +96,21 @@ src_compile() {
if use doc ; then
cd docs
- make pdf || die "pdf doc creation failed"
+ emake pdf || die "pdf doc creation failed"
cd ../tutorial
- make pdf || die "pdf tutorial failed"
+ emake pdf || die "pdf tutorial failed"
fi
}
src_install () {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
if use emacs; then
cd lisp
einfo "Configuring gnuplot-mode for GNU Emacs..."
- EMACS="emacs" econf --with-lispdir="/usr/share/emacs/site-lisp/${PN}" || die "econf Emacs files faild"
- make DESTDIR="${D}" install || die "make install Emacs files failed"
- make clean
+ EMACS="emacs" econf --with-lispdir="${SITELISP}/${PN}" || die "econf Emacs files faild"
+ emake DESTDIR="${D}" install || die "make install Emacs files failed"
+ emake clean
cd ..
# Gentoo emacs site-lisp configuration
@@ -124,7 +124,7 @@ src_install () {
cd lisp
einfo "Configuring gnuplot-mode for XEmacs..."
EMACS="xemacs" econf --with-lispdir="/usr/$(get_libdir)/xemacs/site-packages/${PN}" || die
- make DESTDIR="${D}" install || {
+ emake DESTDIR="${D}" install || {
ewarn "Compiling/installing gnuplot-mode for xemacs has failed."
ewarn "I need xemacs-base to be installed before I can compile"
ewarn "the gnuplot-mode lisp files for xemacs successfully."
@@ -151,6 +151,11 @@ src_install () {
insinto /usr/share/doc/${PF}/psdoc
doins docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
fi
+
+ if ! use X; then
+ # see bug 194527
+ rm -rf "${D}/usr/$(get_libdir)/X11"
+ fi
}
pkg_postinst() {
diff --git a/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild b/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild
index cb2431992aea..bc9d43acef6d 100644
--- a/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild,v 1.6 2007/09/20 16:09:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild,v 1.7 2007/10/04 00:03:32 opfer Exp $
inherit eutils elisp-common multilib wxwidgets
@@ -107,21 +107,21 @@ src_compile() {
if use doc ; then
cd docs
- make pdf || die "pdf doc creation failed"
+ emake pdf || die "pdf doc creation failed"
cd ../tutorial
- make pdf || die "pdf tutorial failed"
+ emake pdf || die "pdf tutorial failed"
fi
}
src_install () {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
if use emacs; then
cd lisp
einfo "Configuring gnuplot-mode for GNU Emacs..."
- EMACS="emacs" econf --with-lispdir="/usr/share/emacs/site-lisp/${PN}" || die "econf Emacs files faild"
- make DESTDIR="${D}" install || die "make install Emacs files failed"
- make clean
+ EMACS="emacs" econf --with-lispdir="${SITELISP}/${PN}" || die "econf Emacs files faild"
+ emake DESTDIR="${D}" install || die "make install Emacs files failed"
+ emake clean
cd ..
# Gentoo emacs site-lisp configuration
@@ -135,7 +135,7 @@ src_install () {
cd lisp
einfo "Configuring gnuplot-mode for XEmacs..."
EMACS="xemacs" econf --with-lispdir="/usr/$(get_libdir)/xemacs/site-packages/${PN}" || die
- make DESTDIR="${D}" install || {
+ emake DESTDIR="${D}" install || {
ewarn "Compiling/installing gnuplot-mode for xemacs has failed."
ewarn "I need xemacs-base to be installed before I can compile"
ewarn "the gnuplot-mode lisp files for xemacs successfully."
@@ -162,6 +162,11 @@ src_install () {
insinto /usr/share/doc/${PF}/psdoc
doins docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
fi
+
+ if ! use X; then
+ # see bug 194527
+ rm -rf "${D}/usr/$(get_libdir)/X11"
+ fi
}
pkg_postinst() {