summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 13:35:35 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 13:35:35 +0000
commit1046a395843de5324f37a2b948f585e59a2df207 (patch)
treed4d512a4025b82f548b4618035c43e4d8acd1e37 /sci-visualization
parentWhitespace (diff)
downloadgentoo-2-1046a395843de5324f37a2b948f585e59a2df207.tar.gz
gentoo-2-1046a395843de5324f37a2b948f585e59a2df207.tar.bz2
gentoo-2-1046a395843de5324f37a2b948f585e59a2df207.zip
sci-visualization/spyview: Punt base.eclass
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/spyview/ChangeLog8
-rw-r--r--sci-visualization/spyview/metadata.xml11
-rw-r--r--sci-visualization/spyview/spyview-20111018.ebuild10
-rw-r--r--sci-visualization/spyview/spyview-20130823.ebuild10
4 files changed, 19 insertions, 20 deletions
diff --git a/sci-visualization/spyview/ChangeLog b/sci-visualization/spyview/ChangeLog
index 6fefe52fc5ff..e74f19ae6e54 100644
--- a/sci-visualization/spyview/ChangeLog
+++ b/sci-visualization/spyview/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/spyview
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.27 2013/12/03 21:32:31 dilfridge Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.28 2014/01/06 13:35:35 jlec Exp $
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> spyview-20111018.ebuild,
+ spyview-20130823.ebuild, metadata.xml:
+ Punt base.eclass
03 Dec 2013; Andreas K. Huettel <dilfridge@gentoo.org>
spyview-20130823.ebuild:
diff --git a/sci-visualization/spyview/metadata.xml b/sci-visualization/spyview/metadata.xml
index e6ebe7e4c0f6..331d38a1cc6f 100644
--- a/sci-visualization/spyview/metadata.xml
+++ b/sci-visualization/spyview/metadata.xml
@@ -1,11 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
-<email>dilfridge@gentoo.org</email>
-<name>Andreas K. Huettel</name>
-</maintainer>
-<longdescription lang="en">
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <longdescription lang="en">
</longdescription>
</pkgmetadata>
-
diff --git a/sci-visualization/spyview/spyview-20111018.ebuild b/sci-visualization/spyview/spyview-20111018.ebuild
index 787c069b9773..d480554840d1 100644
--- a/sci-visualization/spyview/spyview-20111018.ebuild
+++ b/sci-visualization/spyview/spyview-20111018.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/spyview-20111018.ebuild,v 1.5 2013/07/27 22:08:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/spyview-20111018.ebuild,v 1.6 2014/01/06 13:35:35 jlec Exp $
EAPI=4
-inherit base flag-o-matic eutils multilib
+inherit flag-o-matic eutils multilib
DESCRIPTION="Interactive plotting program"
HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
@@ -43,9 +43,7 @@ src_prepare() {
append-ldflags -L$(dirname $(fltk-config --libs))
- find "${S}" -name Makefile.in -exec sed -i -e 's:-mwindows -mconsole::g' {} +
-
- base_src_prepare
+ find "${S}" -name Makefile.in -exec sed -i -e 's:-mwindows -mconsole::g' {} + || die
}
src_configure() {
diff --git a/sci-visualization/spyview/spyview-20130823.ebuild b/sci-visualization/spyview/spyview-20130823.ebuild
index 1d580b42350f..4f00e1d095cf 100644
--- a/sci-visualization/spyview/spyview-20130823.ebuild
+++ b/sci-visualization/spyview/spyview-20130823.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/spyview-20130823.ebuild,v 1.3 2013/12/03 21:32:31 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/spyview-20130823.ebuild,v 1.4 2014/01/06 13:35:35 jlec Exp $
EAPI=5
-inherit base autotools flag-o-matic eutils multilib
+inherit autotools flag-o-matic eutils multilib
DESCRIPTION="Interactive plotting program"
HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
@@ -42,9 +42,7 @@ src_prepare() {
# this one leads to an insane amount of warnings
append-ldflags -L$(dirname $(fltk-config --libs))
- find "${S}" -name Makefile.am -exec sed -i -e 's:-mwindows -mconsole::g' {} +
-
- base_src_prepare
+ find "${S}" -name Makefile.am -exec sed -i -e 's:-mwindows -mconsole::g' {} + || die
eautoreconf
}