summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-09-15 09:02:46 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-09-15 09:02:46 +0000
commit0bd016c4686b133580784dfb6066a7dd6a50668a (patch)
tree213e48fe978e9d5a08ceba09555ecf33564e1184 /sci-visualization
parentAdd the fsck_ext2fs helper and man page for FreeBSD and add a patch for 1.40.... (diff)
downloadgentoo-2-0bd016c4686b133580784dfb6066a7dd6a50668a.tar.gz
gentoo-2-0bd016c4686b133580784dfb6066a7dd6a50668a.tar.bz2
gentoo-2-0bd016c4686b133580784dfb6066a7dd6a50668a.zip
removing latex-package.eclass again as it would pull in virtual/tetex unconditionally; introducing own rehash function based on work from latex-package.eclass; thanks to drac for sighting
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gnuplot/ChangeLog7
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.2.2.ebuild16
2 files changed, 18 insertions, 5 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index 9a4485553fb2..c2b3ae5b5476 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.35 2007/09/14 15:42:36 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.36 2007/09/15 09:02:46 opfer Exp $
+
+ 15 Sep 2007; Christian Faulhammer <opfer@gentoo.org> gnuplot-4.2.2.ebuild:
+ removing latex-package.eclass again as it would pull in virtual/tetex
+ unconditionally; introducing own rehash function based on work from
+ latex-package.eclass; thanks to drac for sighting
14 Sep 2007; Christian Faulhammer <opfer@gentoo.org> gnuplot-4.2.2.ebuild:
do a rehash if USE flag tetex is set, see bug 192471by Sebastian Schubert
diff --git a/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild b/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild
index 850ef94cf54d..9a5d9397ad72 100644
--- a/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild,v 1.3 2007/09/14 15:42:36 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2.2.ebuild,v 1.4 2007/09/15 09:02:46 opfer Exp $
-inherit eutils elisp-common latex-package multilib wxwidgets
+inherit eutils elisp-common multilib wxwidgets
MY_P="${P/_/.}"
@@ -38,6 +38,14 @@ S=${WORKDIR}/${MY_P}
E_SITEFILE="50gnuplot-gentoo.el"
+latex_rehash() {
+ if has_version '>=app-text/tetex-3' || has_version '>=app-text/ptex-3.1.8' ; then
+ texmf-update
+ else
+ texconfig rehash
+ fi
+}
+
pkg_setup() {
if use gd && ! built_with_use media-libs/gd png; then
eerror "media-libs/gd needs to be built with PNG support"
@@ -161,10 +169,10 @@ pkg_postinst() {
einfo "this is usually considered to be a security hazard."
einfo "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
fi
- use tetex && latex-package_rehash
+ use tetex && latex_rehash
}
pkg_postrm() {
use emacs && elisp-site-regen
- use tetex && latex-package_rehash
+ use tetex && latex_rehash
}