summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-03-29 18:32:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-03-29 18:32:05 +0000
commit014443cb6bb101550b42906c53bc4daa406d0cd6 (patch)
tree966c5a6372b0bec774e0289a4efeeff4f3829c8e /sci-visualization
parentImport from the science overlay (diff)
downloadgentoo-2-014443cb6bb101550b42906c53bc4daa406d0cd6.tar.gz
gentoo-2-014443cb6bb101550b42906c53bc4daa406d0cd6.tar.bz2
gentoo-2-014443cb6bb101550b42906c53bc4daa406d0cd6.zip
Version bump.. Respect for LINGUAS, add missing dep, and bump EAPI to 4. Thanks kensington, bug #409777
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/xyscan/ChangeLog10
-rw-r--r--sci-visualization/xyscan/xyscan-3.3.1.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/sci-visualization/xyscan/ChangeLog b/sci-visualization/xyscan/ChangeLog
index 95dab91d40d6..62b1555c158b 100644
--- a/sci-visualization/xyscan/ChangeLog
+++ b/sci-visualization/xyscan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/xyscan
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xyscan/ChangeLog,v 1.11 2011/07/20 17:03:54 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xyscan/ChangeLog,v 1.12 2012/03/29 18:32:05 bicatali Exp $
+
+*xyscan-3.3.1 (29 Mar 2012)
+
+ 29 Mar 2012; Sébastien Fabbro <bicatali@gentoo.org> +xyscan-3.3.1.ebuild:
+ Version bump.. Respect for LINGUAS, add missing dep, and bump EAPI to 4.
+ Thanks kensington, bug #409777
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #105599
diff --git a/sci-visualization/xyscan/xyscan-3.3.1.ebuild b/sci-visualization/xyscan/xyscan-3.3.1.ebuild
new file mode 100644
index 000000000000..d826c49fe10b
--- /dev/null
+++ b/sci-visualization/xyscan/xyscan-3.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xyscan/xyscan-3.3.1.ebuild,v 1.1 2012/03/29 18:32:05 bicatali Exp $
+
+EAPI=4
+LANGS="fr"
+
+inherit eutils qt4-r2 versionator
+
+MY_PV=$(replace_version_separator 2 '')
+
+DESCRIPTION="Tool for extracting data points from graphs"
+HOMEPAGE="http://star.physics.yale.edu/~ullrich/xyscanDistributionPage/"
+SRC_URI="http://star.physics.yale.edu/~ullrich/${PN}DistributionPage/${MY_PV}/${PN}-${MY_PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e "s:qApp->applicationDirPath() + \"/../docs\":\"${EPREFIX}/usr/share/doc/${PF}/html\":" \
+ xyscanWindow.cpp || die "Failed to fix docs path"
+ rm -f moc_xyscanAbout.cpp moc_xyscanHelpBrowser.cpp moc_xyscanWindow.cpp
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe xyscan
+
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/en
+
+ use linguas_fr && doins -r docs/fr
+
+ newicon images/xyscanIcon.png xyscan.png
+ make_desktop_entry xyscan "xyscan data point extractor"
+}