summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-03-29 18:37:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-03-29 18:37:48 +0000
commit606ca817fbf873c0e1fd8a8b455034751334cfd1 (patch)
tree361a1320ac8f2ea9a2fe44b9cd51cdde1b0500fe /sci-visualization/zhu3d
parentVersion bump.. Respect for LINGUAS, add missing dep, and bump EAPI to 4. Than... (diff)
downloadgentoo-2-606ca817fbf873c0e1fd8a8b455034751334cfd1.tar.gz
gentoo-2-606ca817fbf873c0e1fd8a8b455034751334cfd1.tar.bz2
gentoo-2-606ca817fbf873c0e1fd8a8b455034751334cfd1.zip
Version bump. Migrates to qt4-r2.eclass. Respects LINGUAS. Tidies/fixes /usr/share installation. Bump to EAPI4. Minor other improvements. Thanks kensington bug #410157
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/zhu3d')
-rw-r--r--sci-visualization/zhu3d/ChangeLog12
-rw-r--r--sci-visualization/zhu3d/files/zhu3d-4.2.4-gold.patch11
-rw-r--r--sci-visualization/zhu3d/zhu3d-4.2.4.ebuild73
3 files changed, 94 insertions, 2 deletions
diff --git a/sci-visualization/zhu3d/ChangeLog b/sci-visualization/zhu3d/ChangeLog
index 83cca9994bc0..7f8ed0b3e5ad 100644
--- a/sci-visualization/zhu3d/ChangeLog
+++ b/sci-visualization/zhu3d/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-visualization/zhu3d
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/zhu3d/ChangeLog,v 1.18 2010/09/16 18:18:35 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/zhu3d/ChangeLog,v 1.19 2012/03/29 18:37:48 bicatali Exp $
+
+*zhu3d-4.2.4 (29 Mar 2012)
+
+ 29 Mar 2012; Sébastien Fabbro <bicatali@gentoo.org> +zhu3d-4.2.4.ebuild,
+ +files/zhu3d-4.2.4-gold.patch:
+ Version bump. Migrates to qt4-r2.eclass. Respects LINGUAS. Tidies/fixes
+ /usr/share installation. Bump to EAPI4. Minor other improvements. Thanks
+ kensington bug #410157
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> zhu3d-4.2.2.ebuild:
virtual/glu -> virtual/opengl
diff --git a/sci-visualization/zhu3d/files/zhu3d-4.2.4-gold.patch b/sci-visualization/zhu3d/files/zhu3d-4.2.4-gold.patch
new file mode 100644
index 000000000000..64a6ad42b3d4
--- /dev/null
+++ b/sci-visualization/zhu3d/files/zhu3d-4.2.4-gold.patch
@@ -0,0 +1,11 @@
+--- zhu3d.pro
++++ zhu3d.pro
+@@ -48,7 +48,7 @@
+ CONFIG += release
+ TARGET = zhu3d
+ QT += opengl
+-
++LIBS += -lGLU
+
+ # ============================================================================
+ # Optimisation switches. For both GCC/ICC compilers -O3 is default.
diff --git a/sci-visualization/zhu3d/zhu3d-4.2.4.ebuild b/sci-visualization/zhu3d/zhu3d-4.2.4.ebuild
new file mode 100644
index 000000000000..86c95c6632ba
--- /dev/null
+++ b/sci-visualization/zhu3d/zhu3d-4.2.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/zhu3d/zhu3d-4.2.4.ebuild,v 1.1 2012/03/29 18:37:48 bicatali Exp $
+
+EAPI=4
+LANGS="cs de es fr zh"
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Interactive 3D mathematical function viewer"
+HOMEPAGE="http://sourceforge.net/projects/zhu3d"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4"
+REPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gold.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ local datadir=/usr/share/${PN}
+ sed -i \
+ -e "s:^SYSDIR=:SYSDIR=${datadir}/system:" \
+ -e "s:^TEXDIR=:TEXDIR=${datadir}/textures:" \
+ -e "s:^WORKDIR=:WORKDIR=${datadir}/work:" \
+ -e "s:^DOCDIR=:DOCDIR=/usr/share/doc/${PF}/html:" \
+ ${PN}.pri || die "sed zhu3d.pri failed"
+
+ sed -i -e "/# Optimisation/,/# Include/d" zhu3d.pro \
+ || die "optimisation sed failed"
+}
+
+src_install() {
+ # not working: emake install INSTALL_ROOT="${D}" || die
+ dobin zhu3d
+
+ dodoc {readme,src/changelog}.txt
+ dohtml doc/*.png doc/${PN}_en.html
+
+ local lang
+ for lang in ${LANGS} ; do
+ if use linguas_${lang} ; then
+
+ insinto /usr/share/${PN}/system/languages
+ doins system/languages/${PN}_${lang}.qm
+
+ if [ -e doc/${PN}_${lang}.html ] ; then
+ dohtml doc/${PN}_${lang}.html
+ fi
+ fi
+ done
+
+ insinto /usr/share/${PN}
+ doins -r work/textures
+
+ insinto /usr/share/${PN}/work
+ doins -r work/*.zhu work/slideshow
+
+ insinto /usr/share/${PN}/system
+ doins -r system/*.zhu system/icons
+
+ doicon system/icons/${PN}.png
+ make_desktop_entry ${PN} "Zhu3D Function Viewer" ${PN} "Education;Science;Math;Qt"
+}