summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-15 22:09:05 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-15 22:09:05 +0000
commit34f2ff470abae46aebd66edc410fad5ffa87f68a (patch)
treee91f2eccffb436dfbb0673e38326531ec7bfe2e1 /sci-visualization/scidavis
parentVersion bump wrt #309651 by "hitachi". (diff)
downloadgentoo-2-34f2ff470abae46aebd66edc410fad5ffa87f68a.tar.gz
gentoo-2-34f2ff470abae46aebd66edc410fad5ffa87f68a.tar.bz2
gentoo-2-34f2ff470abae46aebd66edc410fad5ffa87f68a.zip
Version Bump, per 309361; PREFIX ready, but not keyworded
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/scidavis')
-rw-r--r--sci-visualization/scidavis/ChangeLog9
-rw-r--r--sci-visualization/scidavis/files/scidavis-0.2.4-profile.patch74
-rw-r--r--sci-visualization/scidavis/scidavis-0.2.4.ebuild82
3 files changed, 164 insertions, 1 deletions
diff --git a/sci-visualization/scidavis/ChangeLog b/sci-visualization/scidavis/ChangeLog
index a2a2aefd9912..1ec01d55b185 100644
--- a/sci-visualization/scidavis/ChangeLog
+++ b/sci-visualization/scidavis/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/scidavis
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/ChangeLog,v 1.12 2010/01/12 15:34:31 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/ChangeLog,v 1.13 2010/03/15 22:09:04 jlec Exp $
+
+*scidavis-0.2.4 (15 Mar 2010)
+
+ 15 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +scidavis-0.2.4.ebuild, +files/scidavis-0.2.4-profile.patch:
+ Version Bump, per 309361
+ Prefix ready, not keyworded.
12 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
scidavis-0.2.3.ebuild:
diff --git a/sci-visualization/scidavis/files/scidavis-0.2.4-profile.patch b/sci-visualization/scidavis/files/scidavis-0.2.4-profile.patch
new file mode 100644
index 000000000000..c7b6751b8b1a
--- /dev/null
+++ b/sci-visualization/scidavis/files/scidavis-0.2.4-profile.patch
@@ -0,0 +1,74 @@
+diff --git a/scidavis/scidavis.pro b/scidavis/scidavis.pro
+index fa33d0e..0af10c6 100644
+--- a/scidavis/scidavis.pro
++++ b/scidavis/scidavis.pro
+@@ -33,7 +33,7 @@ exists(/usr/bin/lupdate-qt4) {
+ linux-g++-64: libsuff = 64
+
+ ### where to install
+-unix: INSTALLBASE = /usr # this is what is called "prefix" when using GNU autotools
++unix: INSTALLBASE = @GENTOO_PORTAGE_EPREFIX@/usr # this is what is called "prefix" when using GNU autotools
+ win32: INSTALLBASE = c:/scidavis
+ unix: target.path = "$$INSTALLBASE/bin" # where to install the binary on Linux/MacOS X
+ win32: target.path = "$$INSTALLBASE" # where to install the exe on Windows
+@@ -56,7 +56,7 @@ win32: translationfiles.path = "$$INSTALLBASE/translations"
+ ### scidavisrc.py and scidavisUtil.py, respectively. Alternatively you can also put scidavisrc.py
+ ### (or ".scidavis.py") into the users home directory. scidavisUtil.py must be either in the
+ ### directory specified here or somewhere else in the python path (sys.path) where "import" can find it
+-unix: pythonconfig.path = /etc # where scidavisrc.py is installed
++unix: pythonconfig.path = $$INSTALLBASE/share/scidavis # where scidavisrc.py is installed
+ win32: pythonconfig.path = $$INSTALLBASE
+ unix: pythonutils.path = $$INSTALLBASE/share/scidavis # where the scidavisUtil python modules is installed
+ win32: pythonutils.path = $$INSTALLBASE
+@@ -76,6 +76,7 @@ include( python.pri )
+ ### instead of the one provided in "3rdparty", uncomment the following 2 lines:
+ # CONFIG += dynamic_liborigin
+ # LIBS += -lorigin
++# INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/liborigin2
+ ### Unfortunately, due to liborigin being in alpha stage, we cannot promise
+ ### that SciDAVis works with any other version that the one in "3rdparty".
+ ################### end of liborigin block
+@@ -87,16 +88,17 @@ include( python.pri )
+ ### are compiled against Qt4), dynamically against everything else.
+ #############################################################################
+
+-unix:INCLUDEPATH += ../3rdparty/qwtplot3d/include
+-unix:LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a
++unix:INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/qwtplot3d
++unix:LIBS += -lqwtplot3d
+
+-unix:INCLUDEPATH += ../3rdparty/qwt/src
+-unix:LIBS += ../3rdparty/qwt/lib/libqwt.a
++unix:INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/qwt5
++unix:LIBS += -lqwt
+
+-unix:LIBS += -L/usr/lib$${libsuff}
+-unix:LIBS += -lgsl -lgslcblas -lz
+-unix:LIBS += -lmuparser
+-unix:INCLUDEPATH += /usr/include/muParser
++unix:INCLUDEPATH += $$system(pkg-config --cflags gsl)
++unix:LIBS += $$system(pkg-config --libs gsl)
++unix:LIBS += $$system(pkg-config --libs muparser)
++unix:INCLUDEPATH += $$system(pkg-config --cflags muparser)
++unix:LIBS += -lz
+
+ #############################################################################
+ ### Link everything dynamically
+diff --git a/scidavis/sourcefiles.pri b/scidavis/sourcefiles.pri
+index 892b45f..bd349c6 100644
+--- a/scidavis/sourcefiles.pri
++++ b/scidavis/sourcefiles.pri
+@@ -48,12 +48,8 @@ contains( INSTALLS, translationfiles ){
+ ###################### DOCUMENTATION ########################################
+
+ documentation.files += ../manual/html \
+- ../INSTALL.html \
+ ../scidavis.css \
+- ../scidavis-logo.png \
+- ../README \
+- ../CHANGES \
+- ../gpl.txt
++ ../scidavis-logo.png
+
+ ###################### DESKTOP INTEGRATION ##################################
+
diff --git a/sci-visualization/scidavis/scidavis-0.2.4.ebuild b/sci-visualization/scidavis/scidavis-0.2.4.ebuild
new file mode 100644
index 000000000000..8e3566621638
--- /dev/null
+++ b/sci-visualization/scidavis/scidavis-0.2.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/scidavis/scidavis-0.2.4.ebuild,v 1.1 2010/03/15 22:09:04 jlec Exp $
+
+EAPI="3"
+
+inherit eutils fdo-mime prefix qt4
+
+DESCRIPTION="Scientific Data Analysis and Visualization"
+HOMEPAGE="http://scidavis.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="de es fr ja ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+CDEPEND="sys-libs/zlib
+ >=x11-libs/qwt-5.1[svg]
+ >=x11-libs/qwtplot3d-0.2.7
+ x11-libs/qt-assistant:4
+ x11-libs/qt-qt3support:4
+ >=dev-cpp/muParser-1.30
+ >=sci-libs/gsl-1.8"
+# remove because unsupported for now
+# sci-libs/liborigin:2"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ >=dev-python/sip-4.7"
+
+RDEPEND="${CDEPEND}
+ >=dev-python/PyQt4-4.4[X]
+ dev-python/pygsl
+ sci-libs/scipy"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-profile.patch
+ eprefixify ${PN}/${PN}.pro
+ sed -i -e '/lgsl/d' fitPlugins/*/*.pro || die "sed gsl link failed"
+ sed -i \
+ -e "s:doc/${PN}:doc/${PF}:g" \
+ ${PN}/${PN}.pro || die "sed doc dir failed"
+ # the libsuff thingy does not work
+ sed -i \
+ -e "s|/usr/lib\$\${libsuff}|/usr/$(get_libdir)|g" \
+ -i fit*/*/*.pro || die "sed plugins failed"
+
+ sed -i \
+ -e '/^include( python.pri )$/d' \
+ ${PN}/${PN}.pro || die "sed python failed"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'emake install failed'
+ dodoc README CHANGES || die
+ doicon scidavis/icons/hicolor-48/scidavis.png || die
+ cd ${PN}/translations
+ insinto /usr/share/${PN}/translations
+ for l in ${LANGS}; do
+ if use linguas_${l}; then
+ doins ${PN}_${l}.qm || die
+ fi
+ done
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}