summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-04-09 22:10:26 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-04-09 22:10:26 +0000
commit87339237c69b9d4976b5ea6c85b20674a565ed08 (patch)
tree8850721dde266f6843faa4cfe0b54a9ec6033887 /sci-visualization/qtiplot/qtiplot-0.8.2.ebuild
parentversion bump, fix one docs issue (diff)
downloadgentoo-2-87339237c69b9d4976b5ea6c85b20674a565ed08.tar.gz
gentoo-2-87339237c69b9d4976b5ea6c85b20674a565ed08.tar.bz2
gentoo-2-87339237c69b9d4976b5ea6c85b20674a565ed08.zip
Version bump, pruned old version.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'sci-visualization/qtiplot/qtiplot-0.8.2.ebuild')
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.8.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-visualization/qtiplot/qtiplot-0.8.2.ebuild b/sci-visualization/qtiplot/qtiplot-0.8.2.ebuild
new file mode 100644
index 000000000000..8ec645fbdac4
--- /dev/null
+++ b/sci-visualization/qtiplot/qtiplot-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.8.2.ebuild,v 1.1 2006/04/09 22:10:26 cryos Exp $
+
+inherit eutils multilib qt3
+
+DESCRIPTION="Qt based clone of the Origin plotting package"
+HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
+SRC_URI="http://soft.proindependent.com/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.3)
+ >=x11-libs/qwt-4.2.0
+ >=x11-libs/qwtplot3d-0.2.6
+ >=sci-libs/gsl-1.6"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-qmake.patch
+ sed -i -e "s|_LIBDIR_|/usr/$(get_libdir)|" ${PN}.pro || die "sed failed."
+}
+
+src_compile() {
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake ${PN}.pro || die 'qmake failed.'
+ emake || die 'emake failed.'
+}
+
+src_install() {
+ make_desktop_entry qtiplot qtiplot qtiplot Graphics
+ dobin qtiplot || die 'Binary installation failed.'
+}