summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-09-10 18:31:13 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-09-10 18:31:13 +0000
commit98974ed0516265a5fc1a58c35a04b71d6b0bb9cc (patch)
tree39768e0cc9496871d55ea7ed897dbba485790e33 /sci-visualization/pythonprop
parent[app-admin/logrotate] Dropped mips and x86-fbsd stable keywords and tune flag... (diff)
downloadgentoo-2-98974ed0516265a5fc1a58c35a04b71d6b0bb9cc.tar.gz
gentoo-2-98974ed0516265a5fc1a58c35a04b71d6b0bb9cc.tar.bz2
gentoo-2-98974ed0516265a5fc1a58c35a04b71d6b0bb9cc.zip
Version bump
(Portage version: 2.1.11.14/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/pythonprop')
-rw-r--r--sci-visualization/pythonprop/ChangeLog9
-rw-r--r--sci-visualization/pythonprop/pythonprop-0.11.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sci-visualization/pythonprop/ChangeLog b/sci-visualization/pythonprop/ChangeLog
index 211a0a55f01a..c6527f5479ce 100644
--- a/sci-visualization/pythonprop/ChangeLog
+++ b/sci-visualization/pythonprop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/pythonprop
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pythonprop/ChangeLog,v 1.1 2011/02/06 10:56:55 tomjbe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pythonprop/ChangeLog,v 1.2 2012/09/10 18:31:13 tomjbe Exp $
+
+*pythonprop-0.11 (10 Sep 2012)
+
+ 10 Sep 2012; Thomas Beierlein <tomjbe@gentoo.org> +pythonprop-0.11.ebuild:
+ Version bump
*pythonprop-0.10 (06 Feb 2011)
diff --git a/sci-visualization/pythonprop/pythonprop-0.11.ebuild b/sci-visualization/pythonprop/pythonprop-0.11.ebuild
new file mode 100644
index 000000000000..022e3e71c5f9
--- /dev/null
+++ b/sci-visualization/pythonprop/pythonprop-0.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/pythonprop/pythonprop-0.11.ebuild,v 1.1 2012/09/10 18:31:13 tomjbe Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Scripts to prepare and plot VOACAP propagation predictions"
+HOMEPAGE="http://www.qsl.net/hz1jw/pythonprop"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sci-electronics/voacapl
+ dev-python/matplotlib[gtk]
+ dev-python/basemap"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS TODO || die
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}