summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2012-03-22 10:15:45 +0000
committerTony Vroon <chainsaw@gentoo.org>2012-03-22 10:15:45 +0000
commit2f248d239ea9ccc7f0d59566e091fb0bee76c1c0 (patch)
treeda5e4ab908d8120fbce140b96e5f24d47cdf92fc /sci-visualization/nonolith-connect
parentNeed zip to build asc. Bug #409113 (diff)
downloadgentoo-2-2f248d239ea9ccc7f0d59566e091fb0bee76c1c0.tar.gz
gentoo-2-2f248d239ea9ccc7f0d59566e091fb0bee76c1c0.tar.bz2
gentoo-2-2f248d239ea9ccc7f0d59566e091fb0bee76c1c0.zip
New upstream release which implements a REST API and adds advanced trigger modes for future use. Udev rule has been removed, not needed due to USB initial group on nonolith-connect user.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/nonolith-connect')
-rw-r--r--sci-visualization/nonolith-connect/ChangeLog10
-rw-r--r--sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch70
-rw-r--r--sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild49
3 files changed, 128 insertions, 1 deletions
diff --git a/sci-visualization/nonolith-connect/ChangeLog b/sci-visualization/nonolith-connect/ChangeLog
index f6611e6cfb1d..e20adbe9a4bf 100644
--- a/sci-visualization/nonolith-connect/ChangeLog
+++ b/sci-visualization/nonolith-connect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-visualization/nonolith-connect
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/nonolith-connect/ChangeLog,v 1.1 2012/02/21 13:41:48 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/nonolith-connect/ChangeLog,v 1.2 2012/03/22 10:15:45 chainsaw Exp $
+
+*nonolith-connect-1.1 (22 Mar 2012)
+
+ 22 Mar 2012; Tony Vroon <chainsaw@gentoo.org>
+ +files/1.1-cflags-respect.patch, +nonolith-connect-1.1.ebuild:
+ New upstream release which implements a REST API and adds advanced trigger
+ modes for future use. Udev rule has been removed, not needed due to USB
+ initial group on nonolith-connect user.
*nonolith-connect-1.0.1 (21 Feb 2012)
diff --git a/sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch b/sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch
new file mode 100644
index 000000000000..c6b04c5fe339
--- /dev/null
+++ b/sci-visualization/nonolith-connect/files/1.1-cflags-respect.patch
@@ -0,0 +1,70 @@
+diff -uNr nonolith-connect-1.1.ORIG/SConstruct nonolith-connect-1.1/SConstruct
+--- nonolith-connect-1.1.ORIG/SConstruct 2012-03-22 10:02:11.398944187 +0000
++++ nonolith-connect-1.1/SConstruct 2012-03-22 10:05:23.149936839 +0000
+@@ -1,7 +1,21 @@
+ import sys, os, shutil
++import SCons.Util
+
+ env = Environment()
+
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++if "$CCFLAGS" in env['CXXCOM']:
++ env['CXXCOM'] = env['CXXCOM'].replace("$CCFLAGS","")
++
+ opts = Variables()
+ opts.Add(BoolVariable("mingwcross", "Cross-compile with mingw for Win32", 0))
+ opts.Add(BoolVariable("boost_static", "Statically link against Boost", 0))
+@@ -95,8 +109,7 @@
+ sources = Glob('*.cpp') + Glob('streaming_device/*.cpp') + ['cee/cee.cpp', 'bootloader/bootloader.cpp']
+
+ json = env.Library('json',
+- Glob('libjson/Source/*.cpp'),
+- CCFLAGS = "-c -O3 -ffast-math -fexpensive-optimizations".split()
++ Glob('libjson/Source/*.cpp')
+ )
+
+ websocketpp = env.Library('websocketpp', ['websocketpp/src/'+i for i in [
+@@ -107,7 +120,7 @@
+ 'websocket_session.cpp',
+ 'sha1/sha1.cpp',
+ 'base64/base64.cpp'
+- ]], CCFLAGS=['-g', '-O3'])
++ ]])
+
+
+ libusb_cflags = []
+@@ -121,14 +134,22 @@
+ libusb_os = ['os/poll_windows.c', 'os/windows_usb.c', 'os/threads_windows.c']
+ libusb_cflags += ['-D OS_WINDOWS', '-DPOLL_NFDS_TYPE=unsigned int', '-D WINVER=0x0501']
+
+-libusb = env.Library('libusb_nonolith', ['libusb/libusb/'+i for i in [
++env_libusb = env.Clone()
++env_libusb.Append(CPPFLAGS=libusb_cflags)
++env_libusb.Append(CFLAGS=['-Ilibusb', '-Ilibusb/libusb'])
++
++libusb = env_libusb.Library('libusb_nonolith', ['libusb/libusb/'+i for i in [
+ 'core.c',
+ 'descriptor.c',
+ 'io.c',
+ 'sync.c',
+- ]+libusb_os], CFLAGS=['-g', '-O3', '-Ilibusb', '-Ilibusb/libusb']+libusb_cflags)
++ ]+libusb_os])
+
+
+ libs += boostlibs
+
+-env.Program('nonolith-connect', sources, LIBS=libs, CCFLAGS=['-Wall', '-g', '-O3', '-Ilibusb', '-Iwebsocketpp/src', '-shared'], FRAMEWORKS=frameworks)
++env_main = env.Clone()
++env_main.Append(CXXFLAGS=['-Ilibusb', '-Iwebsocketpp/src', '-Wall'])
++#env_main.Append(LINKFLAGS=['-shared'])
++env_main.Program('nonolith-connect', sources, LIBS=libs, FRAMEWORKS=frameworks)
++
diff --git a/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild b/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild
new file mode 100644
index 000000000000..798b43128391
--- /dev/null
+++ b/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild,v 1.1 2012/03/22 10:15:45 chainsaw Exp $
+
+EAPI=4
+
+inherit base scons-utils toolchain-funcs
+
+DESCRIPTION="CEE (Control - Experiment - Explore) analog multitool"
+HOMEPAGE="http://www.nonolithlabs.com/cee/"
+SRC_URI="http://apps.nonolithlabs.com/download/source/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ sys-fs/udev"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-cflags-respect.patch" )
+
+pkg_setup() {
+ tc-export CC CXX
+ enewuser nonolithd -1 -1 /dev/null usb
+}
+
+src_configure() {
+ myesconsargs=(
+ boost_static=0
+ )
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ dobin nonolith-connect
+ newinitd "${FILESDIR}/nonolith-connect.initd" nonolith-connect
+}
+
+pkg_postinst() {
+ einfo "Consider adding nonolith-connect to the default runlevel."
+ einfo "Please connect your CEE hardware, start nonolith-connect "
+ einfo "using the init script provided and then visit:"
+ einfo "http://apps.nonolithlabs.com/setup"
+}