summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-29 09:44:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-29 09:44:30 +0000
commita38ce55d804b4117ba9ebb693754aeec5ff721c9 (patch)
treef71ba798f026959b5aa7c2330861f1c66f4428d1 /sci-visualization/hippodraw
parentvget initial commit (tool for veoh.com videos) (diff)
downloadgentoo-2-a38ce55d804b4117ba9ebb693754aeec5ff721c9.tar.gz
gentoo-2-a38ce55d804b4117ba9ebb693754aeec5ff721c9.tar.bz2
gentoo-2-a38ce55d804b4117ba9ebb693754aeec5ff721c9.zip
Removed old versions
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'sci-visualization/hippodraw')
-rw-r--r--sci-visualization/hippodraw/ChangeLog6
-rw-r--r--sci-visualization/hippodraw/hippodraw-1.19.1.ebuild117
-rw-r--r--sci-visualization/hippodraw/hippodraw-1.21.3.ebuild119
3 files changed, 5 insertions, 237 deletions
diff --git a/sci-visualization/hippodraw/ChangeLog b/sci-visualization/hippodraw/ChangeLog
index 123bde0e6237..e1d0248cec35 100644
--- a/sci-visualization/hippodraw/ChangeLog
+++ b/sci-visualization/hippodraw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/hippodraw
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/ChangeLog,v 1.8 2008/07/27 22:25:40 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/ChangeLog,v 1.9 2008/08/29 09:44:30 bicatali Exp $
+
+ 29 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -hippodraw-1.19.1.ebuild, -hippodraw-1.21.3.ebuild:
+ Removed old versions
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> hippodraw-1.19.1.ebuild,
hippodraw-1.21.3.ebuild, hippodraw-1.21.3-r1.ebuild:
diff --git a/sci-visualization/hippodraw/hippodraw-1.19.1.ebuild b/sci-visualization/hippodraw/hippodraw-1.19.1.ebuild
deleted file mode 100644
index 8fd9d6875148..000000000000
--- a/sci-visualization/hippodraw/hippodraw-1.19.1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/hippodraw-1.19.1.ebuild,v 1.5 2008/07/27 22:25:40 carlo Exp $
-
-EAPI=1
-
-inherit eutils qt3
-
-MY_PN=HippoDraw
-
-DESCRIPTION="Highly interactive data analysis Qt environment for C++ and python"
-HOMEPAGE="http://www.slac.stanford.edu/grp/ek/hippodraw/"
-SRC_URI="ftp://ftp.slac.stanford.edu/users/pfkeb/${PN}/${MY_PN}-${PV}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="root fits numarray doc"
-
-# minuit: included in root-5, but standalone cheaper to build
-# qt4 not implemented:
-# - won't work with sip on amd64
-# - is still under testing
-# opengl: completely buggy
-# wcslib: not yet implemented (wcslib has nasty build system)
-# sip: still buggy (gcc411 issue?)
-
-RDEPEND=">=dev-lang/python-2.3
- >=dev-libs/boost-1.32
- x11-libs/qt:3
- numarray? ( dev-python/numarray )
- fits? ( sci-libs/cfitsio
- numarray? ( dev-python/pyfits ) )
- !root? ( >=sci-libs/minuit-5 )
- root? ( >=sci-physics/root-5 )"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-pkg_setup() {
- # need python threads (see bug #224269)
- if ! built_with_use dev-lang/python threads; then
- die "hippodraw needs dev-lang/python with USE=\"threads\""
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- local docdir=/usr/share/doc/${PF}
- # fix the install doc directory to gentoo's one
- sed -i \
- -e "s:\$(pkgdatadir)/html:${docdir}/html:" \
- doc/Makefile.in
-
- # fix an extra DESTDIR inherited from Makefile.am
- sed -i \
- -e "s:\$(DESTDIR)\$(pkgdatadir)/examples:${docdir}/examples:" \
- examples/Makefile.in
-
- # since we do not slot, remove version name in includes
- sed -i \
- -e 's/$(pkgincludedir)-$(VERSION)/$(pkgincludedir)/' \
- */Makefile.in
-
- #if use sip; then
- # sed -i \
- # -e "s:/usr/local:/usr:g"\
- # -e "" \
- # sip/Makefile.in
- #fi
-}
-
-src_compile() {
-
- local myconf="--with-boost-include=/usr/include"
- myconf="${myconf} --with-Qt-include-dir=/usr/qt/3/include"
- myconf="${myconf} --with-Qt-lib-dir=/usr/qt/3/$(get_libdir)"
- myconf="${myconf} --with-Qt-bin-dir=/usr/qt/3/bin"
- myconf="${myconf} --with-boost-lib=/usr/$(get_libdir)"
- myconf="${myconf} --with-boost-libname=boost_python"
- #built_with_use dev-libs/boost threads && myconf="${myconf}-mt"
-
- if use minuit && ! use root; then
- myconf="${myconf} --with-minuit2-include=/usr/include"
- myconf="${myconf} --with-minuit2-lib=/usr/$(get_libdir)"
- fi
-
- if use root; then
- myconf="${myconf} --with-root-include=/usr/include/root"
- myconf="${myconf} --with-root-lib=/usr/$(get_libdir)/root"
- fi
-
- if use fits; then
- myconf="${myconf} --with-cfitsio-include=/usr/include"
- myconf="${myconf} --with-cfitsio-lib=/usr/$(get_libdir)"
- fi
-
- econf \
- $(use_enable numarray numarraybuild) \
- $(use_enable doc help) \
- ${myconf} || die "econf failed"
- # qtui failed with -j2, so build it first with -j1
- emake -j1 -C qtui || die "make qtui failed"
- emake || die "emake failed"
- if use doc; then
- make docs || die "make docs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- make_desktop_entry hippodraw HippoDraw hippoApp \
- Science "/usr/share/${MY_PN}"
- dodoc README DISCLAIMER.rtf
-}
diff --git a/sci-visualization/hippodraw/hippodraw-1.21.3.ebuild b/sci-visualization/hippodraw/hippodraw-1.21.3.ebuild
deleted file mode 100644
index c4dc241b4fc6..000000000000
--- a/sci-visualization/hippodraw/hippodraw-1.21.3.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/hippodraw-1.21.3.ebuild,v 1.5 2008/07/27 22:25:40 carlo Exp $
-
-EAPI=1
-
-inherit eutils qt3
-
-MY_PN=HippoDraw
-
-DESCRIPTION="Highly interactive data analysis Qt environment for C++ and python"
-HOMEPAGE="http://www.slac.stanford.edu/grp/ek/hippodraw/"
-SRC_URI="ftp://ftp.slac.stanford.edu/users/pfkeb/${PN}/${MY_PN}-${PV}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="root fits numpy doc"
-
-# minuit: included in root-5, but standalone cheaper to build
-# qt4 not implemented:
-# - won't work with sip on amd64
-# - is still under testing
-# opengl: completely buggy
-# wcslib: not yet implemented (wcslib has nasty build system)
-# sip: still buggy (gcc411 issue?)
-
-RDEPEND=">=dev-lang/python-2.3
- >=dev-libs/boost-1.32
- x11-libs/qt:3
- numpy? ( dev-python/numpy )
- fits? ( sci-libs/cfitsio
- numpy? ( dev-python/pyfits ) )
- !root? ( >=sci-libs/minuit-5 )
- root? ( >=sci-physics/root-5 )"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-pkg_setup() {
- # need python threads (see bug #224269)
- if ! built_with_use dev-lang/python threads; then
- die "hippodraw needs dev-lang/python with USE=\"threads\""
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc4.3.patch
- epatch "${FILESDIR}"/${P}-numarray.patch
- epatch "${FILESDIR}"/${P}-test-fix.patch
-
- local docdir=/usr/share/doc/${PF}
- # fix the install doc directory to gentoo's one
- sed -i \
- -e "s:\$(pkgdatadir)/html:${docdir}/html:" \
- doc/Makefile.in
-
- # fix an extra DESTDIR inherited from Makefile.am
- sed -i \
- -e "s:\$(DESTDIR)\$(pkgdatadir)/examples:${docdir}/examples:" \
- examples/Makefile.in
-
- # since we do not slot, remove version name in includes
- sed -i \
- -e 's/$(pkgincludedir)-$(VERSION)/$(pkgincludedir)/' \
- */Makefile.in
-
- #if use sip; then
- # sed -i \
- # -e "s:/usr/local:/usr:g"\
- # -e "" \
- # sip/Makefile.in
- #fi
-}
-
-src_compile() {
- local myconf="--with-boost-include=/usr/include"
- myconf="${myconf} --with-boost-lib=/usr/$(get_libdir)"
- myconf="${myconf} --with-boost-libname=boost_python"
- myconf="${myconf} --with-minuit2-include=/usr/include"
- myconf="${myconf} --with-minuit2-lib=/usr/$(get_libdir)"
- myconf="${myconf} --disable-numarraybuild"
- #built_with_use dev-libs/boost threads && myconf="${myconf}-mt"
-
- myconf="${myconf} --with-Qt-include-dir=/usr/qt/3/include"
- myconf="${myconf} --with-Qt-lib-dir=/usr/qt/3/$(get_libdir)"
- myconf="${myconf} --with-Qt-bin-dir=/usr/qt/3/bin"
-
- if use root; then
- myconf="${myconf} --with-root-include=/usr/include/root"
- myconf="${myconf} --with-root-lib=/usr/$(get_libdir)/root"
- fi
-
- if use fits; then
- myconf="${myconf} --with-cfitsio-include=/usr/include"
- myconf="${myconf} --with-cfitsio-lib=/usr/$(get_libdir)"
- fi
-
- econf \
- $(use_enable numpy numpybuild) \
- $(use_enable doc help) \
- ${myconf} || die "econf failed"
- # qtui failed with -j2, so build it first with -j1
- emake -j1 -C qtui || die "make qtui failed"
- emake || die "emake failed"
- if use doc; then
- make docs || die "make docs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- make_desktop_entry hippodraw HippoDraw hippoApp \
- Science "/usr/share/${MY_PN}"
- dodoc README DISCLAIMER.rtf
-}