summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-19 20:58:38 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-19 20:58:38 +0000
commit243183bc817a9dcf1011e37241a5f82580762d27 (patch)
tree8ea288a60e8be947b4467ed6d593192a3e5dbbcc /sci-visualization/fityk
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-243183bc817a9dcf1011e37241a5f82580762d27.tar.gz
gentoo-2-243183bc817a9dcf1011e37241a5f82580762d27.tar.bz2
gentoo-2-243183bc817a9dcf1011e37241a5f82580762d27.zip
Fix for multiple ABI installation
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/fityk')
-rw-r--r--sci-visualization/fityk/fityk-0.9.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-visualization/fityk/fityk-0.9.2.ebuild b/sci-visualization/fityk/fityk-0.9.2.ebuild
index 87888487aaf8..363085f7638f 100644
--- a/sci-visualization/fityk/fityk-0.9.2.ebuild
+++ b/sci-visualization/fityk/fityk-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/fityk/fityk-0.9.2.ebuild,v 1.1 2010/05/19 18:51:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/fityk/fityk-0.9.2.ebuild,v 1.2 2010/05/19 20:58:38 jlec Exp $
EAPI="3"
@@ -35,6 +35,7 @@ RDEPEND="${CDEPEND}
RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
+
has_version "<dev-libs/boost-1.37" && \
sed -i -e 's:impl/directives.hpp:directives.ipp:g' \
"${S}/src/optional_suffix.h"
@@ -68,6 +69,7 @@ src_compile() {
PYTHON_LDFLAGS="$(python_get_library -l)" \
PYTHON_SITE_PKG="$(python_get_sitedir)" \
PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
_fityk.la
}
python_execute_function -s --source-dir swig compilation